P1663,P1667,P1668 crank-no start - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-23-2017, 05:19 PM Thread Starter
PSN Newb
 
Join Date: Mar 2013
Posts: 10
P1663,P1667,P1668 crank-no start

Trying to fix 1997 f250 cranks, no start . dtc's p1663,p1667,p1668.I have an A&E scanner and a 104 pin breakout out box and need guidance. Truck has been down since 1/3/17. I live in CT and work on truck in driveway, so I have been at the mercy of the weather. I am following the U series print out for testing and get to U8 where it asks to connect NGS scan tool which I do not have. Any help would be greatly appreciated. John
11perry is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-23-2017, 06:35 PM
PSN Veteran
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 5,373
Re: P1663,P1667,P1668 crank-no start

Interpreting the descriptions here - 1997 Powertrain Control System Electronics Diagnostic Guide - 1994-1997 Power Stroke FAQ - I would be checking the continuity of the wires between the PCM and IDM, and checking IDM ground.

From the "don't overlook the obvious" department - have you removed the IDM and given it a good shake to listen for sloshing water?
madpogue is offline  
post #3 of 3 (permalink) Old 03-23-2017, 08:08 PM Thread Starter
PSN Newb
 
Join Date: Mar 2013
Posts: 10
Re: P1663,P1667,P1668 crank-no start

Truck died. Had it towed home. Fuel bowl heater shorted out. Blew fuse 22. Ordered new heater, fuel bowl o-ring kit.Drained fuel bowl and had oil in fuel. Ordered fuel injector o-ring kit. Instaled bowl heater and o-rings, reinstalled in truck. Pulled injectors, new o-rings, reinstalled. Purged air by leaving glow plugs out and cranked over few times. Cranks no start. Cranked alot, no start, no smoke from tail pipe.Ordered refurbished IDM. Cranked no start, no smoke out tail pipe.Ordered refurbished PCM, no start, no smoke out tail pipe. Bought 1 new battery, the other checked out fine. No luck. New glow plugs, glow plug relay ,new cam sensor. New IDM,PCM relays. UVC wiring checked out ok. Tested wiring from IDM connector to injector plug ends ok. HPOP level ok. Engine oil level ok. Half tank of fuel each tank. WTS on. Bought A&E scanner and 104 pin breakout box. Ohm readings from IDM to PCM ok. Need help from hear.
11perry is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome