No Start Grrr... SOLVED - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-30-2009, 06:02 AM Thread Starter
97 OBS PSD
 
Aaron Ford's Avatar
 
Join Date: Oct 2008
Location: Fairmont, WV
Posts: 128
No Start Grrr... SOLVED

It was the HPOP. I found a new IPR and HPOP at a local junkyard (Jordans). Paid $50 for the IPR and $250 for the pump. The pump is a 17 degree with a 2006 build date. My old one had a casting date of 1998. Installation was easy and required no new gaskets or o-rings. Sealed right up. Runs like a champ. Haven't seen the performance side, but I also have stock injectors. Gonna put a load behind it and see what it will pull.

Aaron

97 PSD 4X4 250K, Ron Holland/Banks 1.00 A/R, EBPV Delete, 3" DP, Kitty Delete, PHP Phoenix 6 POS, 140V IDM, Autometers on the Pillar,4" Intake, 17 degree SD pump, 18-20 psi depending on setting...
Aaron Ford is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome