Having a bad weekend - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 07-27-2009, 02:48 AM Thread Starter
got another 7.3
 
smokinford07's Avatar
 
Join Date: Jan 2009
Location: Ky
Posts: 526
Send a message via AIM to smokinford07
Having a bad weekend

Ok, yesterday I was about to leave to go to my grandpa's birthday party, I noticed that the tread had separated from my tire and a huge chunk was missing, so I show up late. The truck pull at the fair was canceled. Someone broke into my truck last night and stole my radio in my own back yard. The door locks on my truck were broke so I got a new set from autozone. I got home and one was broken, I broke the plastic door handle, went and got new locks and another handle. And now I can't get the dang things in right. Can anyone please help me out on what I need to do? Oh and to top it all off, my brother in law broke my new door handle as soon as I got it put on! Sorry it's so long winded, I would just really appreciate some help on the locks, they are manual locks by the way

E99 (Red Truck) 4x4, 7.3 4"DP into 5" Flo-Pro exhaust, DIY tymar, 3/8ths fuel line with a holley blue pump,and a PHP Phoenix (stock, 65t, 80dd, 100 performance, 120race, no start) 140v IDM, 285/75/16 Goodyear Duratracs

E99 (Black Truck) 4x4 7.3, 6 speed with a junked motor right now
smokinford07 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 07-27-2009, 02:50 AM
HI DAD!
 
Join Date: Feb 2009
Location: hoosier state
Posts: 435
Send a message via Yahoo to trigger
Re: Having a bad weekend

drink a beer
trigger is offline  
post #3 of 10 (permalink) Old 07-27-2009, 02:54 AM Thread Starter
got another 7.3
 
smokinford07's Avatar
 
Join Date: Jan 2009
Location: Ky
Posts: 526
Send a message via AIM to smokinford07
Re: Having a bad weekend

or 10

E99 (Red Truck) 4x4, 7.3 4"DP into 5" Flo-Pro exhaust, DIY tymar, 3/8ths fuel line with a holley blue pump,and a PHP Phoenix (stock, 65t, 80dd, 100 performance, 120race, no start) 140v IDM, 285/75/16 Goodyear Duratracs

E99 (Black Truck) 4x4 7.3, 6 speed with a junked motor right now
smokinford07 is offline  
 
post #4 of 10 (permalink) Old 07-27-2009, 02:57 AM
That thing got a Cummins?
 
nasty96's Avatar
 
Join Date: Dec 2008
Posts: 1,229
Re: Having a bad weekend

and forget about it for today. The way your luck seems to be going you need to start on it fresh tomorrow.

Ford makes it
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, I break it
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


1996 F350 CCLB 4x4 Broke Built Auto

2000 Dodge 3500 5 Speed 4x4 450k and Counting

2001 Dodge 3500 6 speed 4x4 Fully loaded
nasty96 is offline  
post #5 of 10 (permalink) Old 07-27-2009, 03:01 AM
Michigan Ice Dog
 
8nout's Avatar
 
Join Date: Jun 2009
Location: Bad Axe, Michigan
Posts: 226
Re: Having a bad weekend

Since your BIL broke the handle, I think he owes you at least a case! And it better be COLD!!

"Alot of the worlds problems can be solved with violence"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

______________
04 F350 6.uhoh 6"lift/ 35" ,warn winches front and back:),the usual stuff
----------------------------
Originally Posted by Cat_Rebel
" So taking her home I was going to have her sit in the middle but I relised that she wouldn't fit. "
8nout is offline  
post #6 of 10 (permalink) Old 07-27-2009, 04:37 AM Thread Starter
got another 7.3
 
smokinford07's Avatar
 
Join Date: Jan 2009
Location: Ky
Posts: 526
Send a message via AIM to smokinford07
Re: Having a bad weekend

well things got worse, neither of the trucks doors would open. Then my father in law got to tinkering with it, got it opened and now I have one door and lock that'll work

E99 (Red Truck) 4x4, 7.3 4"DP into 5" Flo-Pro exhaust, DIY tymar, 3/8ths fuel line with a holley blue pump,and a PHP Phoenix (stock, 65t, 80dd, 100 performance, 120race, no start) 140v IDM, 285/75/16 Goodyear Duratracs

E99 (Black Truck) 4x4 7.3, 6 speed with a junked motor right now
smokinford07 is offline  
post #7 of 10 (permalink) Old 07-27-2009, 05:09 AM
97 OBS PSD
 
Aaron Ford's Avatar
 
Join Date: Oct 2008
Location: Fairmont, WV
Posts: 128
Re: Having a bad weekend

Rotate the vertical rod away from you. It should be very difficult to get the lock assembly and clip on the rod. I fought this for hours. If you rotate the rod so that the lock clips onto the rod easily, it will never fit in the door. The vert rod will be backward. Are you close to North Central WV? I got good at this.

Edit: If you pull the inside door handle cable out and insert a spacer behind the cable head, you might save the next door handle. Mine was running out of travel before the door would open so every time you opened the door the handle would flex against the stop. The spacer fixed this. I think it has to do with cable stretch.

Aaron

97 PSD 4X4 250K, Ron Holland/Banks 1.00 A/R, EBPV Delete, 3" DP, Kitty Delete, PHP Phoenix 6 POS, 140V IDM, Autometers on the Pillar,4" Intake, 17 degree SD pump, 18-20 psi depending on setting...
Aaron Ford is offline  
post #8 of 10 (permalink) Old 07-27-2009, 05:44 AM
PSN Local
 
stroked444's Avatar
 
Join Date: Jun 2009
Posts: 183
Re: Having a bad weekend

had that same problem with my 96' F150 just kept breaking those damn plastic door handles I got a chrome medal door handle off an 84' and my door opened up perfect so i got another one from napa to match and they opened with ease and it looked better then the black plastic too
stroked444 is offline  
post #9 of 10 (permalink) Old 07-27-2009, 07:50 AM
97 OBS PSD
 
Aaron Ford's Avatar
 
Join Date: Oct 2008
Location: Fairmont, WV
Posts: 128
Re: Having a bad weekend

Went right past your place on the Hot Rod Power Tour. I was the guy driving the Powerstroke with the flatbed trailer going down the road with 2000+ hot rods. Stuck out like a sore thumb...

Aaron

97 PSD 4X4 250K, Ron Holland/Banks 1.00 A/R, EBPV Delete, 3" DP, Kitty Delete, PHP Phoenix 6 POS, 140V IDM, Autometers on the Pillar,4" Intake, 17 degree SD pump, 18-20 psi depending on setting...
Aaron Ford is offline  
post #10 of 10 (permalink) Old 07-27-2009, 08:10 AM Thread Starter
got another 7.3
 
smokinford07's Avatar
 
Join Date: Jan 2009
Location: Ky
Posts: 526
Send a message via AIM to smokinford07
Re: Having a bad weekend

I would have love to have seen that, but dang this has been a heck of a weekend. Like I said he got the driver's side lock working, the passenger door still won't open, but at least who ever came in the back yard won't be able to get in the truck now. But here is the baffling part, they only stole the face plate to the radio and didn't take a thing out of any of the other vehicles.

And thank you aaron

E99 (Red Truck) 4x4, 7.3 4"DP into 5" Flo-Pro exhaust, DIY tymar, 3/8ths fuel line with a holley blue pump,and a PHP Phoenix (stock, 65t, 80dd, 100 performance, 120race, no start) 140v IDM, 285/75/16 Goodyear Duratracs

E99 (Black Truck) 4x4 7.3, 6 speed with a junked motor right now
smokinford07 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome