Injector O-ring installation Now No Start - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-18-2009, 07:20 PM Thread Starter
97 OBS PSD
 
Aaron Ford's Avatar
 
Join Date: Oct 2008
Location: Fairmont, WV
Posts: 128
Injector O-ring installation Now No Start

I replaced the injector o-rings, the IPR o-rings, and the fuel lines in the engine valley under the filter housing and now it won't start. I have HPOP pressure (500 plus), 50-60 psi fuel, and have kept the batteries on a 10 amp charger and still no response. No smoke from exhaust. Injectors are clicking.

Thanks In Advance,

Aaron

97 PSD 4X4 250K, Ron Holland/Banks 1.00 A/R, EBPV Delete, 3" DP, Kitty Delete, PHP Phoenix 6 POS, 140V IDM, Autometers on the Pillar,4" Intake, 17 degree SD pump, 18-20 psi depending on setting...
Aaron Ford is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-20-2009, 02:53 AM
PSN Local
 
Join Date: Apr 2009
Location: West KY
Posts: 227
Re: Injector O-ring installation Now No Start

Check to see if you are getting fuel to the filter as a start.

1994 F350 Dually w/Powerstroke M.T. 101,000 miles
JDOliver is offline  
post #3 of 8 (permalink) Old 07-20-2009, 03:16 AM
PSN Newb
 
Join Date: Jan 2009
Posts: 47
Re: Injector O-ring installation Now No Start

On my 2000 you have to fill the oil rail with oil and prime the fuel rails with fuel by beading threm.

2000 F-350 7.3 PSD 4X4 exstended cab 200 K Wicked wheel" open stacks, Banks power elbow, New GP New Injectors
Channing is offline  
 
post #4 of 8 (permalink) Old 07-20-2009, 02:05 PM
PSN Local
 
blageurt's Avatar
 
Join Date: Sep 2008
Location: Toronto , Ontario
Posts: 421
Re: Injector O-ring installation Now No Start

You still have air in the system. Just keep doing what you are doing , bieng carefull not to overheat the starter . Eventually it will start. It just takes a while
blageurt is offline  
post #5 of 8 (permalink) Old 07-20-2009, 07:49 PM Thread Starter
97 OBS PSD
 
Aaron Ford's Avatar
 
Join Date: Oct 2008
Location: Fairmont, WV
Posts: 128
Re: Injector O-ring installation Now No Start

I bled the fuel lines on the back of the heads and got white puffs out of the exhaust. To chicken to crank for too long...

Gonna get back to it this evening,

Aaron

97 PSD 4X4 250K, Ron Holland/Banks 1.00 A/R, EBPV Delete, 3" DP, Kitty Delete, PHP Phoenix 6 POS, 140V IDM, Autometers on the Pillar,4" Intake, 17 degree SD pump, 18-20 psi depending on setting...
Aaron Ford is offline  
post #6 of 8 (permalink) Old 07-21-2009, 01:56 AM
OEM Moderator
 
Tom S's Avatar
 
Join Date: Jul 2007
Location: Littleton, Colo
Posts: 9,381
Send a message via AIM to Tom S
Re: Injector O-ring installation Now No Start

I would throw a set of jumper cables on there. Sounds to me like she is almost ready to start.
Tom S is offline  
post #7 of 8 (permalink) Old 07-21-2009, 02:06 AM
PSN Local
 
robp823's Avatar
 
Join Date: May 2008
Posts: 343
Re: Injector O-ring installation Now No Start

yea your close if ya want check the HPOP resevoir and make sure its full.
robp823 is offline  
post #8 of 8 (permalink) Old 07-21-2009, 10:19 PM
shake and bake baby!!
 
stroked350's Avatar
 
Join Date: Jul 2008
Location: VA Beach
Posts: 355
Re: Injector O-ring installation Now No Start

stand by for a smoke show. sounds like you just gotta keep cranking her.
stroked350 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome