miss in motor - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-07-2009, 04:04 PM Thread Starter
 
Join Date: Jan 2009
Posts: 20
miss in motor

i have a miss in my motor but it doesent happen all the time. i lose some power and my truck gets a shake to it. you can def hear it too. past few days white smokes when starts. any ideas let me know. what would happen if an o ring in an injector went bad?
97strokethis is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-09-2009, 03:56 AM
PSN Local
 
The Fireman's Avatar
 
Join Date: Apr 2009
Location: Somerset, Ky
Posts: 173
Re: miss in motor

Check the UVCH first and I would check the EBPV just to be safe.

Bryan

97 F250 SC LB 4x4 Auto 368,000 miles, AD's, 3in down pipe, Straight Pipe,EBPV deleted, DIY Intake, Racer X converter and valve body, Beans tunes
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
The Fireman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome