Bad Injector O-Rings ?? - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-26-2011, 09:07 PM Thread Starter
PSN Local
 
StrokinSince97's Avatar
 
Join Date: Sep 2011
Posts: 136
Bad Injector O-Rings ??

My 97 f-250 with 155,000 miles is smoking a little bit of white/blue smoke at an idle and when i rev it to high rpms it blows a lot of white/blue smoke out the tailpipe. I've read that this is most likely the injector o rings. Does this sound about right?? Also where can I get the kit for a good price?? And I'm not sure on how to make sure all the oil is out of the system like everyone is saying. Can I just take it all apart put it back together then remove the glow plugs and turn it over to blow out all the oil?? Will that clean out all the oil?? Or what should I do ?
StrokinSince97 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-26-2011, 09:39 PM
PSN Local
 
cobrabc1993's Avatar
 
Join Date: Jun 2011
Location: Topeka Ks
Posts: 296
Re: Bad Injector O-Rings ??

Usually, the most common sign of bad orings is oil consumption.. U will notice this also by your fuel turning blackish instead of blue. Just pull your fuel filter, and look and see if your fuel is good and blueish, or has a black tint too it.... This is due to hi psi oil (500-3000psi) feeding the upper portion of the injector. Below the hi psi orings, is the inlet to the fuel portion of the injector. Usually (35-50)psi. The oil pushes past the the orings and mixes with the diesel fuel. Some will get burned with the diesel fuel, the other goes to the return in your fuel tank, hence the black fuel....... Another thing is, internally worn injectors can cause this same phenomenah....... Back to your issue... It is possible for the upper most orings, on the oil feed side to the injectors,to bleed past into your valvecover rocker arm area, which could cause an injector to possibly not fire as hard, which could lead to some smoke, from an injector not recieving full injection oil pressure....
cobrabc1993 is offline  
post #3 of 8 (permalink) Old 10-26-2011, 10:02 PM
PSN Veteran
 
zilla68's Avatar
 
Join Date: Jan 2009
Location: Moore, Oklahoma
Posts: 1,557
Re: Bad Injector O-Rings ??

dieselorings.com has them and he is a great guy

Chris

Moore, Oklahoma



1996 Ford F350 4x4 Crew Cab PSD
6637 tymar
285-75-16 BFG All Terrains/Weld Wheels
3:55 gears
Automatic with billet convertor, tugger and alto discs
New Gearhead Tunes:
1 heavy tow
2 stealth mode
3 tow/econ
4 street perf
5 all out
6 high idle
1.0 housing
exhaust
zilla68 is offline  
 
post #4 of 8 (permalink) Old 10-27-2011, 03:36 AM
PSN Local
 
powerstroker66's Avatar
 
Join Date: Mar 2011
Location: pipersville, PA
Posts: 326
Re: Bad Injector O-Rings ??

Are you burning and coolant? my guess would be bad O-rings but if there is white smoke then that makes me think maybe injector cups... just an idea..but if there bad its usually alot more white smoke.... just watch your fluid levels see if you can narrow it down. Check your coolant and make sure it doesnt smell like diesel fuel to take injector cups out of the picture.
powerstroker66 is offline  
post #5 of 8 (permalink) Old 10-27-2011, 09:48 PM Thread Starter
PSN Local
 
StrokinSince97's Avatar
 
Join Date: Sep 2011
Posts: 136
Re: Bad Injector O-Rings ??

Well I dont think there is oil in my fuel filter and I will have to check but I dont think my coolant has any fuel in it either. Ill have to check again though and make sure thanks a lot for the info. I've had the truck a couple of months now and havent really driven it besides out in my field I start it all the time but it needs an oil pan bad so I havent had it out on the road yet. Not sure if since I dont drive it this will make a difference on finding out whats going on. It seems to start fine and from what I can tell it idles nicely jus has a little tiny bit of smoke at an idle and then blowes clouds of it when i rev it at high rpm. Not very familar with diesels his is my first one so I jus dont kno
StrokinSince97 is offline  
post #6 of 8 (permalink) Old 10-27-2011, 09:50 PM Thread Starter
PSN Local
 
StrokinSince97's Avatar
 
Join Date: Sep 2011
Posts: 136
Re: Bad Injector O-Rings ??

Also I noticed a fuel leak the other day running down the backside of the motor and cant seem to find where the heckk thats coming from doesnt look like the fuel filter but idk. Could that be causing smoke maybe ???
StrokinSince97 is offline  
post #7 of 8 (permalink) Old 10-28-2011, 05:31 AM
PSN Local
 
Join Date: Mar 2010
Location: Middle GA
Posts: 446
Re: Bad Injector O-Rings ??

As far as the fuel leak, look to the the back of the heads where the fuel lines connect to the head. Or the fuel pump. Does it leak into the valley, or just down the back of the motor?

-John-
1996 F-250 Ext Cab Long Bed 4x4 w/ a few mods
jmsmith76 is offline  
post #8 of 8 (permalink) Old 10-31-2011, 04:25 AM
PSN Local
 
powerstroker66's Avatar
 
Join Date: Mar 2011
Location: pipersville, PA
Posts: 326
Re: Bad Injector O-Rings ??

Anyone mention turbo seals? My bosses wife blew the turbo seals out on her 7.3 SD and it thing did exactly what your saying...pull the down pipe back from turbo and see if there is excess oil in/on/around it...just an idea...and the fuel leak might be the O-ring in the banjo fitting on the back side of the fuel pump good luck!
powerstroker66 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome