OBD2 problems, Check Engine light on! - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-06-2011, 01:21 AM Thread Starter
PSN Newb
 
Strokin In Texas's Avatar
 
Join Date: Aug 2011
Location: Dallas TX
Posts: 17
Question OBD2 problems, Check Engine light on!

I cant pull codes! I've used all kinds of scanners including an auto enjunity, and none of them can connect! I'm at a loss! I've got power to both cigarette lighters and it seems I have it to the OBD2 port. With the cheaper scanners, I tried scanning it when it was running and it killed the truck so I know there is some sort of interaction, but I cant figure out what the deal is.

It used to come on only once in a while when the motor was cold, but now it is on all the time. It has a lope idle randomly at stop lights, if I let the clutch out and move forward a few feet it smooths out. Some times it runs just fine. It seems to do it less when my chip is in the stock position.

If anyone has any ideas I would be grateful! It has been about 2,500 miles since my oil change. (Rotella 15-40w and Lucas oil additive)

1996 F-350 XLT 4X4 CREW CAB LONG BED
Strokin In Texas is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-06-2011, 08:14 PM
PSN Veteran
 
Patrick Feeley's Avatar
 
Join Date: Mar 2008
Location: Tehachapi, CA
Posts: 2,854
Re: OBD2 problems, Check Engine light on!

How does it run with the chip completely removed? Cheers!

97 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, Ext Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD: 94 F350 CC DRW PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, 3Ē DP, Bilsteins, $12 AIC, Coolant Filter, Explorer O/H Console, Trans Temp, Boost, and Pyro, Pedestal Mod, Gutted EBPV
Patrick Feeley is offline  
post #3 of 8 (permalink) Old 10-06-2011, 08:24 PM
PSN Veteran
 
Bugman's Avatar
 
Join Date: Aug 2007
Location: Gypsum, Co
Posts: 5,420
Re: OBD2 problems, Check Engine light on!

I agree, pull the chip and see how the truck runs.

96 F250 XLT 4x4, 4:10 gears, 5 speed, Tymar intake and HX hose, downpipe, pyro and boost guages, coolant filter, Luc clutch
Bugman is offline  
 
post #4 of 8 (permalink) Old 10-14-2011, 03:37 PM Thread Starter
PSN Newb
 
Strokin In Texas's Avatar
 
Join Date: Aug 2011
Location: Dallas TX
Posts: 17
Re: OBD2 problems, Check Engine light on!

Pulled the chip, same problem. It ran just like it does when its on the stock tune, check engine light was still on.

I also put a different CPS sensor in, no change.

I put a new air filter on (mine was pretty dirty) and it ran a bit smoother and spools a bit quicker, but still has a rough idle at times and has the check engine light on.

Thanks for any more input! I would really like to figure out why the obd2 scanner doesn't work. Any ideas on how to fix that? Any wright ups on how to test or diag it?

1996 F-350 XLT 4X4 CREW CAB LONG BED
Strokin In Texas is offline  
post #5 of 8 (permalink) Old 10-14-2011, 05:59 PM
PSN Veteran
 
Cratos's Avatar
 
Join Date: Jan 2008
Location: FL
Posts: 2,438
Re: OBD2 problems, Check Engine light on!

you prob need your pcm flashed like my bud did, to get the OB2 port to work his was a 96 too.

Blue 2012 XLT SCLB 4X4 , 38,550 miles, 3:55's & 18's Camper and Tow packages. Edge insight, Airlift Wireless compressor & Air Bag set-up, Dieslesite filter.
Cratos is offline  
post #6 of 8 (permalink) Old 10-15-2011, 12:36 AM Thread Starter
PSN Newb
 
Strokin In Texas's Avatar
 
Join Date: Aug 2011
Location: Dallas TX
Posts: 17
Re: OBD2 problems, Check Engine light on!

How and where do I get that done?

1996 F-350 XLT 4X4 CREW CAB LONG BED
Strokin In Texas is offline  
post #7 of 8 (permalink) Old 10-15-2011, 01:09 AM
PSN Local
 
Join Date: Mar 2010
Location: Middle GA
Posts: 446
Re: OBD2 problems, Check Engine light on!

Should be able to have the dealer do it

-John-
1996 F-250 Ext Cab Long Bed 4x4 w/ a few mods
jmsmith76 is offline  
post #8 of 8 (permalink) Old 10-15-2011, 01:41 AM
PSN Veteran
 
Bugman's Avatar
 
Join Date: Aug 2007
Location: Gypsum, Co
Posts: 5,420
Re: OBD2 problems, Check Engine light on!

I have herd of the 94.5's and 95's needing to be flashed but not the 96's.

Mine was built in May of 96 and it works fine. You may want to check with a dealer if you are friendly with one.

96 F250 XLT 4x4, 4:10 gears, 5 speed, Tymar intake and HX hose, downpipe, pyro and boost guages, coolant filter, Luc clutch
Bugman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome