bad injectors? - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 05-24-2011, 09:20 PM Thread Starter
PSN Local
 
97Stroker13's Avatar
 
Join Date: Dec 2010
Location: south florida
Posts: 418
bad injectors?

when i was driving my truck today i noticed a major power loss. While i was slowing down to make a left, turn the idle dropped, and got really sloppy. It was idling very rough and had no power. i looked to the see if the CEL came on, and it didnt. I drove it all the way home and it never came on. When i got it home, i popped the hood while it was running, and noticed that the "knocking" was harder on the passenger's side than it was on the driver's side. Im not sure if there was something in the fuel lines that may have clogged the injectors. The previous owner said that he had to drop the rear fuel tank becasue of bad diesel one time. Not sure if this is the same problem. Im gussing it may be an injector problem. It is not my lift pump, i replaced that a few months ago.

What do you guys think?

Thanks, brandon

1997 Ford F-250 SCLB
1.00 A/R exhaust housing
TS chip w/ Swamps tunes
6637 intake
4 inch turbo back exhaust
Single disc converter,billet backplate
B&M Trans cooler
BTS valve body w/transgo shiftplate
Wicked wheel 2
Adrenaline HPOP
Swamps diesel 160/100%'s
Irate E-fuel
97Stroker13 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 05-24-2011, 09:50 PM
PSN Veteran
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,561
Re: bad injectors?

Check all the connections to the UVCH.

02 f250
countryboyrob is offline  
post #3 of 14 (permalink) Old 05-24-2011, 09:58 PM Thread Starter
PSN Local
 
97Stroker13's Avatar
 
Join Date: Dec 2010
Location: south florida
Posts: 418
Re: bad injectors?

what and where is that located?

1997 Ford F-250 SCLB
1.00 A/R exhaust housing
TS chip w/ Swamps tunes
6637 intake
4 inch turbo back exhaust
Single disc converter,billet backplate
B&M Trans cooler
BTS valve body w/transgo shiftplate
Wicked wheel 2
Adrenaline HPOP
Swamps diesel 160/100%'s
Irate E-fuel
97Stroker13 is offline  
 
post #4 of 14 (permalink) Old 05-24-2011, 10:02 PM
PSN Veteran
 
jimdawg185's Avatar
 
Join Date: Jan 2009
Location: Grand Rapids, MI
Posts: 1,309
Re: bad injectors?

On the valley side of the valve cover. Large harness plugs into the cover gasket.
jimdawg185 is offline  
post #5 of 14 (permalink) Old 05-24-2011, 10:03 PM
PSN Veteran
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,561
Re: bad injectors?

Top of the motor by the valley, you will see the clips hooked up right below the valve cover. There is 4 wire's per clip, I'm only guessing that maybe one of the clips came off or a bad wire. It's easy to check those and rules out wiring to the harness.

02 f250
countryboyrob is offline  
post #6 of 14 (permalink) Old 05-24-2011, 10:17 PM Thread Starter
PSN Local
 
97Stroker13's Avatar
 
Join Date: Dec 2010
Location: south florida
Posts: 418
Re: bad injectors?

just checked asll of them, besides a little oil, theyre fine, all have good connection.

1997 Ford F-250 SCLB
1.00 A/R exhaust housing
TS chip w/ Swamps tunes
6637 intake
4 inch turbo back exhaust
Single disc converter,billet backplate
B&M Trans cooler
BTS valve body w/transgo shiftplate
Wicked wheel 2
Adrenaline HPOP
Swamps diesel 160/100%'s
Irate E-fuel
97Stroker13 is offline  
post #7 of 14 (permalink) Old 05-24-2011, 10:27 PM
PSN Local
 
bad12jr's Avatar
 
Join Date: Oct 2010
Posts: 90
Re: bad injectors?

Could have a wire rubbed through under the valve cover. Had a buddies do similar. Any smoke. Also you can unplug the front plug on the passenger and start it. See if it runs different then plug it back in and do the back.

1996 F250 ext cab XL 5spd
Gearhead 6 pos, 3" dp to 5" Tailpipe, 6637, Sunpro gauges, SD AD's, T500 HPOP, SD Electric Fuel, 3" Plenums 300hp 500ft/lbs
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bad12jr is offline  
post #8 of 14 (permalink) Old 05-24-2011, 10:31 PM Thread Starter
PSN Local
 
97Stroker13's Avatar
 
Join Date: Dec 2010
Location: south florida
Posts: 418
Re: bad injectors?

no smoke at all, what will this tell me? ill try it.

1997 Ford F-250 SCLB
1.00 A/R exhaust housing
TS chip w/ Swamps tunes
6637 intake
4 inch turbo back exhaust
Single disc converter,billet backplate
B&M Trans cooler
BTS valve body w/transgo shiftplate
Wicked wheel 2
Adrenaline HPOP
Swamps diesel 160/100%'s
Irate E-fuel
97Stroker13 is offline  
post #9 of 14 (permalink) Old 05-24-2011, 11:54 PM
PSN Newb
 
Join Date: May 2011
Posts: 4
Re: bad injectors?

I'm having exactly the same problem, however; I'm loosing oil quickly at times... It will be interesting to see what you do as I am debating on upgrading everything...
oldschoolstrokerr is offline  
post #10 of 14 (permalink) Old 05-25-2011, 12:42 AM Thread Starter
PSN Local
 
97Stroker13's Avatar
 
Join Date: Dec 2010
Location: south florida
Posts: 418
Re: bad injectors?

Quote:
Originally Posted by bad12jr View Post
Could have a wire rubbed through under the valve cover. Had a buddies do similar. Any smoke. Also you can unplug the front plug on the passenger and start it. See if it runs different then plug it back in and do the back.
i tried it, nothing.

Thanks though man anything helps.

1997 Ford F-250 SCLB
1.00 A/R exhaust housing
TS chip w/ Swamps tunes
6637 intake
4 inch turbo back exhaust
Single disc converter,billet backplate
B&M Trans cooler
BTS valve body w/transgo shiftplate
Wicked wheel 2
Adrenaline HPOP
Swamps diesel 160/100%'s
Irate E-fuel
97Stroker13 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome