Edge fail to load, now flashing c.e.l and w.t.s. lights - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 04-21-2011, 05:47 AM Thread Starter
OBS Stroker
 
Nodge's Avatar
 
Join Date: Jan 2010
Location: Saskatchetoon, eh!
Posts: 1,004
Edge fail to load, now flashing c.e.l and w.t.s. lights

Since my truck is acting up, my dad loaned me his 97 F350 with 12,000 kms on it. He gave me his edge evo programmer and instructed me to put on the 60horse tune. (I know, I know.........I use a TS chip.......I know all about the edge horror stories)

The tune failed to load, retried, failed, retried, and said it was successful.
Truck will not start.
Returned edge programmer to stock, but still no start, and engine light / wait to start light is flashing / clicking opposite of each other.

I'm guessing I fried the PCM.
This is just not my week with 7.3's......

1997 F250 ECSB, 140Kmiles, 3.55's, 5 spd, Sht throw, S.B. dd clutch, Rosewood 238/100, Adrenaline, S468, irate mount, ARP studs, 910 springs, smith bros. p/r, 4" MBRP, AFE Stg 2, BDP tunes, Termi Scan gauge, Swamps IDM, intercooled, BDP fuel
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1997 F250, CCSB, swamps idm, 3" dp, 3.5" cat delete, 38gal rear tank.
Nodge is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 04-21-2011, 05:57 AM
oil burner
 
tughill283's Avatar
 
Join Date: Jul 2009
Location: tughill,upstate ny
Posts: 1,136
Re: Edge fail to load, now flashing c.e.l and w.t.s. lights

i wouldnt have touched the damn thin.try unhooking the batteries for 15 min and then try to start.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

96 f250, ZF5,160cc,
300k miles

96 f350 plow truck
tughill283 is offline  
post #3 of 12 (permalink) Old 04-21-2011, 07:09 PM
OBS Addict
 
7.3psd97444's Avatar
 
Join Date: Mar 2011
Location: Blairsville PA
Posts: 1,538
Re: Edge fail to load, now flashing c.e.l and w.t.s. lights

Yeah sounds like a fried PCM to me too. Do try unhooking the batts though.

-Jordan-
97 SCLB 7.3 Handshaker
Valair Clutch, only the best.
TS 6 Position Tyrant Tuning
S&B, MBRP, Isspro, Mag-Hytec, 1.00 A/R Exhaust housing, HPX
Full sound system: Kicker-Kenwood
BILLET BADGES
Dick Cepek DC-2's/Duratracs
On-Board Air
Few cosmetics
PSA # 269
7.3psd97444 is offline  
 
post #4 of 12 (permalink) Old 04-21-2011, 09:49 PM Thread Starter
OBS Stroker
 
Nodge's Avatar
 
Join Date: Jan 2010
Location: Saskatchetoon, eh!
Posts: 1,004
Re: Edge fail to load, now flashing c.e.l and w.t.s. lights


1997 F250 ECSB, 140Kmiles, 3.55's, 5 spd, Sht throw, S.B. dd clutch, Rosewood 238/100, Adrenaline, S468, irate mount, ARP studs, 910 springs, smith bros. p/r, 4" MBRP, AFE Stg 2, BDP tunes, Termi Scan gauge, Swamps IDM, intercooled, BDP fuel
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1997 F250, CCSB, swamps idm, 3" dp, 3.5" cat delete, 38gal rear tank.
Nodge is offline  
post #5 of 12 (permalink) Old 04-21-2011, 09:52 PM
PSN Veteran
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,561
Re: Edge fail to load, now flashing c.e.l and w.t.s. lights

Ouch.

02 f250
countryboyrob is offline  
post #6 of 12 (permalink) Old 04-21-2011, 10:04 PM
OBS Addict
 
7.3psd97444's Avatar
 
Join Date: Mar 2011
Location: Blairsville PA
Posts: 1,538
Re: Edge fail to load, now flashing c.e.l and w.t.s. lights

Not cool.

-Jordan-
97 SCLB 7.3 Handshaker
Valair Clutch, only the best.
TS 6 Position Tyrant Tuning
S&B, MBRP, Isspro, Mag-Hytec, 1.00 A/R Exhaust housing, HPX
Full sound system: Kicker-Kenwood
BILLET BADGES
Dick Cepek DC-2's/Duratracs
On-Board Air
Few cosmetics
PSA # 269
7.3psd97444 is offline  
post #7 of 12 (permalink) Old 04-21-2011, 11:00 PM Thread Starter
OBS Stroker
 
Nodge's Avatar
 
Join Date: Jan 2010
Location: Saskatchetoon, eh!
Posts: 1,004
Re: Edge fail to load, now flashing c.e.l and w.t.s. lights

I told the old man to throw the edge in the garbage, and I'll give him my spare TS 6 pos.
I keep the edge in my truck just because it spells out the trouble codes in plain english.
I have a scangauge which is a life saver!

We both have an edge programmer, since together we have 6 obs 7.3's.
He's not impressed.
This is the 2nd pcm of his to be fried by an edge in 2 weeks, so I think he's convinced to jump over to a TS chip.
Ford charged him $1200 for the last one.
I have a re-man coming for this one.
$300 on ebay.

1997 F250 ECSB, 140Kmiles, 3.55's, 5 spd, Sht throw, S.B. dd clutch, Rosewood 238/100, Adrenaline, S468, irate mount, ARP studs, 910 springs, smith bros. p/r, 4" MBRP, AFE Stg 2, BDP tunes, Termi Scan gauge, Swamps IDM, intercooled, BDP fuel
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1997 F250, CCSB, swamps idm, 3" dp, 3.5" cat delete, 38gal rear tank.
Nodge is offline  
post #8 of 12 (permalink) Old 04-21-2011, 11:02 PM
PSN Veteran
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,561
Re: Edge fail to load, now flashing c.e.l and w.t.s. lights

BTW your dad's truck looks great.

02 f250
countryboyrob is offline  
post #9 of 12 (permalink) Old 04-21-2011, 11:05 PM Thread Starter
OBS Stroker
 
Nodge's Avatar
 
Join Date: Jan 2010
Location: Saskatchetoon, eh!
Posts: 1,004
Re: Edge fail to load, now flashing c.e.l and w.t.s. lights

It had better!
Its only got 12,200 kms on it!

Thanks!

1997 F250 ECSB, 140Kmiles, 3.55's, 5 spd, Sht throw, S.B. dd clutch, Rosewood 238/100, Adrenaline, S468, irate mount, ARP studs, 910 springs, smith bros. p/r, 4" MBRP, AFE Stg 2, BDP tunes, Termi Scan gauge, Swamps IDM, intercooled, BDP fuel
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1997 F250, CCSB, swamps idm, 3" dp, 3.5" cat delete, 38gal rear tank.
Nodge is offline  
post #10 of 12 (permalink) Old 04-21-2011, 11:19 PM
OBS Addict
 
7.3psd97444's Avatar
 
Join Date: Mar 2011
Location: Blairsville PA
Posts: 1,538
Re: Edge fail to load, now flashing c.e.l and w.t.s. lights

Quote:
Originally Posted by Nodge View Post
It had better!
Its only got 12,200 kms on it!

Thanks!
Wow! He the only owner and never drive it?!

-Jordan-
97 SCLB 7.3 Handshaker
Valair Clutch, only the best.
TS 6 Position Tyrant Tuning
S&B, MBRP, Isspro, Mag-Hytec, 1.00 A/R Exhaust housing, HPX
Full sound system: Kicker-Kenwood
BILLET BADGES
Dick Cepek DC-2's/Duratracs
On-Board Air
Few cosmetics
PSA # 269
7.3psd97444 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome