LED Switchback problem - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-13-2017, 05:59 PM Thread Starter
PSN Newb
 
Join Date: Aug 2017
Posts: 1
LED Switchback problem

I have a 99 super duty with the 6.0 headlights. When I try to replace my turn signal bulbs with switchbacks they won't blink they just stay solid on my dash. I have load resistors and they are the correct bulbs. Anyone have advice for me?
Boozecruisin is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-13-2017, 10:52 PM
POWERSTROKEMIKE
 
Join Date: Dec 2007
Location: Planet Earth
Posts: 530
Re: LED Switchback problem

where did you place your load resistors.. I put mine on the lights an got rid of my problems..
powerstrokemike is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome