no power to stereo - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-04-2013, 12:52 AM Thread Starter
PSN Newb
 
Join Date: Mar 2013
Location: Chicago
Posts: 11
no power to stereo

So i pulled out my aftermarket pioneer head unit on my '94 F-350 and was putting it back in and it wouldn't power up at all or would sporadically turn on then off. I connected the yellow and red wires and it turned on. then after I saw a spark and now the pioneer radio wont power up at all. None of the fuses in the fuse box under the hood nor under the steering wheel were blown nor the one on the stereo itself. I bout a new stereo just to make sure it wasn't that and the new kenwood one wont turn on at all either. I'm lost and have no idea what else to do. I tried disconnecting the batteries to possibly reset it but no luck. Anything will help.
Thanks
oilburner23 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome