Wiring help - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-10-2013, 05:50 PM Thread Starter
PSN Newb
 
Join Date: Apr 2012
Posts: 2
Wiring help

I have an '05 duty and the rear running lights as well as the plate lights are not working. The brake and turn signals work thought. I've checked the "exterior lights" fuse but find it hard to believe that's the only fuse for all the lights. All the bulbs appear to be okay as well.

I've had a couple of people tell me over the past couple of weeks that I had not tail lights but when I get out to check them they're working fine. Now they aren't working at all.

Any help would be greatly appreciated and I'm sorry if I've posted this in the wrong forum.
Dtmbenz is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-12-2013, 04:53 PM
PSN Newb
 
Join Date: Mar 2012
Posts: 13
Re: Wiring help

Have you solved this problem?? Currently have the same problem and cannot find a solution yet.
tmanrose2007 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome