Light bar power issue - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 07-05-2017, 03:29 PM Thread Starter
PSN Local
 
Join Date: Apr 2016
Posts: 162
Light bar power issue

I have a small (20") LED bar installed. There's a toggle switch on the dash and a relay mounted nearby. When I turn it on, my CEL will come on momentarily and the engine loses power for a second. Ideas? I used decent gauge supply wire, and it CANT be drawing much current. Ideas?


Sent from my iPhone using Tapatalk
tmsbandman is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 07-05-2017, 03:56 PM
Moderator
 
Sbluke55's Avatar
 
Join Date: Jun 2015
Location: Colorado
Posts: 7,867
Re: Light bar power issue

So the light bar is causing interference with the cam sensor. Is it an oem sensor.
You could add some ferrite beads I fix it.

01 f-250, Standard
Rev tech 4" lift, 37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks intercooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
Sbluke55 is offline  
post #3 of 14 (permalink) Old 07-05-2017, 07:06 PM Thread Starter
PSN Local
 
Join Date: Apr 2016
Posts: 162
Re: Light bar power issue

Quote:
Originally Posted by Sbluke55 View Post
So the light bar is causing interference with the cam sensor. Is it an oem sensor.
You could add some ferrite beads I fix it.


Interesting. Is it the current draw, or the actual LEDs themselves? By ferrite beads, do you mean the little donut magnets that are on some electronics? If so, where should I put them?



Sent from my iPhone using Tapatalk
tmsbandman is offline  
 
post #4 of 14 (permalink) Old 07-05-2017, 09:46 PM
Moderator
 
Sbluke55's Avatar
 
Join Date: Jun 2015
Location: Colorado
Posts: 7,867
Re: Light bar power issue

It's the leds causing noise and screwing with the cam sensor.

I would try a new cps first.

01 f-250, Standard
Rev tech 4" lift, 37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks intercooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
Sbluke55 is offline  
post #5 of 14 (permalink) Old 07-05-2017, 09:58 PM Thread Starter
PSN Local
 
Join Date: Apr 2016
Posts: 162
Re: Light bar power issue

The cam position sensor was just replaced a few weeks ago by ford when I got a fuel pump. What would be the next step?


Sent from my iPhone using Tapatalk
tmsbandman is offline  
post #6 of 14 (permalink) Old 07-05-2017, 10:10 PM
Moderator
 
Sbluke55's Avatar
 
Join Date: Jun 2015
Location: Colorado
Posts: 7,867
Re: Light bar power issue

How about the icp sensor. Is it oem?

01 f-250, Standard
Rev tech 4" lift, 37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks intercooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
Sbluke55 is offline  
post #7 of 14 (permalink) Old 07-05-2017, 10:31 PM
PSN Veteran
 
Bugman's Avatar
 
Join Date: Aug 2007
Location: Gypsum, Co
Posts: 5,157
Re: Light bar power issue

Do you have a dedicated ground to the light bar?

96 F250 XLT 4x4, 4:10 gears, 5 speed, Tymar intake and HX hose, downpipe, pyro and boost guages, coolant filter, Luc clutch
Bugman is offline  
post #8 of 14 (permalink) Old 07-05-2017, 11:56 PM Thread Starter
PSN Local
 
Join Date: Apr 2016
Posts: 162
Re: Light bar power issue

Quote:
Originally Posted by tmsbandman View Post
The cam position sensor was just replaced a few weeks ago by ford when I got a fuel pump. What would be the next step?


Sent from my iPhone using Tapatalk


Sorry. Yes (better be). Work
Was done at a Ford dealer.


Sent from my iPhone using Tapatalk
tmsbandman is offline  
post #9 of 14 (permalink) Old 07-05-2017, 11:58 PM Thread Starter
PSN Local
 
Join Date: Apr 2016
Posts: 162
Re: Light bar power issue

Quote:
Originally Posted by Sbluke55 View Post
How about the icp sensor. Is it oem?


Oops. Wrong spot. Yes, it better be. Repairs we're done at a Ford dealer


Sent from my iPhone using Tapatalk
tmsbandman is offline  
post #10 of 14 (permalink) Old 07-05-2017, 11:59 PM Thread Starter
PSN Local
 
Join Date: Apr 2016
Posts: 162
Re: Light bar power issue

Quote:
Originally Posted by Bugman View Post
Do you have a dedicated ground to the light bar?


Negative from light bar is grounded directly


Sent from my iPhone using Tapatalk
tmsbandman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome