Early 99, Fleetrite ELC, need some opinions - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-25-2016, 02:11 PM Thread Starter
PSN Newb
 
Join Date: Mar 2008
Posts: 9
Early 99, Fleetrite ELC, need some opinions

Changed my water pump a few years back and swapped to the Fleetrite ELC coolant at the time. Well it's time again to change the water pump and I need coolant. Through some research I've found that ELC isn't recommended for early 99's due to the sealant for the injector cups.

So far I haven't had any issues with the cups, but my dilemma is no one has the Fleetrite concentrate in stock, nor do they know when they'll have more.

I've read good reviews on the Zerex ELC and it's readily available at NAPA. My only concern with switching brands is I've heard the early 99's might be okay with some brands and not with others.

So I need some opinions on what to do. I need to get the water pump done this weekend as well. So switch to Zerex ELC or go back to the old green stuff and additive.

Thanks in advance.
MATREDGT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome