Did in tank mod and when I filled tank it started leaking - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 06-19-2010, 05:37 AM Thread Starter
PSN Local
 
Join Date: May 2009
Location: Mountain House, CA
Posts: 78
Did in tank mod and when I filled tank it started leaking

Ok thanks to the help of Nick (weekendwarriorfs32w) we instaled a pre pump and in tank kit. Also did the Hutch and Harpoon mod. after install I went to fill tank up and it started leaking from top of tank. I can't see but the hoses fell dry but on top of the sending unit felt wet. Has anyone had this prob? Everything was tight just dont want to have to drop tank again.

2000 F350 crew cab long bed 4x4 7.3L Diesel, 4inch procomp lift 315/75/16 tires, 104,000 miles, 6637 air intake, zoodad mod, 4inch MBRP turboback exhaust, AIH delete, Isspro EV2 Gauges, EGT, boost, trany temp, Just installed DP tuner F6 high idle, 80T, 80E, 120 Race. WW. Just installed T 500 HPOP, JW valve body
renyren is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 06-19-2010, 05:51 AM
PSN Veteran
 
TARM's Avatar
 
Join Date: Nov 2009
Location: Winchester, Virginia
Posts: 4,865
Re: Did in tank mod and when I filled tank it started leaking

Sounds like your feed hose most likely or the return has a bad (leaking) connection. No matter what if its coming from the top you are gonna have to drop the tank again.
TARM is offline  
post #3 of 12 (permalink) Old 06-19-2010, 07:26 AM
Lovin Life...
 
02BigD's Avatar
 
Join Date: Dec 2008
Location: Coastal NC
Posts: 2,900
Re: Did in tank mod and when I filled tank it started leaking

That top can be a real PIA to get seated properly.

X2 for dropping it.

02-350. CCSB - Drivetrain by Stauffer, fuel by Swamps, air by Barder, tunes by Gearhead.
04-250. ECSB - In the shop...7.3 swap.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
02BigD is offline  
 
post #4 of 12 (permalink) Old 06-19-2010, 01:29 PM
All done now
 
Arisley's Avatar
 
Join Date: Sep 2007
Location: Arlington, TX
Posts: 22,486
Re: Did in tank mod and when I filled tank it started leaking

I put the ring out in the hot texas sun for a while. It helped. Bet you have it cross threaded. Might think about raising the bed. I thought everybody was crazy talking about it, but when I changed my bed, I found out how really simple it is.




Early '99 F350 DRW, Excab, LB. Auto. 2WD, 2010 bed, 2005 headlights, 298K, on my way to 1000K.
H2E, 238 Hybrids, Adrenaline oil, Tuned by Tony. DIY Regulated Return.
Arisley is offline  
post #5 of 12 (permalink) Old 06-19-2010, 01:31 PM
Hoosier daddy!
 
Ramblin'_Man's Avatar
 
Join Date: Feb 2008
Location: "The Region"
Posts: 1,700
Re: Did in tank mod and when I filled tank it started leaking

I second Andy's thoughts... I couldn't get the ring started when I did these mods on my truck... Set it in really hot water for a few minutes and finally got it.

2001 PSD F250
Born 4/01 in KY USA,
4x4, 3.73, Ext. Cab, Shortbox...
ITP RR, CCV, Tymar Intake, Airdog, DP tuner

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Ramblin'_Man is offline  
post #6 of 12 (permalink) Old 06-19-2010, 02:01 PM
Village Idiot
 
southmike's Avatar
 
Join Date: Jul 2007
Posts: 8,209
Re: Did in tank mod and when I filled tank it started leaking

could take the bed off, since tank is full.

Early 99 f350 4x4 crew cab, auto. pmt2 pcm
2001 cup holder ,T500, MAX AC ASSIST AC mod, Diy Twin tymar, TS chip, Powerslots & Hawk pads, ford AIC, ..... with big fat want to list.
southmike is offline  
post #7 of 12 (permalink) Old 06-19-2010, 02:51 PM Thread Starter
PSN Local
 
Join Date: May 2009
Location: Mountain House, CA
Posts: 78
Re: Did in tank mod and when I filled tank it started leaking

yea we put it in hot water and used hammer and 2x4. That was my next question is it easier to pull the bed off or drop the tank? The tank came down fine but it was not so easy to get back in.

2000 F350 crew cab long bed 4x4 7.3L Diesel, 4inch procomp lift 315/75/16 tires, 104,000 miles, 6637 air intake, zoodad mod, 4inch MBRP turboback exhaust, AIH delete, Isspro EV2 Gauges, EGT, boost, trany temp, Just installed DP tuner F6 high idle, 80T, 80E, 120 Race. WW. Just installed T 500 HPOP, JW valve body
renyren is offline  
post #8 of 12 (permalink) Old 06-19-2010, 03:19 PM
All done now
 
Arisley's Avatar
 
Join Date: Sep 2007
Location: Arlington, TX
Posts: 22,486
Re: Did in tank mod and when I filled tank it started leaking

Eight bolts T50 IIRC, might be T55. Disconnect the filler neck. Raise it up enough to get to it. You will see where it is leaking.




Early '99 F350 DRW, Excab, LB. Auto. 2WD, 2010 bed, 2005 headlights, 298K, on my way to 1000K.
H2E, 238 Hybrids, Adrenaline oil, Tuned by Tony. DIY Regulated Return.
Arisley is offline  
post #9 of 12 (permalink) Old 06-19-2010, 08:55 PM
PSN Veteran
 
Orezona's Avatar
 
Join Date: Oct 2007
Posts: 1,118
Re: Did in tank mod and when I filled tank it started leaking

I used Vaseline on the threads to get it started after about an hour of trying. Load the threads up with Vaseline, get it started and then give it a smack on the high side to even it out.
Orezona is offline  
post #10 of 12 (permalink) Old 06-20-2010, 11:26 PM Thread Starter
PSN Local
 
Join Date: May 2009
Location: Mountain House, CA
Posts: 78
Re: Did in tank mod and when I filled tank it started leaking

Ok took bed off truck this morning and fuel was leaking from the collar. was able to tighten it a full turn or turn and a half. Hopefully that fixed it. It was much easier to lift the bed I think. Thank you to everyone for the help.

2000 F350 crew cab long bed 4x4 7.3L Diesel, 4inch procomp lift 315/75/16 tires, 104,000 miles, 6637 air intake, zoodad mod, 4inch MBRP turboback exhaust, AIH delete, Isspro EV2 Gauges, EGT, boost, trany temp, Just installed DP tuner F6 high idle, 80T, 80E, 120 Race. WW. Just installed T 500 HPOP, JW valve body
renyren is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome