It's running again! 250/100's and Adrenaline in. - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 26 (permalink) Old 05-28-2010, 12:10 PM Thread Starter
Rented Mule
 
icanski2's Avatar
 
Join Date: Feb 2008
Location: Mansfield/Rendon, Texas
Posts: 95
Smile It's running again! 250/100's and Adrenaline in.

Well, I finally got a chance to finish the install and after the first test drive, it ended up being well worth the PIA. Actually the second test drive because I had to limp home and put an intercooler boot back on after the first drive. I forgot to finish tightening the all the clamps. ! The Adrenaline did an outstanding job and Beans Tunes and Injectors were equally impressive. I havenít fully reviewed all the AE Data but from what I saw from hpop gauge and quick glances at the laptop, there was definitely no shortage of oil for the sticks. Beans Tunes were great from what I got to observe in my limited test drives. They were not touchy, idled well, good shift logic and made good use of the full range of the accelerator. I didn't do a hot retorque on the studs yet to verify ARP's new torquing procedure base on using their Ultra-Torque Lube. I will post the results when I do because there were some people interested in the info from one of my previous posts. I installed new up-pipes using Beans brass donuts and they sealed up as designed but I'm curious about how long they will last compared to regular ones. The only thing yet to install is the Walbro Fuel Pump and that needs fast tracked because the factory pump is not even coming close to keeping up.
New parts installed over the last couple weeks:
Adrenaline HPOP
New IPR
Full coolant flush with 30 gallons of distilled water
Radiator
Radiator Reservoir Tank and Cap
6.0 Tranny Cooler
Fan Clutch
Water Pump
Oil Cooler
Every hose that holds antifreeze
Belt tensioner
Idler pully bearing
Belt.
Tranny filter then flush with Schaeffer Fluid before hooking the lines to the new radiator and cooler.
Swapped over to Rotella ELC
Isspro EV2 Fuel Press gauge.
Head studs
910 Springs
Beans Injectors 250/100's
DI Pushrods
up pipes with brass doughnuts
Walbro Fuel Pump is next

My 7.3 doesn't leak oil. It marks my space!
Y2K F250 Lariat CC 4X4, Bought New
TS chip, Adrenaline, ARP Head Studs. 910's. DI Push Rods
Full Force 250/100's, BTS, 6.0 Cooler, Fuelab pump, Beans sump
AFE Stage II, GT38R, Non EBV, R.R. Fuel Sys, CCV Mod
DPP 4" Exhaust, Isspros, DiPricol HP Oil Gauge
icanski2 is offline  
Sponsored Links
Advertisement
 
post #2 of 26 (permalink) Old 05-28-2010, 12:40 PM
All done now
 
Arisley's Avatar
 
Join Date: Sep 2007
Location: Arlington, TX
Posts: 22,486
Re: It's running again! 250/100's and Adrenaline in.

Good to hear.




Early '99 F350 DRW, Excab, LB. Auto. 2WD, 2010 bed, 2005 headlights, 298K, on my way to 1000K.
H2E, 238 Hybrids, Adrenaline oil, Tuned by Tony. DIY Regulated Return.
Arisley is offline  
post #3 of 26 (permalink) Old 05-28-2010, 01:02 PM
Crazy wid da cheeze wiz
 
David N's Avatar
 
Join Date: Oct 2008
Location: Williamston NC
Posts: 2,411
Re: It's running again! 250/100's and Adrenaline in.

NICE! Get some video. This is about what I want to do, and you just may be the inpiration. And what power level do you think you are at?

2002 F-250 CCSB Lariat 4x4 7.3 Mostly stock... for now

2003 Ford Ranger Fx4 Level ll Sonic Blue with 33s"

Quote:
Originally Posted by Steamfighter View Post
I'm getting it in the can right now!!
David N is offline  
 
post #4 of 26 (permalink) Old 05-28-2010, 01:42 PM
OEM Moderator
 
Tom S's Avatar
 
Join Date: Jul 2007
Location: Littleton, Colo
Posts: 9,381
Send a message via AIM to Tom S
Re: It's running again! 250/100's and Adrenaline in.

I am curious you used a lot of distilled water doing the flush. Did you pull the block drain plugs when working on your flush?
Tom S is offline  
post #5 of 26 (permalink) Old 05-28-2010, 01:57 PM Thread Starter
Rented Mule
 
icanski2's Avatar
 
Join Date: Feb 2008
Location: Mansfield/Rendon, Texas
Posts: 95
Re: It's running again! 250/100's and Adrenaline in.

Quote:
Originally Posted by Tom S View Post
I am curious you used a lot of distilled water doing the flush. Did you pull the block drain plugs when working on your flush?

Yea I pulled all the block drain plugs many times..... I just wanted to give it a very thorough flush because I was replacing about every part that held coolant and I was swapping over to ELC (red) coolant. 30 gallons was probably overkill, but at 78 cents a gallon I decided to be a big spender.

My 7.3 doesn't leak oil. It marks my space!
Y2K F250 Lariat CC 4X4, Bought New
TS chip, Adrenaline, ARP Head Studs. 910's. DI Push Rods
Full Force 250/100's, BTS, 6.0 Cooler, Fuelab pump, Beans sump
AFE Stage II, GT38R, Non EBV, R.R. Fuel Sys, CCV Mod
DPP 4" Exhaust, Isspros, DiPricol HP Oil Gauge
icanski2 is offline  
post #6 of 26 (permalink) Old 05-28-2010, 02:04 PM
All done now
 
Arisley's Avatar
 
Join Date: Sep 2007
Location: Arlington, TX
Posts: 22,486
Re: It's running again! 250/100's and Adrenaline in.

We need to get both of our trucks down to Kennedale, see what they will do.




Early '99 F350 DRW, Excab, LB. Auto. 2WD, 2010 bed, 2005 headlights, 298K, on my way to 1000K.
H2E, 238 Hybrids, Adrenaline oil, Tuned by Tony. DIY Regulated Return.
Arisley is offline  
post #7 of 26 (permalink) Old 05-28-2010, 02:04 PM
Village Idiot
 
southmike's Avatar
 
Join Date: Jul 2007
Posts: 8,209
Re: It's running again! 250/100's and Adrenaline in.

that was going to be my next question, what was going on with the coolant system to require the complete overhaul?

got a lot done , and some nice upgrades need to get a rr system next...

Early 99 f350 4x4 crew cab, auto. pmt2 pcm
2001 cup holder ,T500, MAX AC ASSIST AC mod, Diy Twin tymar, TS chip, Powerslots & Hawk pads, ford AIC, ..... with big fat want to list.
southmike is offline  
post #8 of 26 (permalink) Old 05-28-2010, 02:39 PM Thread Starter
Rented Mule
 
icanski2's Avatar
 
Join Date: Feb 2008
Location: Mansfield/Rendon, Texas
Posts: 95
Re: It's running again! 250/100's and Adrenaline in.

Quote:
Originally Posted by southmike View Post
that was going to be my next question, what was going on with the coolant system to require the complete overhaul?

got a lot done , and some nice upgrades need to get a rr system next...
It all started when the top radiator hose neck broke off going down the highway. I had to replace the radiator because of that and since my tranny temps were running hotter than, I liked I replaced the v10 cooler with a 6.0 one. I replaced the fan clutch because I donít think it was working right anymore and may have been the cause of the hot tranny last year. The other stuff I replaced based on the "since I'm in there philosophy" The water pump was fine and I wanted a clean new oil cooler because of the new injectors and hpop. I had high iron readings after a turbo failure a long time ago but they went down to normal after a few oil changes but I wanted to make sure no old stuff would break free of the old cooler down the road. Basically I spent money on unneeded parts to make myself feel warm and fuzzy inside. I bought the truck new and it has almost 200k on but itís been paid for since 2004. I drove my neighbors 2011 6.7 a while back and it was nice, but not $60k nice, so I guess Iíll keep mine another ten years. Itís a third vehicle and Iím putting less 4000 miles a year on it now

By the way, I've had an ITP RR for about six years now. I recently upgraded it to the new style with the larger braided lines.

My 7.3 doesn't leak oil. It marks my space!
Y2K F250 Lariat CC 4X4, Bought New
TS chip, Adrenaline, ARP Head Studs. 910's. DI Push Rods
Full Force 250/100's, BTS, 6.0 Cooler, Fuelab pump, Beans sump
AFE Stage II, GT38R, Non EBV, R.R. Fuel Sys, CCV Mod
DPP 4" Exhaust, Isspros, DiPricol HP Oil Gauge
icanski2 is offline  
post #9 of 26 (permalink) Old 05-28-2010, 02:40 PM Thread Starter
Rented Mule
 
icanski2's Avatar
 
Join Date: Feb 2008
Location: Mansfield/Rendon, Texas
Posts: 95
Re: It's running again! 250/100's and Adrenaline in.

Quote:
Originally Posted by Arisley View Post
We need to get both of our trucks down to Kennedale, see what they will do.
Sounds fun! I can hear the track from my house when there is a north wind.

My 7.3 doesn't leak oil. It marks my space!
Y2K F250 Lariat CC 4X4, Bought New
TS chip, Adrenaline, ARP Head Studs. 910's. DI Push Rods
Full Force 250/100's, BTS, 6.0 Cooler, Fuelab pump, Beans sump
AFE Stage II, GT38R, Non EBV, R.R. Fuel Sys, CCV Mod
DPP 4" Exhaust, Isspros, DiPricol HP Oil Gauge
icanski2 is offline  
post #10 of 26 (permalink) Old 05-28-2010, 02:44 PM
All done now
 
Arisley's Avatar
 
Join Date: Sep 2007
Location: Arlington, TX
Posts: 22,486
Re: It's running again! 250/100's and Adrenaline in.

I would like to get it out there and kinda see what it will do before Crandall.

Also might want to check out his Dyno day.

Dyno Day North Texas July 10 - Powerstroke Nation




Early '99 F350 DRW, Excab, LB. Auto. 2WD, 2010 bed, 2005 headlights, 298K, on my way to 1000K.
H2E, 238 Hybrids, Adrenaline oil, Tuned by Tony. DIY Regulated Return.
Arisley is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome