Idle a little high . - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-25-2019, 09:44 PM Thread Starter
PSN Local
 
Philhan69@aol.com's Avatar
 
Join Date: Jul 2017
Location: Gaffney S.C.
Posts: 224
Idle a little high .

Just wandering if any one else's truck idles high after a couple thousand miles after injectors and hpop replacement. My truck runs the best it ever has now but seems to be idling high the last few days. Thanks for any info.

Sent from my SM-G955U using Tapatalk
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-25-2019, 10:09 PM
dmd
Member
 
dmd's Avatar
 
Join Date: Apr 2009
Posts: 142
Re: Idle a little high .

What do you define as high?

'00 F350 Supercrewzer Lariet, PSD, Auto, 3.73, CC, 4x4, SWB, SRW, 160/30 w/Gearhead Tunes, 38r, S&B CAI, 4-inch turbo back exhaust, Adrenaline HPOP, BTS Trans, in-tank/pre-pump mod, heater/AC mod, Excursion sound panels, Harvest Gold and Black / Packages: Trailer Tow, Camper, Off-Road.
dmd is offline  
post #3 of 5 (permalink) Old 04-25-2019, 11:45 PM Thread Starter
PSN Local
 
Philhan69@aol.com's Avatar
 
Join Date: Jul 2017
Location: Gaffney S.C.
Posts: 224
Re: Idle a little high .

Most of the time its idling about 750 the last unless it's cold then it idles high till I touch the brake. Lately it stays around 950 to 975. Sometimes it goes back to 750 if I cut it off and go in a store and come back 30 minutes later and crank it up. But after a minute or so it goes back to 950. Maybe that's where it is supposed to idle. Just seems strange. I like it better around 750 to 800

Sent from my SM-G955U using Tapatalk
 
post #4 of 5 (permalink) Old 04-25-2019, 11:48 PM Thread Starter
PSN Local
 
Philhan69@aol.com's Avatar
 
Join Date: Jul 2017
Location: Gaffney S.C.
Posts: 224
Re: Idle a little high .

Also my Kc38r seems to be getting a louder higher pitched sound is that common after running for a few months.

Sent from my SM-G955U using Tapatalk
post #5 of 5 (permalink) Old 05-09-2019, 03:14 AM
dmd
Member
 
dmd's Avatar
 
Join Date: Apr 2009
Posts: 142
Re: Idle a little high .

Appears like it thinks that the brake isnt being depressed and it is cold.

'00 F350 Supercrewzer Lariet, PSD, Auto, 3.73, CC, 4x4, SWB, SRW, 160/30 w/Gearhead Tunes, 38r, S&B CAI, 4-inch turbo back exhaust, Adrenaline HPOP, BTS Trans, in-tank/pre-pump mod, heater/AC mod, Excursion sound panels, Harvest Gold and Black / Packages: Trailer Tow, Camper, Off-Road.
dmd is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
How high should the high side oil pressure be at idle? paramax55 1994-1997 Power Stroke Technical Info 11 11-18-2014 10:26 AM
Run a little and Die a little Hollywood691 7.3L Power Stroke Technical Info 21 04-20-2013 02:41 PM
Truck still heating up a little high. drwoodchopper 1994-1997 OBS Power Stroke - Aftermarket & Performance 17 07-16-2010 11:00 PM
Newer to the nation sayin high and lookin for a little advise darklcdfeller New To The Nation 6 02-07-2010 03:37 PM
A little rough a little smoke a little weird. doubledoor 7.3L Power Stroke Technical Info 7 10-14-2009 08:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome