New pcm ts not working - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-16-2019, 09:28 PM Thread Starter
PSN Newb
 
RPs957.3td's Avatar
 
Join Date: Mar 2015
Posts: 5
New pcm ts not working

So I had a previous thread on my truck randomly shutting down finally was able to fix it it was a bad pcm. Installed the new one plugged my ts 6 position on and it doesn't do anything. Wondering if its because of the updated pcm. I bought it brand new from a local diesel performance shop. And if my ts needs to be refreshed any recommendations on where to send it?
RPs957.3td is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-16-2019, 10:57 PM
PSN Veteran
 
Bugman's Avatar
 
Join Date: Aug 2007
Location: Gypsum, Co
Posts: 5,157
Re: New pcm ts not working

Does your truck run without the chip plugged in?

What do you mean by it doesn't do anything?

Did you clean the contacts before installing the chip?

96 F250 XLT 4x4, 4:10 gears, 5 speed, Tymar intake and HX hose, downpipe, pyro and boost guages, coolant filter, Luc clutch
Bugman is offline  
post #3 of 3 (permalink) Old 03-18-2019, 11:23 AM Thread Starter
PSN Newb
 
RPs957.3td's Avatar
 
Join Date: Mar 2015
Posts: 5
Yes it runs I cleaned everything before the install did everything you're supposed to do when you install them, unplug the battery etc. But when it's plugged in and running when I turn it to high idle it doesn't respond and every other tune that is supposed to be on the chip is like stock tune. It's like the chip is blank.
RPs957.3td is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
94.5 psd #3 injector not working. IDM?PCM? Dukerpabst Powerstrokenation.com Site Issues Forum 2 04-23-2017 05:18 AM
Max AC fan speed 1&2 not working regular AC working clydesdale 7.3L Power Stroke Technical Info 0 03-24-2013 06:32 PM
new ts 6 pos.chip not working kenny 1994-1997 OBS Power Stroke - Aftermarket & Performance 24 12-19-2010 02:48 PM
Glow plugs working, Wait to start not working Why? offroad diesel 1994-1997 Power Stroke Technical Info 5 11-14-2009 04:10 AM
ts chip not working LakesideLimo 1994-1997 OBS Power Stroke - Aftermarket & Performance 6 07-11-2009 03:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome