TN 1.0 Drop-in problems - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 53 (permalink) Old 07-31-2007, 05:14 AM Thread Starter
 
Join Date: Jul 2007
Posts: 2,085
TN 1.0 Drop-in problems

First off I want to say I didn't buy this turbo from BWD as BBunting wasn't a TN dealer at the time. I've been more than happy with BWD, ITP, DI and several others I've done business with. I don't want to start any arguments between vendors, I just want to have a truck that works correctly. Here is the story. I think that I'm discovering that the TN drop in turbos (or the same turbo under one of it's numerous other names) might not be all they are cracked up to be. Following is my sob story on the toy hauling truck:

With just an Juice/Attitude, new stock AD's w/nozzles, and a couple other doo-dads I put down around 350/650. Couple weeks after the injector install (dyno'd before and after injectors [load dyno] and the ~650ft/lbs was after injectors) I installed the TN drop-in. Never dyno'd it. It was a bit laggy on the bottom but I don't much care about fast spool-up. It seemed once it was making boost to be pretty capable. What I now think I was feeling was just the additional lag making it feel like it was pushing more air later.

So I dumped the Edge for an F5, installed a Terminator, new fuel pump and I go back to the same dyno I got the above numbers on. HP was lower, but not excessively (which doesn't mean much as HP is more a function of speed than anything), however I lost about 100 ft/lbs of TQ. I was not happy.

Checked ICP, ect. No problems with the new pumps, they work great. Checked for boost leaks, up-pipe leaks and exhaust manifold leaks, all non existent yet it's all the turbo will do to make 22-23 psi of boost. I still get a noticeable amount of over-fueling with a load on it, telling me the turbo isn't providing enough CFM regardless of pressure. I think one problem maybe the turbine speed is too low. Changing turbine nozzle sizes (I'm assuming I'd have to change the turbine housing as turbos this small don't usually have separate turbine housing nozzles) would help, but I've talked with some guys running the 0.84A/R housing that weren't impressed with the improvement. Not sure what else to do but pull it off and put something different on it.

I know if it wasn't for bad luck I wouldn't have any
69W900A is offline  
Sponsored Links
Advertisement
 
post #2 of 53 (permalink) Old 07-31-2007, 05:21 AM
 
Join Date: Jul 2007
Posts: 6,652
Re: TN 1.0 Drop-in problems

Same dyno?

I hate to say it but I think your initial 350hp dyno number was false.

I have NEVER seen or heard of anyone making more than 300ish with Edge J/A.

Not saying it hasn't happened, nor am I questioning you. Just wondering if that first dyno run wasn't somehow very skewed.
gregrob is offline  
post #3 of 53 (permalink) Old 07-31-2007, 05:30 AM Thread Starter
 
Join Date: Jul 2007
Posts: 2,085
Re: TN 1.0 Drop-in problems

The first dyno run was done three times on the same day, but at different times. Even with the difference in humidity and temperature the three runs were not significantly different (less than 4% variation).

Also remember that the 350 runs with the J/A were with modd'd nozzles on brand new injectors. Even if the numbers were high (and they might be) the fact that the dyno consistently reads high is all that matters. Even if the 350 was high the fact that I lost so much TQ is significant so long as the dyno consistently reads high.
69W900A is offline  
 
post #4 of 53 (permalink) Old 07-31-2007, 06:27 AM
 
Join Date: Jul 2007
Posts: 1,110
Re: TN 1.0 Drop-in problems

Not sure what the issue is, but there seems to be something else wrong

Here is our old stanby with a weak HPOP, no fuel system, 80 econo tune-notice the boost is higher at lower RPM (as it can fuel):

1.00 drop in
bbunting is offline  
post #5 of 53 (permalink) Old 07-31-2007, 06:33 AM
 
Join Date: Jul 2007
Posts: 6,652
Re: TN 1.0 Drop-in problems

Ah I see, modded nozzles
gregrob is offline  
post #6 of 53 (permalink) Old 07-31-2007, 03:29 PM
<<< THE GAUGE WHORE...
 
CSIPSD's Avatar
 
Join Date: Jul 2007
Location: Bend, OR
Posts: 12,083
Re: TN 1.0 Drop-in problems

Same thing I told you at the other site... I have swapped turbos so many times on this truck... The TN drop in is the best option out there for a stand up turbo, there is another issue there...

Again, I think you should try the .84 housing too... Drive pressures with the .84 housing are still lower then the Garrett 38r with the 1.00... and it spools faster...

[CENTER]01 F-250 SC PSD,430k,16 Isspro Gauges, AFE-2,CCV Mod,IAH delete,map reg,Modded H2e, 6.0 IC, 230/100, Studs, 910 springs, Forged rods, Hydra chip, Swamps HVHF IDM, MBRP 4" dual's, Aero, 6" tip's, 4" Revtek lift, 37/12.5/16.5 MT's
Joe
CSIPSD is offline  
post #7 of 53 (permalink) Old 07-31-2007, 03:34 PM Thread Starter
 
Join Date: Jul 2007
Posts: 2,085
Re: TN 1.0 Drop-in problems

Brian, what do you think could be causing the problem? Before I put the turbo on I checked endplay and radial run out and they were next to non-existent so I don't think it's a cartridge problem and the compressor and turbine wheels looked good. I don't have any boost or exhaust leaks.

The test data you linked to is similar in setup to this truck, but you have more fuel. However, I don't think it's a lack of fuel that is causing the issue because I get a noticeable amount of over-fueling at WOT with a load on it.
69W900A is offline  
post #8 of 53 (permalink) Old 07-31-2007, 03:52 PM
<<<<< Next Generation
 
boggerr's Avatar
 
Join Date: Jul 2007
Location: Barnegat, N.J.
Posts: 1,994
Re: TN 1.0 Drop-in problems

Did you get the F5 directly from Jody?????
My suggestion is talk to Jody about tuning.Im going through somewhat the same problem but mine is the low end(lag).Jody is changing the fuel on my chip so we will see how it works out.Top end mine is pulling hard and not as much smoke as I thought with the B-codes.
BTW I talked to Kevin @BWD last week and very he was very helpfull.Had me do a drive pressure test to make sure the TN was working properly and all came back OK.YOu may want to check dive pressure,may or may not rule out the turbo.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

N.E. Terminator Tech

2000 F350 Lariat CC 4x4 LWB Auto
DP-Tuner F5, Terminator HPOP, QSSB, ITP's fuel system, BTS trans.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
boggerr is offline  
post #9 of 53 (permalink) Old 07-31-2007, 04:30 PM Thread Starter
 
Join Date: Jul 2007
Posts: 2,085
Re: TN 1.0 Drop-in problems

Yes, I got the F5 directly from Jody and he knew what turbo I was running and said he was familar with it and wrote the programming for it. Mine is laggy, but I don't care about that I don't race it.

Drive pressure was about 30psi at WOT.
69W900A is offline  
post #10 of 53 (permalink) Old 07-31-2007, 05:15 PM
 
Join Date: Jul 2007
Posts: 1,110
Re: TN 1.0 Drop-in problems

Couple thoughts

1) drive pressure is low, so either you have no fuel really, or there is a pressure leak
2) boost pressure is low, due to low drive pressure-so either the turbo is broke, tuning is no good, or the injectors aren't helping

3) is the wastegate working? Could it be bleeding off boost?
bbunting is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome