Cooling mist Problems - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 07-02-2014, 02:17 PM Thread Starter
PSN Local
 
hyrk's Avatar
 
Join Date: Mar 2009
Location: Alberta
Posts: 236
Cooling mist Problems

Just installed the MPG stage 3 system and ive been having problems. Been getting both the hi current and low current alarms. Ive called cooling mist a couple times and during first call he told me to manually learn so i did that and still got alarms. Next call was to increase the parameter 8 & 9 numbers untill the alarm no longer comes in. I have maxed out these parameters at 50 and still getting alarms. Ive checked lines for plugging, pulled injectors out and ran them maually and seems to run fine into atmospheric pressure. Really ticked at this system so far as everytime i get an alarm the truck has to be shut to get it out of alarm mode and get my boost reading. (just installed a small switch to shut power for resetting) Also when it seems to be working my egts dont seem to change much. Ive heard of 200 F declines but im nowhere near that. Got #2 and #10 (at max output) injectors. Anyone with info is greatly appreciated.

2002 F-350, S&B intake, 38R tubro w/ wwII, EBV delete, CFM manifold, Spearco i/c, Adrenaline HPOP, Casserly stage I AC injectors , ITP Reg. return, DI Headers, hutch fuel mod, Cooling mist stg. 3, 4" MBRP Exhaust, transflow 46 and 40 gal fuel tanks/tool chest, Tunes by GAP, 4" pc lift, 22" Tis 534 wheels w/37"x 13.5" Dakar MT's, 4.30 gears
hyrk is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 07-02-2014, 04:46 PM
the stryker god
 
Join Date: Nov 2008
Location: 615 'till I DIE!!!
Posts: 3,659
Re: Cooling mist Problems

If you're having egt issues with ac's, a 38r a spearco ic then you have other problems. With a modded h2e and 250/200's I could tow pretty much as heavy as I wanted as fast as I wanted without problems
bruce51d is offline  
post #3 of 21 (permalink) Old 07-02-2014, 05:46 PM Thread Starter
PSN Local
 
hyrk's Avatar
 
Join Date: Mar 2009
Location: Alberta
Posts: 236
Re: Cooling mist Problems

Quote:
Originally Posted by bruce51d View Post
If you're having egt issues with ac's, a 38r a spearco ic then you have other problems. With a modded h2e and 250/200's I could tow pretty much as heavy as I wanted as fast as I wanted without problems
yep, thats my thoughts exactly...just had the family out with the holiday trailer and couldnt keep the egts under 1150 F with the cooloing mist. All boost boots are tight, clean filter, clean intercooler, Next step is a new thermocouple.

2002 F-350, S&B intake, 38R tubro w/ wwII, EBV delete, CFM manifold, Spearco i/c, Adrenaline HPOP, Casserly stage I AC injectors , ITP Reg. return, DI Headers, hutch fuel mod, Cooling mist stg. 3, 4" MBRP Exhaust, transflow 46 and 40 gal fuel tanks/tool chest, Tunes by GAP, 4" pc lift, 22" Tis 534 wheels w/37"x 13.5" Dakar MT's, 4.30 gears
hyrk is offline  
 
post #4 of 21 (permalink) Old 07-03-2014, 02:31 AM
PSN Veteran
 
OBSpstroke97's Avatar
 
Join Date: Sep 2010
Location: South FLA
Posts: 1,189
Re: Cooling mist Problems

Quote:
Originally Posted by hyrk View Post
yep, thats my thoughts exactly...just had the family out with the holiday trailer and couldnt keep the egts under 1150 F with the cooloing mist. All boost boots are tight, clean filter, clean intercooler, Next step is a new thermocouple.
Have you checked for boost leakes? Whos tunes are you running ?

1997 F-250, D60, 8in lift/38s, OUO ladder bars, BTS, Spearco 6.0 IC, SRP 1.1, Irate 468 turbo, Dyno proven tunes, P.I.S 300/200s, ARPs/910s/Smith bros push rods, A1000/sump.

[email protected] on 38s
OBSpstroke97 is offline  
post #5 of 21 (permalink) Old 07-03-2014, 12:55 PM Thread Starter
PSN Local
 
hyrk's Avatar
 
Join Date: Mar 2009
Location: Alberta
Posts: 236
Re: Cooling mist Problems

No leaks that I can find. Still getting my 30psi with the 38r turbo. At the moment im using dp tunes. Gonna put matts (gap) tunes back in bf this big trip I have next week. I'm trying everything to keep this thing cool. (Engine and tranny are spot on, no problems there).. even went as far as removing my 4- 8" lights on Front bumper, thought maybe theyre blocking some air flow.

2002 F-350, S&B intake, 38R tubro w/ wwII, EBV delete, CFM manifold, Spearco i/c, Adrenaline HPOP, Casserly stage I AC injectors , ITP Reg. return, DI Headers, hutch fuel mod, Cooling mist stg. 3, 4" MBRP Exhaust, transflow 46 and 40 gal fuel tanks/tool chest, Tunes by GAP, 4" pc lift, 22" Tis 534 wheels w/37"x 13.5" Dakar MT's, 4.30 gears
hyrk is offline  
post #6 of 21 (permalink) Old 07-03-2014, 01:03 PM
the stryker god
 
Join Date: Nov 2008
Location: 615 'till I DIE!!!
Posts: 3,659
Re: Cooling mist Problems

id try another gauge
bruce51d is offline  
post #7 of 21 (permalink) Old 07-03-2014, 01:38 PM Thread Starter
PSN Local
 
hyrk's Avatar
 
Join Date: Mar 2009
Location: Alberta
Posts: 236
Re: Cooling mist Problems

Yep. Gauge and thermocouple on its way. Talked with a guy yesterday, he said I should move from a 4" to a 5" exhaust... Not so sure that's an issue. . Thoughts?

2002 F-350, S&B intake, 38R tubro w/ wwII, EBV delete, CFM manifold, Spearco i/c, Adrenaline HPOP, Casserly stage I AC injectors , ITP Reg. return, DI Headers, hutch fuel mod, Cooling mist stg. 3, 4" MBRP Exhaust, transflow 46 and 40 gal fuel tanks/tool chest, Tunes by GAP, 4" pc lift, 22" Tis 534 wheels w/37"x 13.5" Dakar MT's, 4.30 gears
hyrk is offline  
post #8 of 21 (permalink) Old 07-03-2014, 04:59 PM
the stryker god
 
Join Date: Nov 2008
Location: 615 'till I DIE!!!
Posts: 3,659
Re: Cooling mist Problems

Down pipe size wouldn't change. With all that stuff you have egts should be a none issue.
bruce51d is offline  
post #9 of 21 (permalink) Old 07-03-2014, 05:49 PM
PSN Local
 
Join Date: Dec 2011
Location: ogemaw, michigan
Posts: 137
Re: Cooling mist Problems

5 inch exhaust is a waste to money stick with 4. they do nothing for performance and that pipe is hard to tuck under the truck
erstroke is offline  
post #10 of 21 (permalink) Old 07-03-2014, 06:43 PM Thread Starter
PSN Local
 
hyrk's Avatar
 
Join Date: Mar 2009
Location: Alberta
Posts: 236
Re: Cooling mist Problems

thats what i figured thanks. ill post back after i get gauge in.

Kinda got sidetracked here...anyone have any experience with cooling mist? Still cant get alarms to go away for good.

2002 F-350, S&B intake, 38R tubro w/ wwII, EBV delete, CFM manifold, Spearco i/c, Adrenaline HPOP, Casserly stage I AC injectors , ITP Reg. return, DI Headers, hutch fuel mod, Cooling mist stg. 3, 4" MBRP Exhaust, transflow 46 and 40 gal fuel tanks/tool chest, Tunes by GAP, 4" pc lift, 22" Tis 534 wheels w/37"x 13.5" Dakar MT's, 4.30 gears
hyrk is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome