Transgo tugger kit problem - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-23-2014, 01:47 AM Thread Starter
PSN Local
 
Join Date: Feb 2010
Posts: 315
Transgo tugger kit problem

I'm having a difficult time putting in the front pump. I even bought a new oring seal and cleaned the hell out the housing and it won't go in. Any ideas or anyone have this problem???
foxco44 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-23-2014, 02:59 AM
PSN Veteran
 
RyanG85's Avatar
 
Join Date: Apr 2013
Location: Rome, NY
Posts: 616
Re: Transgo tugger kit problem

Sure you have it clocked correctly? I just had mine out and it went back in very easily.

2001 F250 ECSB (FOR SALE)
Walker BTM

2001 F350 CCSB
Ford AIS with Zoodad mod & Sleeve
Dorman Bellowed Uppies
Autometer Factory Match
Terminator T500
Hutch and Harpooned
CCV Mod
PHP Hydra
BTS Valve Body & PI Stallion
Diamond Eye 4" Turbo Back
Riff Raff Billet Wheel and FRX
RyanG85 is offline  
post #3 of 6 (permalink) Old 05-24-2014, 12:34 AM Thread Starter
PSN Local
 
Join Date: Feb 2010
Posts: 315
Re: Transgo tugger kit problem

There's probably little more of a 1/4 inch left till it seats
foxco44 is offline  
 
post #4 of 6 (permalink) Old 05-24-2014, 12:16 PM
PSN Veteran
 
RyanG85's Avatar
 
Join Date: Apr 2013
Location: Rome, NY
Posts: 616
Re: Transgo tugger kit problem

Try removing the o-ring and dropping it in, should fall right in. Should be able to tell where its catching without the o-ring adding resistance.

2001 F250 ECSB (FOR SALE)
Walker BTM

2001 F350 CCSB
Ford AIS with Zoodad mod & Sleeve
Dorman Bellowed Uppies
Autometer Factory Match
Terminator T500
Hutch and Harpooned
CCV Mod
PHP Hydra
BTS Valve Body & PI Stallion
Diamond Eye 4" Turbo Back
Riff Raff Billet Wheel and FRX
RyanG85 is offline  
post #5 of 6 (permalink) Old 05-24-2014, 02:47 PM Thread Starter
PSN Local
 
Join Date: Feb 2010
Posts: 315
Re: Transgo tugger kit problem

Did that also falls in the same spot. I even banded the pump to make it center before tightening the bolts. It goes in farther now but there's still 1/4 inch left
foxco44 is offline  
post #6 of 6 (permalink) Old 05-24-2014, 08:26 PM Thread Starter
PSN Local
 
Join Date: Feb 2010
Posts: 315
Re: Transgo tugger kit problem

Figured it out. Since the drum behind it came out with it everything moved and got out of alignment
foxco44 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome