Traction problems - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 05-31-2013, 03:34 AM Thread Starter
PSN Local
 
Join Date: Nov 2011
Location: Madison NH
Posts: 295
Traction problems

hey guys having trouble getting my new found power to the ground
was wondering if anyone had the same problem and what they did I have traction bars that are homemade and Ive tried lowering the air pressure in my tires but im still spinning tires at 80mph. I would like to be able to at least give my truck a full throttle run and full boost pressure

thanks

2000 F250 SCSB 6-speed, stage 3 clutch, lifted 4'' with 37's, 5er, 4'' turbo back, 6637 intake, STAGE II Rosewood singles, PHP Phoenix chip, 38R, 910"s shimed, Traction Bars.

05/12_288.64 RWHP. 575.04 FT-LBS-TQ
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


JUST DYNOED! 411 HP 794 FT-LBS-TQ
RLSCOAL is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 05-31-2013, 04:18 AM
PSN Local
 
Derkperk's Avatar
 
Join Date: Feb 2013
Location: Twin cities
Posts: 162
Re: Traction problems

Sounds like time for some new rubber.

05 Intl F250 CCSB FX4 Lariat
6.0, studded, updated, modified
Derkperk is offline  
post #3 of 15 (permalink) Old 05-31-2013, 04:30 AM
PSN Veteran
 
jaybuller's Avatar
 
Join Date: Oct 2008
Posts: 2,081
Re: Traction problems

I have a hard time believeing you can spin tires at 80 mph with anything less than 600 hp on dry pavent especially with 37s

2000 f250 ECSB Dually 4.10s 305/70/16, 4x4 7.3 zf6 200k miles
Php hydra chip PHP tuned! 4" exhaust, stock turbo(ww2, turbomaster wastage actuator, gutted ebpv), FRX, 160/30 sticks SB 1939-CB single clutch, home brew water setup for when i'm pulling hay through the mountains.
jaybuller is offline  
 
post #4 of 15 (permalink) Old 05-31-2013, 05:29 AM
<<< THE GAUGE WHORE...
 
CSIPSD's Avatar
 
Join Date: Jul 2007
Location: Bend, OR
Posts: 12,082
Re: Traction problems

Agreed... With a 400hp truck, its not happening.

[CENTER]01 F-250 SC PSD,430k,16 Isspro Gauges, AFE-2,CCV Mod,IAH delete,map reg,Modded H2e, 6.0 IC, 230/100, Studs, 910 springs, Forged rods, Hydra chip, Swamps HVHF IDM, MBRP 4" dual's, Aero, 6" tip's, 4" Revtek lift, 37/12.5/16.5 MT's
Joe
CSIPSD is offline  
post #5 of 15 (permalink) Old 05-31-2013, 05:37 AM
Village Idiot
 
southmike's Avatar
 
Join Date: Jul 2007
Posts: 8,209
Re: Traction problems

Eaton tru trac..maybe..
Hope it is tire not your clutch spinning...lol reminds me of a you tube video and a yello corevette doing a burnout...priceless

Early 99 f350 4x4 crew cab, auto. pmt2 pcm
2001 cup holder ,T500, MAX AC ASSIST AC mod, Diy Twin tymar, TS chip, Powerslots & Hawk pads, ford AIC, ..... with big fat want to list.
southmike is offline  
post #6 of 15 (permalink) Old 05-31-2013, 12:15 PM
PSN Local
 
Cv0lv0g0's Avatar
 
Join Date: Apr 2013
Location: St. Albans WV
Posts: 99
Re: Traction problems

He's wheels maybe chirping and 80 when he drops the clutch. Not spinning just chirping.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

It was 5:30 in the morning someone needed help. I was to lazy to put the chains on. I ended up needed the help.
Cv0lv0g0 is offline  
post #7 of 15 (permalink) Old 05-31-2013, 01:54 PM
PSN Veteran
 
Join Date: May 2009
Posts: 926
Re: Traction problems

Interested what this new set up you have is...that's a heavy truck to spin at that speed

95 f250 ECLB,silver/purple 199k FFD 350/200s, arps, comp 910 shimmed, BTS ZF delete, glowshift EGT,Boost,trans temp,6" aussies,6637, 6.oh IC,dual sd elec fuel. irate T4, S475/96,136k 97 motor. Twin termies

Plans: twin turbs, crowers and fresh rebuild.
rideracelivemx7 is offline  
post #8 of 15 (permalink) Old 06-01-2013, 08:53 AM
PSN Local
 
Join Date: May 2008
Posts: 186
Re: Traction problems

Quote:
Originally Posted by rideracelivemx7 View Post
Interested what this new set up you have is...that's a heavy truck to spin at that speed
I could see spinning them on wet pavement at 65, my old OBS 250 would do that with 300hp and the 235/75/16's and 355 gears once the boost built is would start sliding sideways down the freeway.
Big Bird is offline  
post #9 of 15 (permalink) Old 06-01-2013, 05:36 PM Thread Starter
PSN Local
 
Join Date: Nov 2011
Location: Madison NH
Posts: 295
Re: Traction problems

mods are in sig and I have a open diff with military 37's at 45psi if your not familiar with the military tires they have very little in contact with the ground. I think just the drive tire is spinning cause it doesnt spin in 4wd and the diff is open. also It will spin in lower gears if I hit bumps in the road. my traction bars are not set up right i just put them in one night before a pull been meaning to change them. 80mph is just a guess the tires have thrown off the speedo the chip was supposed to correct it but it didn't. and on wet pavement I can get the truck to go sideways on the highway but its starting to get anoying cause I want to go fast! not ruling out the clutch slipping, do you guys know of a way to check it with out pulling the trans?

2000 F250 SCSB 6-speed, stage 3 clutch, lifted 4'' with 37's, 5er, 4'' turbo back, 6637 intake, STAGE II Rosewood singles, PHP Phoenix chip, 38R, 910"s shimed, Traction Bars.

05/12_288.64 RWHP. 575.04 FT-LBS-TQ
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


JUST DYNOED! 411 HP 794 FT-LBS-TQ
RLSCOAL is offline  
post #10 of 15 (permalink) Old 06-01-2013, 05:38 PM Thread Starter
PSN Local
 
Join Date: Nov 2011
Location: Madison NH
Posts: 295
Re: Traction problems

The truck is empty all the time now that I live in the city so there is no weight in the bed the truck is around 7500lbs now idk if that helps.

2000 F250 SCSB 6-speed, stage 3 clutch, lifted 4'' with 37's, 5er, 4'' turbo back, 6637 intake, STAGE II Rosewood singles, PHP Phoenix chip, 38R, 910"s shimed, Traction Bars.

05/12_288.64 RWHP. 575.04 FT-LBS-TQ
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


JUST DYNOED! 411 HP 794 FT-LBS-TQ
RLSCOAL is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome