help FAST..electric fuel problems(QUAD FEED) - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 07-12-2008, 09:29 PM Thread Starter
The Oracle
 
BigRed97's Avatar
 
Join Date: Jan 2008
Location: Saugus MA
Posts: 2,777
Send a message via AIM to BigRed97
help FAST..electric fuel problems(QUAD FEED)

well i just got my electric fuel system and Stealth DIY pumps installed....

rolled the key to prime the system and check for leaks, pump kicked on like it should for about 30seconds then the return line started jumping and making this banging noise....

cycled the key and it did this imediately....FP is around 60 psi(but the needle is jumping in sequence with the return line)

started the truck and it seems to idle great...but the issue is still present...

HELP!

http://s169.photobucket.com/albums/u...9-17-07001.flv

http://s169.photobucket.com/albums/u...9-17-07002.flv

CCLB with some stuff done .....


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BigRed97 is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 07-12-2008, 09:40 PM
PSN Veteran
 
urbanwheeler's Avatar
 
Join Date: Nov 2007
Location: Chico, CA
Posts: 2,031
Re: help FAST..electric fuel problems(QUAD FEED)

what size is the fuel return? is it possible your regulator is acting up? have you tried changing you fuel psi?

'96 f-250, auto, shackle flip, solid axle, rsk, high/crossover steering, 3.73's, true trac's front and rear, trac bars, gt4202, 7.3 ic, idm mod, ccv mod, A1000, 4-line DIY Gen3, dual ipr's, casserly 350/200's, arp studs, 910's, pushrods, elec. fan, 2-stage nitrous, fluidampr.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
[SIGPIC][/SIGPIC]
urbanwheeler is offline  
post #3 of 19 (permalink) Old 07-12-2008, 09:59 PM Thread Starter
The Oracle
 
BigRed97's Avatar
 
Join Date: Jan 2008
Location: Saugus MA
Posts: 2,777
Send a message via AIM to BigRed97
Re: help FAST..electric fuel problems(QUAD FEED)

return line is -6 from the regulator then mated to the stock line off the selector valve

i tried the FP any where from 90-50psi and it still did it

CCLB with some stuff done .....


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BigRed97 is offline  
 
post #4 of 19 (permalink) Old 07-12-2008, 10:15 PM
Banned
 
Join Date: Jul 2007
Location: Twilightzone
Posts: 7,764
Re: help FAST..electric fuel problems(QUAD FEED)

It's just working the air out. It'll stop.
Charles is offline  
post #5 of 19 (permalink) Old 07-12-2008, 10:57 PM Thread Starter
The Oracle
 
BigRed97's Avatar
 
Join Date: Jan 2008
Location: Saugus MA
Posts: 2,777
Send a message via AIM to BigRed97
Re: help FAST..electric fuel problems(QUAD FEED)

great thats what i was hoping to hear

thanks Charles

CCLB with some stuff done .....


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BigRed97 is offline  
post #6 of 19 (permalink) Old 07-13-2008, 01:23 AM
Soon to be a 6.4
 
lildevil02's Avatar
 
Join Date: Jul 2007
Location: Raleigh NC
Posts: 2,116
Send a message via AIM to lildevil02
Re: help FAST..electric fuel problems(QUAD FEED)

Quote:
Originally Posted by Charles View Post
It's just working the air out. It'll stop.
I agree I have seen some of our JD tractors do the same thing when we change out a busted hdy line and get air in the system.
lildevil02 is offline  
post #7 of 19 (permalink) Old 07-13-2008, 02:55 AM
PSN Veteran
 
urbanwheeler's Avatar
 
Join Date: Nov 2007
Location: Chico, CA
Posts: 2,031
Re: help FAST..electric fuel problems(QUAD FEED)

all my air came out within a few minutes.

'96 f-250, auto, shackle flip, solid axle, rsk, high/crossover steering, 3.73's, true trac's front and rear, trac bars, gt4202, 7.3 ic, idm mod, ccv mod, A1000, 4-line DIY Gen3, dual ipr's, casserly 350/200's, arp studs, 910's, pushrods, elec. fan, 2-stage nitrous, fluidampr.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
[SIGPIC][/SIGPIC]
urbanwheeler is offline  
post #8 of 19 (permalink) Old 07-13-2008, 03:00 AM
Banned
 
Join Date: Jul 2007
Location: Twilightzone
Posts: 7,764
Re: help FAST..electric fuel problems(QUAD FEED)

Mine did machine gun fire out the return line for a minute or so, and then it was completely cleared up before I ever fired it.

I just cycled the key until it cleared out.
Charles is offline  
post #9 of 19 (permalink) Old 07-13-2008, 03:45 AM
Soon to be a 6.4
 
lildevil02's Avatar
 
Join Date: Jul 2007
Location: Raleigh NC
Posts: 2,116
Send a message via AIM to lildevil02
Re: help FAST..electric fuel problems(QUAD FEED)

Is it possible for the pump or a fitting to be sucking in air?
lildevil02 is offline  
post #10 of 19 (permalink) Old 07-13-2008, 03:52 AM Thread Starter
The Oracle
 
BigRed97's Avatar
 
Join Date: Jan 2008
Location: Saugus MA
Posts: 2,777
Send a message via AIM to BigRed97
Re: help FAST..electric fuel problems(QUAD FEED)

well i drove it for a few hours (hard) and its somewhat better, but it still does it....

CCLB with some stuff done .....


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BigRed97 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome