Rocker arm not moving very far - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 11-21-2019, 01:45 AM Thread Starter
PSN Newb
 
Join Date: Nov 2019
Posts: 7
Rocker arm not moving very far

Hi guys I'm new here. Also new to the diesel world. I have a 00 super duty 7.3 that lost number 5 injector. I went to replace it and found a bent pushrod on the right side valve. I replaced the pushrod and fired the truck up with the valve cover off and the side I replaced was working fine but the left side was barely moving. Maybe just enough to crack the valve open. Not sure if it's a bad lifter or what. Any advice would help. Thank you.
Leifshannon50 is online now  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 11-21-2019, 01:28 PM
Master BS'er
 
jamiesaun's Avatar
 
Join Date: Nov 2016
Location: Boise Idaho
Posts: 5,796
Re: Rocker arm not moving very far

Let it sit for a couple hours and see if the litter is spongy. When you push down on that rod, it should be firm and basically not move at all. Or take the rocker out of the way and see if the rod moves up as much as the other rods. If it does, the lifter is shot. If not, it's a wiped cam lobe.

Brother James

Ps...Im pretty frickin awesome!
jamiesaun is offline  
post #3 of 14 (permalink) Old 11-21-2019, 02:40 PM Thread Starter
PSN Newb
 
Join Date: Nov 2019
Posts: 7
Ok I'll give it a shot. Is there anyway to fish that lifter out or do you have to pull the head?
Leifshannon50 is online now  
 
post #4 of 14 (permalink) Old 11-21-2019, 04:25 PM
Master BS'er
 
jamiesaun's Avatar
 
Join Date: Nov 2016
Location: Boise Idaho
Posts: 5,796
Re: Rocker arm not moving very far

I'm not infinitely familiar with this engine, but I believe you do have to pull the head. Not sure though, someone else will know that

Brother James

Ps...Im pretty frickin awesome!
jamiesaun is offline  
post #5 of 14 (permalink) Old 11-21-2019, 05:28 PM
PSN Local
 
Join Date: Apr 2013
Posts: 129
Re: Rocker arm not moving very far

You can fish the lifter out and leave the head on, but you have to remove the sheetmetal intake plenum. That's sealed on with the special grey goo.

'01 F250 4x4 Crew Shorty, PM Rods, PIS 160/30's , Hydra, BW 364.5SXE, Monster Box, MBRP 4" 409 SSTL Exhaust, Firestone Ride-Rights, Regulated fuel return.
Dan V is offline  
post #6 of 14 (permalink) Old 11-22-2019, 03:37 AM Thread Starter
PSN Newb
 
Join Date: Nov 2019
Posts: 7
So does removing the plenum help you get in there from the other side?
Leifshannon50 is online now  
post #7 of 14 (permalink) Old 11-23-2019, 02:36 PM
PSN Local
 
Join Date: Apr 2013
Posts: 129
Re: Rocker arm not moving very far

Quote:
Originally Posted by Leifshannon50 View Post
So does removing the plenum help you get in there from the other side?
I might be wrong...i'm looking for a picture.

The head has to come off...sorry for the confusion.

'01 F250 4x4 Crew Shorty, PM Rods, PIS 160/30's , Hydra, BW 364.5SXE, Monster Box, MBRP 4" 409 SSTL Exhaust, Firestone Ride-Rights, Regulated fuel return.
Dan V is offline  
post #8 of 14 (permalink) Old Yesterday, 10:48 PM Thread Starter
PSN Newb
 
Join Date: Nov 2019
Posts: 7
Thanks for the help fellas. I've got a new question now. My #5 injector quit working, so I went to a friend of mines salvage yard and got 8 injectors off another 7.3l. I have tried 3 of them and none of them will fire. I also swapped the valve cover and harness off the other truck thinking it may be the problem but still no luck getting it to fire.
Leifshannon50 is online now  
post #9 of 14 (permalink) Old Today, 02:45 AM
Master BS'er
 
jamiesaun's Avatar
 
Join Date: Nov 2016
Location: Boise Idaho
Posts: 5,796
Re: Rocker arm not moving very far

You really need a labscope to see if the driver module is working or not, then go from there. Lots of things it could be, but it's probably the module.

Brother James

Ps...Im pretty frickin awesome!
jamiesaun is offline  
post #10 of 14 (permalink) Old Today, 03:30 AM Thread Starter
PSN Newb
 
Join Date: Nov 2019
Posts: 7
It would cause just the number 5 injector not to work?
Leifshannon50 is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome