High IPR duty cycle, low icp, hot hard start - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-12-2019, 08:03 PM Thread Starter
PSN Local
 
vick97psd's Avatar
 
Join Date: Aug 2012
Location: Hitchcock, Texas
Posts: 184
High IPR duty cycle, low icp, hot hard start

Ok I just rebuilt the fuel bowl, replaced the IPR, replaced all injector o-rings, and glow plugs. I know the icp is leaking a little bit but I don't think that's the problem.

It's a 2000 7.3 4x4 Excursion 280K, my wife was driving home from work and it died on her wouldn't start by the time I got home from work it started it took a little bit but started.


I checked icp, IPR, cmp with my AE and it wasn't really giving me anything definitive.


Kind of acted like fuel issue so I rebuilt the fuel bowl, good pressure after that. It took a little too long in my opinion to start cold and stranded me on the side of the road once it warmed up, so I replaced the IPR cause I was getting high duty cycle.


New IPR same thing, ordered alliant injector o-rings from diesel o-rings.com, same place I got everything for fuel bowl and IPR, new injector o-rings and seemed to be starting good and all was well.


Well I've learned my lesson and let it warm up before going on test drive, went to leave and no power, the duty cycle is at 93% icp is at 420ish at idle.

Truck is do for an oil change but I don't really see that being the real problem, it is my wife's truck and I don't want her and our kids getting stranded in the hot Texas summer because I changed the oil instead of fixing the real issue.

I did notice when revving it up, when I discovered the no power issue, that it was blowing some blue smoke but I would imagine that is from the oil in the cylinders after doing the injector o-rings

And now once warm it's back to a no start, please someone help me out here.
vick97psd is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-14-2019, 11:07 AM
PSN Veteran
 
longjonsilver's Avatar
 
Join Date: Jun 2017
Location: Upstate South Carolina
Posts: 949
Re: High IPR duty cycle, low icp, hot hard start

Quote:
Originally Posted by vick97psd View Post
Ok I just rebuilt the fuel bowl, replaced the IPR, replaced all injector o-rings, and glow plugs. I know the icp is leaking a little bit but I don't think that's the problem.



It's a 2000 7.3 4x4 Excursion 280K, my wife was driving home from work and it died on her wouldn't start by the time I got home from work it started it took a little bit but started.





I checked icp, IPR, cmp with my AE and it wasn't really giving me anything definitive.





Kind of acted like fuel issue so I rebuilt the fuel bowl, good pressure after that. It took a little too long in my opinion to start cold and stranded me on the side of the road once it warmed up, so I replaced the IPR cause I was getting high duty cycle.





New IPR same thing, ordered alliant injector o-rings from diesel o-rings.com, same place I got everything for fuel bowl and IPR, new injector o-rings and seemed to be starting good and all was well.





Well I've learned my lesson and let it warm up before going on test drive, went to leave and no power, the duty cycle is at 93% icp is at 420ish at idle.



Truck is do for an oil change but I don't really see that being the real problem, it is my wife's truck and I don't want her and our kids getting stranded in the hot Texas summer because I changed the oil instead of fixing the real issue.



I did notice when revving it up, when I discovered the no power issue, that it was blowing some blue smoke but I would imagine that is from the oil in the cylinders after doing the injector o-rings



And now once warm it's back to a no start, please someone help me out here.


Pull the valve covers while the engine is hot and look for a oil leak from one or more of the injectors. You may have a defective HPOP . Also when it wont restart hot do you show oil pressure on the gauge in the dash ?



Sent from my iPhone using Tapatalk
longjonsilver is offline  
post #3 of 4 (permalink) Old 06-14-2019, 02:40 PM
Project Shamu
 
Lt.Dan's Avatar
 
Join Date: Mar 2015
Location: Visalia, Ca
Posts: 1,922
Re: High IPR duty cycle, low icp, hot hard start

If the IPR is fully closed, then its desperately trying to build HPO. I would do what longjonsilver said above, pull valve covers and run the truck to check if injectors are pissing oil


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1996 Cali F350 CCFB, 7.3 PSD, 2wd SAS, w/ 378,000 miles.
New Motor at 352,000, DieselSite Legendary Trans at 356,000 and many more


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1983 F150 SCSB Flareside, 302 w/ AOD Trans


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2002 F450 SCFB, 7.3 PSD 2wd w/ 144,000 miles
SOLD
Lt.Dan is offline  
 
post #4 of 4 (permalink) Old 06-14-2019, 08:09 PM
PSN Local
 
2000f250's Avatar
 
Join Date: Jul 2017
Posts: 222
Re: High IPR duty cycle, low icp, hot hard start

If you can get it running with the power it has need to try a full throttle run on it and watch icp and ipr and see what they hold bet it has a weak hpop and that could cause low power and height duty cycle. A cut o ring a injector not seated all the way can cause problems as well. Here a link that should help you. https://oregonfuelinjection.com/cont...diagnostic.pdf


Sent from my iPhone using Tapatalk
2000f250 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome