99 7.3 skipping at startup and smokes - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-19-2019, 12:53 AM Thread Starter
PSN Newb
 
Join Date: Mar 2019
Posts: 2
99 7.3 skipping at startup and smokes

My son got a 99 f250 7.3 a two years ago and it sit till he got 16. It was running and quit on a family friend and he sold it to him for just a little because he liked it. Now he is ready to start working on it but it skipped bad. We pulled the valve covers checked the glow plugs all good, then we started the truck and unplugged the injectors one by one and 1,3 and 7 did not change the motor. We checked the wiring with a meter and replaced the injectors. Now the truck runs good when warm but skips when cold. It also smokes alot on startup and never fully quits but it gets light.

Not sure of next steps.

Thanks,
jjmiller is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-19-2019, 01:11 AM
PSN Local
 
2000f250's Avatar
 
Join Date: Jul 2017
Posts: 216
Re: 99 7.3 skipping at startup and smokes

Quote:
Originally Posted by jjmiller View Post
My son got a 99 f250 7.3 a two years ago and it sit till he got 16. It was running and quit on a family friend and he sold it to him for just a little because he liked it. Now he is ready to start working on it but it skipped bad. We pulled the valve covers checked the glow plugs all good, then we started the truck and unplugged the injectors one by one and 1,3 and 7 did not change the motor. We checked the wiring with a meter and replaced the injectors. Now the truck runs good when warm but skips when cold. It also smokes alot on startup and never fully quits but it gets light.



Not sure of next steps.



Thanks,


How many miles on it how does it start cold does it act like it running on sticking injectors and then clears when warm. You might need to replace a few more injectors. A good practice is to replace injectors in sets if money allows it.


Sent from my iPhone using Tapatalk
2000f250 is offline  
post #3 of 7 (permalink) Old 03-19-2019, 01:24 AM Thread Starter
PSN Newb
 
Join Date: Mar 2019
Posts: 2
Re: 99 7.3 skipping at startup and smokes

The truck has 380k miles. You have to crank it over a couple times before it starts then it is skipping, if you let it run a little bit or give it a little fuel it will pour out smoke but then the smoke gets light and the motor starts hitting on all 8.
jjmiller is offline  
 
post #4 of 7 (permalink) Old 03-19-2019, 01:51 AM
PSN Local
 
2000f250's Avatar
 
Join Date: Jul 2017
Posts: 216
Re: 99 7.3 skipping at startup and smokes

The best corse of action in my opinion would be replace the 5 injectors that you did not replace. If you plan on keeping the truck. Does it use any oil. Is there a chip or a tuner on the truck. Is the turbo in good shape. Does it have good power after it gets warmed up.


Sent from my iPhone using Tapatalk
2000f250 is offline  
post #5 of 7 (permalink) Old 03-21-2019, 11:34 AM
PSN Newb
 
Join Date: Mar 2019
Posts: 8
Re: 99 7.3 skipping at startup and smokes

You might try running a fuel cleaner through it, and replace the fuel filter. My 02 was having cold start issues, ran a double dose of cleaner through one tank and it cleared right up

Sent from my SM-G975U using Tapatalk
tda271 is offline  
post #6 of 7 (permalink) Old 03-21-2019, 12:04 PM
Master BS'er
 
jamiesaun's Avatar
 
Join Date: Nov 2016
Location: Boise Idaho
Posts: 5,519
Re: 99 7.3 skipping at startup and smokes

Quote:
Originally Posted by 2000f250 View Post
The best corse of action in my opinion would be replace the 5 injectors that you did not replace. If you plan on keeping the truck. Does it use any oil. Is there a chip or a tuner on the truck. Is the turbo in good shape. Does it have good power after it gets warmed up.


Sent from my iPhone using Tapatalk
Pretty much. Replace the other injectors and go from there.

Brother James

Ps...Im pretty frickin awesome!
jamiesaun is offline  
post #7 of 7 (permalink) Old 03-23-2019, 01:10 AM
PSN Local
 
Philhan69@aol.com's Avatar
 
Join Date: Jul 2017
Location: Gaffney S.C.
Posts: 206
Re: 99 7.3 skipping at startup and smokes

Just replaced injectors on mine and it runs great. Before it would run terrible until it got warmed up. Would shake and vibrate the whole truck. I would also replacing the other 5 so that they are all new.

Sent from my SM-G955U using Tapatalk
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
06 F250 6.0 skipping at idle and slowing down. Transmission not holding 5 TCL 06Jtbear 6.0L Power Stroke Technical Info 9 04-11-2013 04:50 PM
Need help! lots of white smoke when cold and skipping mainer815 7.3L Power Stroke Technical Info 2 10-26-2012 02:51 AM
Engines smokes white startup and after idle KeithW 7.3L Power Stroke Technical Info 11 09-20-2012 09:14 AM
making a slite skipping and hissing sound strokedout73 6.0L Power Stroke Technical Info 1 11-29-2010 03:45 PM
7.3 shaking, and skipping. smitty16s 7.3L Power Stroke Technical Info 8 07-11-2008 01:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome