6.0 turbo trouble - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-16-2010, 06:03 AM Thread Starter
PSN Veteran
 
Twan's Avatar
 
Join Date: Sep 2010
Location: Lovland, Co
Posts: 571
6.0 turbo trouble

I just had my turbo go out on my 2006 and ford put one on under warrenty, and it the inside was all rusted and they will not warrenty it again, so i order the garrett gt3788va and was wounder how they spool vs the stockers, the truck is all stock.
Twan is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-19-2010, 01:47 AM Thread Starter
PSN Veteran
 
Twan's Avatar
 
Join Date: Sep 2010
Location: Lovland, Co
Posts: 571
Re: 6.0 turbo trouble

Anything will help, i pull anywhere from 8 to 25k, and would like to know if this trubo will work. thanks
Twan is offline  
post #3 of 6 (permalink) Old 09-19-2010, 02:58 AM
PSN Local
 
douglash's Avatar
 
Join Date: Mar 2010
Posts: 54
Re: 6.0 turbo trouble

I just put one on a few months ago. I really like it. There can be a little more lag. The only thing I don't like is the noise. It is really loud. I would make sure to have gauges. I tow around 10k. What impressed me was pulling a hill the egts were starting to push 1150 and all I had to do to push the pedal down enough to downshift and the egts would drop. the stock would never do that. I also have IDP tunes, 4" exhaust and gauges.

2004 EB Excursion
douglash is offline  
 
post #4 of 6 (permalink) Old 09-21-2010, 12:54 AM Thread Starter
PSN Veteran
 
Twan's Avatar
 
Join Date: Sep 2010
Location: Lovland, Co
Posts: 571
Re: 6.0 turbo trouble

I do have the gauges, 2 egt, boost, trany, volt, just got the stage 2 S&B intake, thinking about the exhust. How dose the turbo light when you are pulling on hot days, do you have have to think twice about pull onto, infront of cars! What kind of egts did you hit with the stock turbo, i was running 1100, 1200 on flats and 1350 on hills with my 5th gross weight 27k. thanks.
Twan is offline  
post #5 of 6 (permalink) Old 09-21-2010, 03:02 PM
PSN Local
 
douglash's Avatar
 
Join Date: Mar 2010
Posts: 54
Re: 6.0 turbo trouble

I only pull around 10k. I think the stock turbo would have went to 1800 no problem but I always let off around 1200. With this one I just make it kick down a gear and it will stay below 1200 all day long. I can pull hills and never lose speed which I always had to let off and slow down.

Over labor day (upper 80's low 90's) I was pulling 4 hours into 30 mph + head winds. My 35" tires really made my truck work hard. I still got 8.9 mpg but I was running 70 -75.

I was at a stop light with my trailer on a steep hill and it lagged a little before she started moving. I think with more weight there might be more lag. Merging on the highway normal (flatter) stop lights I have little to no more lag then stock. Eric did say with the extreme tune it doesn't have this lag issue but I will not tow with that tune. I love this turbo but it is a loud sob. If fits what I need. Maybe someone who towes near your weight can help out.

Thanks
Douglas

2004 EB Excursion
douglash is offline  
post #6 of 6 (permalink) Old 09-21-2010, 10:36 PM Thread Starter
PSN Veteran
 
Twan's Avatar
 
Join Date: Sep 2010
Location: Lovland, Co
Posts: 571
Re: 6.0 turbo trouble

Thanks for the info, how much power is the tune your running, how much boost you seeing? Any injector, head studs trouble?

Thanks
Anthony
Twan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome