Who is running a FASS and have never had a problem with it? - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 08-23-2010, 02:33 PM Thread Starter
Joe
 
flexyford's Avatar
 
Join Date: Sep 2009
Location: Fremont Wisconsin
Posts: 278
Who is running a FASS and have never had a problem with it?

Exactly as the title sais i got an old style FASS pump on the way and am just wondering everyone elses experience with it. Good bad and ugly.

2009 F-250 CCSB Lariat, 5" Flo Pro, Minni Maxx, S&B, HID's, Visionary Metals Traction Bars.
flexyford is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 08-23-2010, 03:29 PM
PSN Veteran
 
Extended Power's Avatar
 
Join Date: Aug 2007
Location: Alberta, Canada
Posts: 1,856
Re: Who is running a FASS and have never had a problem with it?

Kinda silly to ask that question AFTER you bought it isn't it???

Not gonna get too many that are gonna say they never had ANY issues with them.

I went through 2 electric motors, and sold it with the new third one in it....and that was after the "Oh, well now we have a new gear material...blah, blah, blah......you won't have any issues now..."

2003 F-350 KingRanch 4x4
Extended Power is offline  
post #3 of 19 (permalink) Old 08-23-2010, 03:41 PM
PSN Veteran
 
AllanB's Avatar
 
Join Date: Mar 2009
Location: Mississippi
Posts: 728
Re: Who is running a FASS and have never had a problem with it?

Knock on wood. Never had a problem!!!

The world is a dangerous place to live, not because of the people who are evil, but becase of the people who do nothing about it.
--Albert Einstein
AllanB is offline  
 
post #4 of 19 (permalink) Old 08-23-2010, 03:59 PM
PSN Veteran
 
06powerstroke's Avatar
 
Join Date: Feb 2009
Location: Santa Clarita, SoCal
Posts: 3,600
Re: Who is running a FASS and have never had a problem with it?

My first FASS made it about 3 months before the motor died, I have about 8 months on the replacement and it is starting to sound funny. After my first motor died I carry a spare motor and T-block with me at all times. Don't want to be stranded again!

2006 F250 CC LB FX4 Lariat
ARP studs, SCT X3 IDP & Gearhead tuned, S&B CAI, straight pipe, FASS 150/180, FCDP solid uppipe, Dieselsite coolant filter
2.5" BTS leveling kit, 35" Xtreme A/T's on XD Hoss 18's, N-Fab prerunner bar w/ 3 9" Hellas
Pioneer double din, JL components, 3 10" Pioneer subs

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
06powerstroke is offline  
post #5 of 19 (permalink) Old 08-23-2010, 04:06 PM Thread Starter
Joe
 
flexyford's Avatar
 
Join Date: Sep 2009
Location: Fremont Wisconsin
Posts: 278
Re: Who is running a FASS and have never had a problem with it?

Quote:
Originally Posted by Extended Power View Post
Kinda silly to ask that question AFTER you bought it isn't it???

Not gonna get too many that are gonna say they never had ANY issues with them.

I went through 2 electric motors, and sold it with the new third one in it....and that was after the "Oh, well now we have a new gear material...blah, blah, blah......you won't have any issues now..."
I know i know...

2009 F-250 CCSB Lariat, 5" Flo Pro, Minni Maxx, S&B, HID's, Visionary Metals Traction Bars.
flexyford is offline  
post #6 of 19 (permalink) Old 08-23-2010, 04:43 PM
Sponsor
 
dalpilot's Avatar
 
Join Date: Jul 2007
Posts: 3,297
Re: Who is running a FASS and have never had a problem with it?

Richard, (Unbroken) pretty much did the first one on a 6.0. When the directions come, that is his hand your seeing in the pictures. He still has the original one in his truck.

I have an older style FASS in the Ranger, and it works fine, on that note, I have an AirDog in the red truck, and its never missed a beat either. I think just like the 6.0, you either got a good one or a bad one.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dalpilot is offline  
post #7 of 19 (permalink) Old 08-23-2010, 04:46 PM
PSN Veteran
 
CanadianRedneck's Avatar
 
Join Date: May 2008
Location: Fort McMurray, Alberta, CANADA
Posts: 583
Re: Who is running a FASS and have never had a problem with it?

Never had an issue with my pump yet and its still running strong.

2005 F350 Crewcab 4x4 6.0L
64mm turbo, NADP race tranny, tuning by Eric at Innovative Diesel
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 F250 4x4 6.0L
Work in progress.......
EDE heads, cam, pistons, hybrid injectors, Hypermax rods,
2 really big turbos and a whole bunch of other crap to come.....
Tuning by Innovative of course!
CanadianRedneck is offline  
post #8 of 19 (permalink) Old 08-23-2010, 04:49 PM
PSN Veteran
 
Redneck6.0L's Avatar
 
Join Date: Mar 2008
Posts: 1,960
Re: Who is running a FASS and have never had a problem with it?

I had the same fass pump in my truck from 05 till this spring, the only reason I changed it was because I ripped the wires out of it. Idiot lol

2006 F-350 crew cab dually 4X4
225cc injectors, CRD twin turbo's
Fueled by Gibson's

2003 F-350 crew cab
[email protected]


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Redneck6.0L is offline  
post #9 of 19 (permalink) Old 08-23-2010, 05:03 PM
Sponsor
 
dalpilot's Avatar
 
Join Date: Jul 2007
Posts: 3,297
Re: Who is running a FASS and have never had a problem with it?

Quote:
Originally Posted by Redneck6.0L View Post
I had the same fass pump in my truck from 05 till this spring, the only reason I changed it was because I ripped the wires out of it. Idiot lol
Flossing with it again?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dalpilot is offline  
post #10 of 19 (permalink) Old 08-23-2010, 05:04 PM
BRING DA AMBALAMPS
 
stroke of luck's Avatar
 
Join Date: Nov 2008
Location: Dallas, Tejas
Posts: 1,952
Re: Who is running a FASS and have never had a problem with it?

mines on it's second motor but no issues on this one for about 20k

2005 CC FX4...compounds and everything else that goes with em.
stroke of luck is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome