Coolant issues......?????? - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-11-2010, 11:52 PM Thread Starter
PSN Local
 
6oh stroker's Avatar
 
Join Date: Jan 2010
Posts: 265
Coolant issues......??????

I have FIRERINGED heads from hypermax, And yes they do machine the heads for these gaskets...........

I have innovative tunes, which run crazy cylinder pressures.. I started pushing coolant last Monday... I have been drivin the truck off and on since then, but the last time that I drove it was this Tuesday(March, 9th).. I just went out side to look and see if there was coolant still ON the degas bottle, and there wasnt. But when i cracked the bottle open, there was still pressure in there from almost 3 days ago... If i was pressurising the coolant system, there should be a leak somewhere, and the pressure should have been slowly leaking, but why the PHUCK is there still pressure in the system......... On my way home tuesday i was givin her HELL, the clutch hated me too, and after givin her hell I still didnt see any signs of coolant leakin....
I was ready to pull the cab but now im second guessing the gasket issues... any help would be amazing.....

06 250 CC/SB 6 speed
Aeromotive A1000
Aeromotive regulator
Caterpiller filters
SCT tunes from Rcd
Arp's
full egr delete
6oh stroker is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-11-2010, 11:58 PM
FREE THINKER
 
Chip's Avatar
 
Join Date: Mar 2008
Location: Galveston TX.
Posts: 703
Re: Coolant issues......??????

might be the cap itself? just a guess

1999 7.3, 2wd ,auto
Chip is offline  
post #3 of 12 (permalink) Old 03-12-2010, 01:40 AM Thread Starter
PSN Local
 
6oh stroker's Avatar
 
Join Date: Jan 2010
Posts: 265
Re: Coolant issues......??????

Anyone.......

06 250 CC/SB 6 speed
Aeromotive A1000
Aeromotive regulator
Caterpiller filters
SCT tunes from Rcd
Arp's
full egr delete
6oh stroker is offline  
 
post #4 of 12 (permalink) Old 03-12-2010, 02:21 AM
It wasn't me
 
offroadinginaz's Avatar
 
Join Date: Apr 2008
Location: Gilbert, Arizona
Posts: 1,232
Re: Coolant issues......??????

I've had a few bad caps

Newman
A few Fords
Special Thanks to:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
offroadinginaz is offline  
post #5 of 12 (permalink) Old 03-12-2010, 02:52 AM
reluctant ford fan
 
Join Date: Jun 2009
Location: Cave Creek AZ
Posts: 127
Re: Coolant issues......??????

Quote:
Originally Posted by offroadinginaz View Post
I've had a few bad caps
And a few other minor issues.


04 X/4wd/EB/6.no-leaker thanks to Strictly Diesel!
brian is offline  
post #6 of 12 (permalink) Old 03-12-2010, 03:06 PM
Captain Negativity!
 
PSDPlayer's Avatar
 
Join Date: Jul 2007
Location: Ft Lauderdale, FL
Posts: 3,109
Send a message via AIM to PSDPlayer
Re: Coolant issues......??????

Quote:
Originally Posted by 6oh stroker View Post
I have FIRERINGED heads from hypermax, And yes they do machine the heads for these gaskets...........

I have innovative tunes, which run crazy cylinder pressures.. I started pushing coolant last Monday... I have been drivin the truck off and on since then, but the last time that I drove it was this Tuesday(March, 9th).. I just went out side to look and see if there was coolant still ON the degas bottle, and there wasnt. But when i cracked the bottle open, there was still pressure in there from almost 3 days ago... If i was pressurising the coolant system, there should be a leak somewhere, and the pressure should have been slowly leaking, but why the PHUCK is there still pressure in the system......... On my way home tuesday i was givin her HELL, the clutch hated me too, and after givin her hell I still didnt see any signs of coolant leakin....
I was ready to pull the cab but now im second guessing the gasket issues... any help would be amazing.....
How much pressure are we talking about? 1psi? 15psi? The pressure is there as your friend to help you raise the boiling point of the fluid. The rate at which the pressure builds is a whole other story.

Email:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Phone:954-275-6801 Leave me a message. I can't always answer.
05 CC LB DRW Lariat 4x2 Dropped 3/6.
PSDPlayer is offline  
post #7 of 12 (permalink) Old 03-12-2010, 07:02 PM Thread Starter
PSN Local
 
6oh stroker's Avatar
 
Join Date: Jan 2010
Posts: 265
Re: Coolant issues......??????

I would say 5 psi..... Was left in the system. Hard to judge though, I never herd of it holdin pressure that long though!!! I'll have go beat the hell outta her and find out what's the deal!!! Thanks Doug!

06 250 CC/SB 6 speed
Aeromotive A1000
Aeromotive regulator
Caterpiller filters
SCT tunes from Rcd
Arp's
full egr delete
6oh stroker is offline  
post #8 of 12 (permalink) Old 03-12-2010, 09:53 PM
It wasn't me
 
offroadinginaz's Avatar
 
Join Date: Apr 2008
Location: Gilbert, Arizona
Posts: 1,232
Re: Coolant issues......??????

Quote:
Originally Posted by brian View Post
And a few other minor issues.

Smartass!

Newman
A few Fords
Special Thanks to:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
offroadinginaz is offline  
post #9 of 12 (permalink) Old 03-12-2010, 10:17 PM
PSN Veteran
 
Binder man's Avatar
 
Join Date: Sep 2008
Location: Nashville, TN/ Worthington, IN
Posts: 1,168
Re: Coolant issues......??????

I'm in the same boat right now. Except I'm losing a gallon of coolant every 3K miles or less. Put dye in it and blacklighted it checking for leaks and nothing :bonk: Anywhere to look other than heads?

Early 99, regular cab, Six Speed, Wildman Tuned, Red wastegate line MIA, muffler MIA, Isspro EGT/Boost, DIY Tymar, EBPV Switch, a slipping South Bend, 2.5" leveling kit, 35x12.5 BFG All-Terrains, 16.5" American Racing wheels SOLD
04, red regular cab, six speed, Edge SOLD
97, silver regular cab 300/200 s300
Binder man is offline  
post #10 of 12 (permalink) Old 03-13-2010, 02:32 AM
Hate 'R Us
 
!!!PainTrain!!!'s Avatar
 
Join Date: Jul 2007
Location: Haterville
Posts: 2,436
Re: Coolant issues......??????

Quote:
Originally Posted by Binder man View Post
I'm in the same boat right now. Except I'm losing a gallon of coolant every 3K miles or less. Put dye in it and blacklighted it checking for leaks and nothing :bonk: Anywhere to look other than heads?
The tailpipe might be a good place to start


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
!!!PainTrain!!! is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome