06 6.0 problems? - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-05-2014, 05:07 AM Thread Starter
PSN Newb
 
Join Date: May 2014
Posts: 2
06 6.0 problems?

Bought a 06 6.0, had 145k mi when bought it, has 160k on it now, last week it would start fine when engine was cold but if hot it would crank but no start, today it shut off while going down the hiway & cranks but no start, retrieved these codes, po2290,p2617,p0460,&p2614, is it the ficm, high oil pressure leak, or hpop itself that's the problem? Thankyou

Last edited by albie; 05-05-2014 at 05:09 AM. Reason: mispelling
albie is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-06-2014, 12:04 AM Thread Starter
PSN Newb
 
Join Date: May 2014
Posts: 2
Re: 06 6.0 problems?

No feedback????
albie is offline  
post #3 of 5 (permalink) Old 05-06-2014, 01:16 AM
JGman141
 
Jgman141's Avatar
 
Join Date: Oct 2012
Location: Ohio
Posts: 859
Re: 06 6.0 problems?

Sounds like you have a high pressure oil leak, time to update the stc fitting and the oil feed tubes.

2004 6.0 ccsb Warren 430/150 hybrids, Warren Comp Trans, Warren Dual Hpop, Billet S475 w/race cover, Marty's A1000 Fuel System, Colt Stage 2, and all the other supporting stuff
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jgman141 is offline  
 
post #4 of 5 (permalink) Old 05-06-2014, 02:38 AM
Jig350
 
Join Date: May 2014
Posts: 1
Re: 06 6.0 problems?

Hey I got 05 350 with a 6 litre. I had similar issues took to many mechanics they ended up all saying oil pressure issues After getting engine to workin temp and shut off it won't start for 45-60 mins. I was sick paying mechanics to guess. So I ended up adding Lucas oil stabalizer 2-3 liters and 15-40 oil,when i changed oil.I've burnt a tank of fuel and it starts when hot now. So I figure u run a thicker oil and let the viscosity do the work. It worked for mine!!
Jig1981 is offline  
post #5 of 5 (permalink) Old 05-06-2014, 05:22 AM
PSN Local
 
cope102's Avatar
 
Join Date: May 2013
Location: Fort Worth, Tx
Posts: 166
Re: 06 6.0 problems?

it seems you have an hpop leak but i would run some test first.. i could be wrong but i believe p2290 is for the icp sensor.. i would check it, check yr ficm voltage and if those are both good i would do an air test if you can and test yr ipr that will definatly determine whether you have a bad ipr or an hpop leak...

2004 F350 DRW FX4 Banks Six Gun Tuner,Egr delete, Adrenaline pump, Banks air, 4 inch straight pipe exhaust
cope102 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome