issue after tuner install - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-10-2014, 01:21 AM Thread Starter
PSN Newb
 
Join Date: Feb 2014
Posts: 34
issue after tuner install

I just installed a edge cs w/juice and attitude and I am not getting a reading on the boost pressure gauge and also can't really tell a difference in how the truck performs by the way its a 2005 ccsb fx4 also just installed a full 4"exhaust
CYIZEAL is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-10-2014, 09:53 AM
"Slap hands slap hands"
 
FlossyB's Avatar
 
Join Date: Sep 2013
Location: Las Vegas
Posts: 1,488
Re: issue after tuner install

My friendly advice is to only use Edge for monitoring and get a SCT programmer. I had a edge blow up on me and it caused a lot of problems and almost left me stranded with my truck not being able to turn off. Heard of a lot of guys having similar issues with them. When mine did work I didn't like it it wasn't even clots to the SCT and is really hard on your transmission on certain programs.

JB
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
FlossyB is offline  
post #3 of 6 (permalink) Old 03-11-2014, 03:01 AM Thread Starter
PSN Newb
 
Join Date: Feb 2014
Posts: 34
Re: issue after tuner install

Well I've never had an issue with edge but problem is resolved called edge the cs tuner needed updated and now it's a different truck
CYIZEAL is offline  
 
post #4 of 6 (permalink) Old 03-11-2014, 04:15 AM
"Slap hands slap hands"
 
FlossyB's Avatar
 
Join Date: Sep 2013
Location: Las Vegas
Posts: 1,488
Re: issue after tuner install

Glad you got it figured out good luck with your edge. Everyone I have talked to says its not if it's when with the edge on the 6.0 causing problems just trying to help you out. My mechanic and almost everyone on here runs SCT for that reason. My mechanic sad he has replaced 100s of Edges after they have failed or created $1000s of damage to peoples 6.0s.

JB
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
FlossyB is offline  
post #5 of 6 (permalink) Old 03-12-2014, 11:05 AM
PSN Local
 
Join Date: Aug 2012
Posts: 128
Re: issue after tuner install

Good luck make sure your starting a fund to replace your trans soon... know way to many people who break due to edge... good luck...

Dan / Dando
04 F-250 CCSB, she's got stuff...
DieselShopCT.com


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GatorBaitR6 is offline  
post #6 of 6 (permalink) Old 03-13-2014, 02:19 AM Thread Starter
PSN Newb
 
Join Date: Feb 2014
Posts: 34
Re: issue after tuner install

Not really hammering on the truck was really looking at taking advantage of getting better mpg and it was a smoking deal on the edge is the only reason I got it
CYIZEAL is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome