Horrible Tech Support @ SCT - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 07-20-2012, 02:06 PM Thread Starter
PSN Newb
 
Join Date: Apr 2012
Location: Spartanburg, SC
Posts: 24
Horrible Tech Support @ SCT

Ok, I don't usually like to blast someone but I am fed up with SCT! I have been trying to call them all week, sent multiple emails and sat on their online support all week and sent the message after it times out. The scrolling message that an associate will be with me shortly is a JOKE!!!

Finally got the updater installed and still had to manually install the drivers for the X3. I am currently in the process of updating the X3 on my own but it has been on the same screen for the past 20 minutes and nothing is changing other than the green bar trying to be knight rider under the exclamation icon.

And as I am typing this, my latest tech support window has timed out and wants me to send a message to their staff which will never be responded to.

I had seen online where tech support was awesome and got their product up and running quickly. Well I guess if you consider a week and counting awesome...

Oh well, maybe I will have a tuner within a week or 20 that will work...

Don't know if they read their emails so maybe they will see this.

2006 F-250 FX4 4x4 Extended Cab
6.0 Auto
ARP Studs, Blue Spring, Black Onyx HG's, EGR Deleted, 4" Exhaust, SCT X3
2006.0FX4 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 07-20-2012, 02:50 PM Thread Starter
PSN Newb
 
Join Date: Apr 2012
Location: Spartanburg, SC
Posts: 24
Re: Horrible Tech Support @ SCT

Well, it is still "thinking" about doing the firmware update. I have to go to work so I am going to let it sit while I am at work. My luck they will call or email while I am there...guess I will keep them on hold while I drive back to the tuner and laptop.

2006 F-250 FX4 4x4 Extended Cab
6.0 Auto
ARP Studs, Blue Spring, Black Onyx HG's, EGR Deleted, 4" Exhaust, SCT X3
2006.0FX4 is offline  
post #3 of 16 (permalink) Old 07-20-2012, 02:52 PM
Gambled and Lost 6.oh
 
ksieckmann's Avatar
 
Join Date: Aug 2011
Location: Midwest - where we love the USA
Posts: 927
Re: Horrible Tech Support @ SCT

they do have a long hold time.. but theyre the only flash tuner for the 6.0 lol

'05 CCSB FX4
Deleted, Studded, SCT w/ Vivian's Looney Wild, Warrens 190cc. DieselRX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ksieckmann is offline  
 
post #4 of 16 (permalink) Old 07-20-2012, 03:05 PM Thread Starter
PSN Newb
 
Join Date: Apr 2012
Location: Spartanburg, SC
Posts: 24
Re: Horrible Tech Support @ SCT

I understand a long hold time...but a week is a little excessive don't you think...

2006 F-250 FX4 4x4 Extended Cab
6.0 Auto
ARP Studs, Blue Spring, Black Onyx HG's, EGR Deleted, 4" Exhaust, SCT X3
2006.0FX4 is offline  
post #5 of 16 (permalink) Old 07-20-2012, 03:38 PM
PSN Local
 
Kbryant777's Avatar
 
Join Date: Apr 2012
Location: Stilesville, IN
Posts: 159
Re: Horrible Tech Support @ SCT

I have honestly never had bad support from them. Maybe on hold for 10-15 min but they have always helped me out. Sorry to hear about your experience. Hope you get it worked out

[B]2005 F250 King Ranch
Studs,egr delete, regulated return,RCD 68powermax, banks CAI,FICM tunes from PHP, Tuned by Eric
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kbryant777 is offline  
post #6 of 16 (permalink) Old 07-20-2012, 05:31 PM
PSN Local
 
Join Date: Sep 2008
Location: Alberta, Canada
Posts: 357
Re: Horrible Tech Support @ SCT

i would check your computer. i have had problems when trying to download things through ie9.

i've also had good luck with their tech support.
sonic blue l is offline  
post #7 of 16 (permalink) Old 07-20-2012, 05:42 PM
Gambled and Lost 6.oh
 
ksieckmann's Avatar
 
Join Date: Aug 2011
Location: Midwest - where we love the USA
Posts: 927
Re: Horrible Tech Support @ SCT


'05 CCSB FX4
Deleted, Studded, SCT w/ Vivian's Looney Wild, Warrens 190cc. DieselRX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ksieckmann is offline  
post #8 of 16 (permalink) Old 07-20-2012, 05:43 PM
Gambled and Lost 6.oh
 
ksieckmann's Avatar
 
Join Date: Aug 2011
Location: Midwest - where we love the USA
Posts: 927
Re: Horrible Tech Support @ SCT

what version of windows are you running?

'05 CCSB FX4
Deleted, Studded, SCT w/ Vivian's Looney Wild, Warrens 190cc. DieselRX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ksieckmann is offline  
post #9 of 16 (permalink) Old 07-20-2012, 06:31 PM
PSN Local
 
mantis118's Avatar
 
Join Date: Apr 2012
Location: Nederland Tx
Posts: 85
Re: Horrible Tech Support @ SCT

Every time i call them ive been on hold for 20-30 mins. Then told i have to pay fir this or that. And there 7 say turn around that took a month...

06 KR F250 4X4 egr delete 4" straight pipe exhaust blue spring 6.4 banjos SCT tune. Sold
04 comp orange cobra way to much to list here....sold.
03 F250XL regular cab 4x4 - fuel lab fuel system with sumped tank, wheel, cold air, full exhaust, bags and horns.
2012 Boss 302- twin 60s, full suspension, t56 magnum.
mantis118 is offline  
post #10 of 16 (permalink) Old 07-20-2012, 09:11 PM Thread Starter
PSN Newb
 
Join Date: Apr 2012
Location: Spartanburg, SC
Posts: 24
Re: Horrible Tech Support @ SCT

Running win xp. Still no response from sct...

2006 F-250 FX4 4x4 Extended Cab
6.0 Auto
ARP Studs, Blue Spring, Black Onyx HG's, EGR Deleted, 4" Exhaust, SCT X3
2006.0FX4 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome