fuel pressure question - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-25-2012, 10:50 PM Thread Starter
PSN Local
 
Join Date: Apr 2012
Location: rockford il
Posts: 171
fuel pressure question

i have a Regulated Return Kit and it eliminates the blue spring so what should i set my fuel pressure at on the regulater
what a mess is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-25-2012, 11:01 PM
matt
 
mgeistman's Avatar
 
Join Date: Nov 2011
Location: victoria texas
Posts: 911
Re: fuel pressure question

65+- is where I keep mine

4'' exhaust, egr delete, upgraded oil cooler, arp studs,50mm BOV, volant CAI, 66/73/.91 turbo, 205/100 injectors, crossover fuel line, airdog II, sct by TSD & ID, high idle mod, nitrous express with .092 jet, 26 GPH water/meth, ats stage 3 tranny, king Ranch front and rear captins chairs, and of course kicker sound system
mgeistman is offline  
post #3 of 9 (permalink) Old 05-25-2012, 11:26 PM
I Love Work'N On Hot Rods
 
windrunner408's Avatar
 
Join Date: Jun 2011
Posts: 1,549
Re: fuel pressure question

Yep that is where I keep mine too.

Nate
06 F350 4x4: Non-VGT 67mm Turbo, WPE Big Oil HPOP, HD 215/85s, Race Ported Intake, NB/Warren Tranny, and some other stuff.... 100k miles and counting....

06 F250 2wd: Stock... EGR delete, Race Ported Intake, and a mild street tune.... Leaking HGs
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


WINDRUNNER PERFORMANCE ENGINEERING (WPE)
windrunner408 is offline  
 
post #4 of 9 (permalink) Old 05-26-2012, 01:55 AM Thread Starter
PSN Local
 
Join Date: Apr 2012
Location: rockford il
Posts: 171
Re: fuel pressure question

ok thank you much i have mine set on 65 but i wasnt 100% sure i have stock injectors atm should i leave it there or bump it up and would that affect gas milage? cause i went from 15-10 =(
what a mess is offline  
post #5 of 9 (permalink) Old 05-26-2012, 02:03 AM
I Love Work'N On Hot Rods
 
windrunner408's Avatar
 
Join Date: Jun 2011
Posts: 1,549
Re: fuel pressure question

You mean your fuel mileage dropped by 5 mpg from installing JUST a RR kit!!!????

I would say you most likely have a fuel leak if that is the only mod you did and then noticed a drop in mileage.

Nate
06 F350 4x4: Non-VGT 67mm Turbo, WPE Big Oil HPOP, HD 215/85s, Race Ported Intake, NB/Warren Tranny, and some other stuff.... 100k miles and counting....

06 F250 2wd: Stock... EGR delete, Race Ported Intake, and a mild street tune.... Leaking HGs
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


WINDRUNNER PERFORMANCE ENGINEERING (WPE)
windrunner408 is offline  
post #6 of 9 (permalink) Old 05-26-2012, 02:10 PM
'05 Excursion
 
Term3's Avatar
 
Join Date: Jun 2011
Location: Edmonton, Alberta
Posts: 1,948
Quote:
Originally Posted by what a mess View Post
ok thank you much i have mine set on 65 but i wasnt 100% sure i have stock injectors atm should i leave it there or bump it up and would that affect gas milage? cause i went from 15-10 =(
Is this hand calculated or off the milage display?

SCT, no studs...yet, Dual OEM intake air filter housings, Banks intercooler & intake elbow, Banks exhaust syatem, Windrunner ported intake manifold, Bullet Proof Diesel remote oil cooler & thermostat, AirDog2 (plus a couple spares), Power steering filter (Amsoil dual-bypass), MagTec deep ATF pan, Electric oil pre-lub pump, Dakota Digital gauges.
Term3 is offline  
post #7 of 9 (permalink) Old 05-26-2012, 03:56 PM Thread Starter
PSN Local
 
Join Date: Apr 2012
Location: rockford il
Posts: 171
Re: fuel pressure question

no it droped a little after i started having hot start issues once we pulled the cab off and replaced stc fitting stand pipes dummy plugs added a powermax and intake manifold once i got it on the street again im getting 250 miles outa a tank of fuel
what a mess is offline  
post #8 of 9 (permalink) Old 05-26-2012, 04:09 PM
I Love Work'N On Hot Rods
 
windrunner408's Avatar
 
Join Date: Jun 2011
Posts: 1,549
Re: fuel pressure question

Are you still having starting issues?? I would put the truck on stock and check what sort of ICP you are getting. You could have a bad HPOP, ICP sensor, and/or IPR valve.

Nate
06 F350 4x4: Non-VGT 67mm Turbo, WPE Big Oil HPOP, HD 215/85s, Race Ported Intake, NB/Warren Tranny, and some other stuff.... 100k miles and counting....

06 F250 2wd: Stock... EGR delete, Race Ported Intake, and a mild street tune.... Leaking HGs
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


WINDRUNNER PERFORMANCE ENGINEERING (WPE)
windrunner408 is offline  
post #9 of 9 (permalink) Old 05-26-2012, 04:13 PM Thread Starter
PSN Local
 
Join Date: Apr 2012
Location: rockford il
Posts: 171
Re: fuel pressure question

no more hot start issues now u want me to put the program back to stock ?? and i replaced one of those the one on the valve cover on passanger side what else might be wrong then the hpop or icp can those be check with a scan tool or how abouts to i do that? thank you much
what a mess is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome