Question About MAF Sensor - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-26-2011, 02:31 PM Thread Starter
I Love Work'N On Hot Rods
 
windrunner408's Avatar
 
Join Date: Jun 2011
Posts: 1,549
Question About MAF Sensor

I have question regarding whether my MAF sensor is messed up or not. There IS definitely a noticeable way my engine behaves when the IAT reaches 80+ degrees F. What I am noticing is that while cruising down the road and IATs get over 80F that my required boost to maintain ~67mph goes from about 6-7psi on relatively flat level ground to around 9-10+psi. So my question is what could be causing this?? I have noticed that this WILL happen everytime IAT gets over 80F. Am I looking in the right direction by blaming the MAF sensor?

Nate
06 F350 4x4: Non-VGT 67mm Turbo, WPE Big Oil HPOP, HD 215/85s, Race Ported Intake, NB/Warren Tranny, and some other stuff.... 100k miles and counting....

06 F250 2wd: Stock... EGR delete, Race Ported Intake, and a mild street tune.... Leaking HGs
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


WINDRUNNER PERFORMANCE ENGINEERING (WPE)
windrunner408 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome