Problem with Airdog ii 165 on my 6.0 - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 09-28-2011, 03:24 AM Thread Starter
PSN Local
 
Join Date: Jun 2010
Location: Mountain View, Wyoming
Posts: 73
Problem with Airdog ii 165 on my 6.0

I keep popping fuses on my new airdog. Anyone else having this same problem?? Any ideas?? I have had the pump for all summer and then just today it blew the fuse twice after an hour of driving each time. wth?
skank is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 09-28-2011, 03:38 AM
PSN Veteran
 
rdunagan's Avatar
 
Join Date: May 2011
Location: Kerrville, Tx
Posts: 922
Re: Problem with Airdog ii 165 on my 6.0

ive heard of this problem before. there is a short in the wiring harness. call airdog tomorrow and tell them what its doing. the last guy that had this problem had to replace the whole wiring harness

2009 Ford F-350 FX4 4x4, H&S 300HD, MBRP 5" DP back exhaust, S&B intake, sinister egr delete, 4" BDS lift with fox shocks, 20x12 fuel nutz, 37" toyos, Custom painted headlights by me, fusion bumper with rigid led lights
rdunagan is offline  
post #3 of 13 (permalink) Old 09-28-2011, 03:44 AM Thread Starter
PSN Local
 
Join Date: Jun 2010
Location: Mountain View, Wyoming
Posts: 73
Re: Problem with Airdog ii 165 on my 6.0

Cool Thanks!
skank is offline  
 
post #4 of 13 (permalink) Old 09-28-2011, 04:58 PM
PSN Veteran
 
rdunagan's Avatar
 
Join Date: May 2011
Location: Kerrville, Tx
Posts: 922
Re: Problem with Airdog ii 165 on my 6.0

let me know what ya find out with airdog

2009 Ford F-350 FX4 4x4, H&S 300HD, MBRP 5" DP back exhaust, S&B intake, sinister egr delete, 4" BDS lift with fox shocks, 20x12 fuel nutz, 37" toyos, Custom painted headlights by me, fusion bumper with rigid led lights
rdunagan is offline  
post #5 of 13 (permalink) Old 09-28-2011, 05:11 PM Thread Starter
PSN Local
 
Join Date: Jun 2010
Location: Mountain View, Wyoming
Posts: 73
Re: Problem with Airdog ii 165 on my 6.0

Just got off the phone with AD. They said to take the rotor out of the end of the pump and turn the key on and see if it is running quiet. Then also take one of the screws out of the other end of the motor and see if there has been any contamination inside. They stated they would be happy to send out a new motor if water or fuel has gotten inside. Kinda frustrating. Especially when the damn thing left me stranded twice out on the interstate.
skank is offline  
post #6 of 13 (permalink) Old 09-28-2011, 05:23 PM
PSN Veteran
 
rdunagan's Avatar
 
Join Date: May 2011
Location: Kerrville, Tx
Posts: 922
Re: Problem with Airdog ii 165 on my 6.0

idk why they stated that. but then again they are the techs. i bet it has to do with some kinda wiring issue in the motor

2009 Ford F-350 FX4 4x4, H&S 300HD, MBRP 5" DP back exhaust, S&B intake, sinister egr delete, 4" BDS lift with fox shocks, 20x12 fuel nutz, 37" toyos, Custom painted headlights by me, fusion bumper with rigid led lights
rdunagan is offline  
post #7 of 13 (permalink) Old 09-28-2011, 10:21 PM
'05 Excursion
 
Term3's Avatar
 
Join Date: Jun 2011
Location: Edmonton, Alberta
Posts: 1,948
I've had an AD 2 for a couple years with no problems at all.

SCT, no studs...yet, Dual OEM intake air filter housings, Banks intercooler & intake elbow, Banks exhaust syatem, Windrunner ported intake manifold, Bullet Proof Diesel remote oil cooler & thermostat, AirDog2 (plus a couple spares), Power steering filter (Amsoil dual-bypass), MagTec deep ATF pan, Electric oil pre-lub pump, Dakota Digital gauges.
Term3 is offline  
post #8 of 13 (permalink) Old 09-28-2011, 10:26 PM
diesel and nothing else
 
amarillo250's Avatar
 
Join Date: Apr 2009
Location: Montreal/Canada
Posts: 1,620
Send a message via Yahoo to amarillo250
Re: Problem with Airdog ii 165 on my 6.0

I'm on my 3th. airdog and still got problems. Ask for Josh at AD.
I'm looking to replace the AD with something more reliable.

06 F250 CCSB, still working on it
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Thanks to FCDP and all the guys on here for their help.
amarillo250 is offline  
post #9 of 13 (permalink) Old 09-29-2011, 02:55 PM
PSN Local
 
whitestroke55's Avatar
 
Join Date: Mar 2011
Posts: 117
Re: Problem with Airdog ii 165 on my 6.0

Quote:
Originally Posted by donzimama View Post
aeromotive ftw
X2
whitestroke55 is offline  
post #10 of 13 (permalink) Old 09-29-2011, 05:05 PM
i like to party
 
pizza pig's Avatar
 
Join Date: Aug 2010
Posts: 1,415
Re: Problem with Airdog ii 165 on my 6.0

Quote:
Originally Posted by donzimama View Post
aeromotive ftw


pizza pig is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome