Front axles won't spin after rebuild ? Please helpppp - PowerStrokeNation : Ford Powerstroke Diesel Forum
 1Likes
  • 1 Post By matthewd11
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-13-2019, 04:11 PM Thread Starter
PSN Newb
 
Casper Amodio's Avatar
 
Join Date: Oct 2019
Posts: 3
Front axles won't spin after rebuild ? Please helpppp

So I was getting a clunking in the front end under acceleration and whenever I hit a bump, so went ahead and changed the U-joints... upon rebuild, after I put the shafts back in and torqued down the hub, the axles bound.... absolutely will not move.... anyone else have this problem? The is with the truck up on stands, in 2wd, and with the locking hubs still OUT ... loosened the hub, and they spin... front diff cover was off and the spider gears were still turning inside, ever tho the shaft wouldn't... wtf is going on? I can't find anything about this on the whole damn internet... they spun when I took it all apart..
Casper Amodio is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-13-2019, 04:32 PM Thread Starter
PSN Newb
 
Casper Amodio's Avatar
 
Join Date: Oct 2019
Posts: 3
2006 f250 btw
Casper Amodio is offline  
post #3 of 5 (permalink) Old 10-14-2019, 02:00 AM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,732
You may have not gotten the knuckle seals in correctly. What did you use to install them?
bismic1 likes this.

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
 
post #4 of 5 (permalink) Old 10-14-2019, 01:35 PM Thread Starter
PSN Newb
 
Casper Amodio's Avatar
 
Join Date: Oct 2019
Posts: 3
A 4" piece of pvc pipe... they looked to be set properly on the shaft and inside the hub....I did get the driver's side to free up last.. the pass. Side still wont move... the hubs obv spin... I think once I move the truck it should free up
Casper Amodio is offline  
post #5 of 5 (permalink) Old 10-14-2019, 02:04 PM
PSN Local
 
Randy4614's Avatar
 
Join Date: Feb 2018
Location: Middle of Montana
Posts: 99
Re: Front axles won't spin after rebuild ? Please helpppp

Quote:
Originally Posted by Casper Amodio View Post
A 4" piece of pvc pipe... they looked to be set properly on the shaft and inside the hub....I did get the driver's side to free up last.. the pass. Side still wont move... the hubs obv spin... I think once I move the truck it should free up
I would be very careful moving the truck to free things up, may cause damage. Something must not be together right or installed correctly. I would pull it back apart and start over. It has to turn free and not be bondup.
Randy4614 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome