Weird Rough idle - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-16-2019, 04:18 AM Thread Starter
PSN Newb
 
Join Date: Sep 2019
Posts: 6
Weird Rough idle

I have an 05 6.0 with new injector harness, new motorcraft icp and ipr, icp plug is new, ficm is new, warren diesel injectors put in in July, numbers aren’t showing hpop leak, air test doesn’t show anything, truck idles rough when I take load off the engine like turning off the air conditioning in park. Doesn’t lack power doesn’t smoke, starts fine hot or cold. Driving me nuts. No codes, I’m lost for ideas
Ethan.johnson6oh is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-16-2019, 04:21 AM Thread Starter
PSN Newb
 
Join Date: Sep 2019
Posts: 6
Injectors are 155/stock and I’ve got warren diesel tunes and tsd tunes does it on both. Egr is deleted and I have studs. I should have added that in the first post
Ethan.johnson6oh is offline  
post #3 of 8 (permalink) Old 09-16-2019, 12:18 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,918
Re: Weird Rough idle

Sounds like an injector to me.

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
 
post #4 of 8 (permalink) Old 09-16-2019, 01:30 PM Thread Starter
PSN Newb
 
Join Date: Sep 2019
Posts: 6
Ran a power balance in ids injectors are fine. Did relative compression too and all is fine there too
Ethan.johnson6oh is offline  
post #5 of 8 (permalink) Old 09-16-2019, 02:19 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,918
Re: Weird Rough idle

The usual suspects are ICP, ICP wiring, IPR, injectors, and FICM.

Check FICM connections next I guess.

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #6 of 8 (permalink) Old 09-16-2019, 04:56 PM Thread Starter
PSN Newb
 
Join Date: Sep 2019
Posts: 6
Did that yesterday when I swapped on another ficm and checked again this morning
Ethan.johnson6oh is offline  
post #7 of 8 (permalink) Old 09-16-2019, 09:46 PM Thread Starter
PSN Newb
 
Join Date: Sep 2019
Posts: 6
Had a buddy that runs a shop tell me it sounds like a crank position sensor if everything else checks out. He said he’s had it one or two other times. Unexplainable rough idle, no codes. Crank sensor solved it. Anyone else hear anything like this?
Ethan.johnson6oh is offline  
post #8 of 8 (permalink) Old 09-17-2019, 02:26 PM Thread Starter
PSN Newb
 
Join Date: Sep 2019
Posts: 6
I replaced the already new icp pigtail after I noticed the icp voltage was off. All seems to be good now. Will update after I drive it a little bit more today
Ethan.johnson6oh is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome