WTF?! Loss of electrical - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-22-2019, 03:39 PM Thread Starter
PSN Veteran
 
Weatherlite's Avatar
 
Join Date: Aug 2012
Posts: 1,252
Garage
WTF?! Loss of electrical

I'm hoping the wtf gets some attention. I had something happen last night that really concerns me, but I can't find anything about it....I lost my electrical while driving. But, I didn't.

Vehicle is the Ex in my sig. Nothing unusual about how things are set up. I do have a 250 amp alternator and two brand new (bought em a month ago, manufactured in April for both) AGM batteries. I have all 2/0 cable, properly terminated, sealed, etc. Electrical setup hasn't given me a lick of trouble in years.

As for what happened, I was driving home from the store, in town, at about 25MPH. Suddenly, with no warning, no prelude, nada, everything in my truck except for the lights and the engine turned off. Everything then went through a test cycle like it would when you first turn on the key and then remained on for the rest of the drive.

First thought is it has something to do with the key, but the key was never touched, and since the FICM and fuel pumps stayed on as well, it doesn't feel right. So, I'm wondering if there is a connection which houses most, but not all, of the items controlled by the key.....something that would let what I described happen. Any thoughts?

Sent from my Moto Z (2) using Tapatalk

2004 Excursion 6.0
New HPOP/HPO system o-rings; Updated standpipes and dummy plugs
EGR delete; Rebuilt oil cooler; CCV collection mod
VR Black Diamond head gaskets and ARP studs
Oil and coolant bypass filters; Shell EC-1 coolant
Rebuilt turbo; 250 amp alt; 6000 watts of brain scrambling
One giant 240 pound English Mastiff riding shotgun!
Weatherlite is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-22-2019, 03:42 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,831
Re: WTF?! Loss of electrical

Possible it is the battery saver circuit in the Instrument Cluster

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #3 of 9 (permalink) Old 06-22-2019, 04:26 PM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,612
battery saver relay in the cluster is failing.

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
 
post #4 of 9 (permalink) Old 06-22-2019, 04:43 PM Thread Starter
PSN Veteran
 
Weatherlite's Avatar
 
Join Date: Aug 2012
Posts: 1,252
Garage
Re: WTF?! Loss of electrical

Well that's a new one on me! What's a battery saver relay, and can it be replaced? Gonna start googling now.

Sent from my Moto Z (2) using Tapatalk

2004 Excursion 6.0
New HPOP/HPO system o-rings; Updated standpipes and dummy plugs
EGR delete; Rebuilt oil cooler; CCV collection mod
VR Black Diamond head gaskets and ARP studs
Oil and coolant bypass filters; Shell EC-1 coolant
Rebuilt turbo; 250 amp alt; 6000 watts of brain scrambling
One giant 240 pound English Mastiff riding shotgun!
Weatherlite is offline  
post #5 of 9 (permalink) Old 06-22-2019, 05:42 PM Thread Starter
PSN Veteran
 
Weatherlite's Avatar
 
Join Date: Aug 2012
Posts: 1,252
Garage
Re: WTF?! Loss of electrical

Did the research already. Here's the million dollar question: can this HEC module be bought by the average Joe? I have good soldering skills and have confidence I could do it, but I can't actually find it for sale anywhere, nor can I find a pic or video specifying which component it is on the back of the cluster.

Sent from my Moto Z (2) using Tapatalk

2004 Excursion 6.0
New HPOP/HPO system o-rings; Updated standpipes and dummy plugs
EGR delete; Rebuilt oil cooler; CCV collection mod
VR Black Diamond head gaskets and ARP studs
Oil and coolant bypass filters; Shell EC-1 coolant
Rebuilt turbo; 250 amp alt; 6000 watts of brain scrambling
One giant 240 pound English Mastiff riding shotgun!
Weatherlite is offline  
post #6 of 9 (permalink) Old 06-22-2019, 06:22 PM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,612
It’s a PCB relay soldered to the board. Send the cluster to circuit board medics and they can repair it

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
post #7 of 9 (permalink) Old 06-22-2019, 07:27 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,831
Re: WTF?! Loss of electrical

My understanding is that the battery saver relay works with the accessory delay relay which is in the fuse/relay box. Your problem may be with the accessory delay relay rather than the battery saver relay, but that is very uncommon.

https://ww2.justanswer.com/uploads/s...5_021056_0.jpg

Check this out (or just send it in!):
https://www.justanswer.com/ford/4tok...t-working.html

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #8 of 9 (permalink) Old 06-22-2019, 08:40 PM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,612
Bismic you are correct. The battery saver relay controls the accessory delay relay. Like you said the ADR isn’t a common failure

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
post #9 of 9 (permalink) Old 06-24-2019, 02:13 PM Thread Starter
PSN Veteran
 
Weatherlite's Avatar
 
Join Date: Aug 2012
Posts: 1,252
Garage
Re: WTF?! Loss of electrical

Some great info there! I also ran across quite a few stories of bad solder joints, so I decided to go ahead and reflow the solder on anything I could on the board. Found several junctions which looked questionable. Guess we'll see how this works. If it happens again, I'll probably just send it in. Just wish I could find out what to replace so I could do it myself. Hate paying someone else to do something I am capable of performing.

2004 Excursion 6.0
New HPOP/HPO system o-rings; Updated standpipes and dummy plugs
EGR delete; Rebuilt oil cooler; CCV collection mod
VR Black Diamond head gaskets and ARP studs
Oil and coolant bypass filters; Shell EC-1 coolant
Rebuilt turbo; 250 amp alt; 6000 watts of brain scrambling
One giant 240 pound English Mastiff riding shotgun!
Weatherlite is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome