Random High-Idle -- Need some help !!! - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-13-2019, 12:41 AM Thread Starter
PSN Local
 
Rcjetsaok's Avatar
 
Join Date: Jul 2017
Location: Central Texas
Posts: 92
Random High-Idle -- Need some help !!!

Hello all,
I have an early '04 F-250 2WD, 6.0 w/ 210K on it. EGR delete, 4" exhaust. I have always had the idle-up come on cold ( aprox. 1K rpm even if the ambient temp is 80 degrees ) and then idles down and all is good. However I have never been able to get it to idle down with the brake pedal or putting in gear. If I start to drive and if it has not idled up yet, it will all the sudden jump up while driving. I have gotten used to it and not that big a deal. However, now, it seems does it at random with the engine at any temp... My Edge CTSII shows all seems normal for the most part but It seems that the ICP #'s are fluctuating a bit more than normal ( I think ) at highway speeds but I don't feel it in the truck... ICP idle warm is always been a is a solid 638+-10psi. IPR is a solid 25% at idle warm. No codes, but I have seen a MAF code in the past, cleared it a has not come back. Turbo feels/sounds normal, good vane sweep at idle, 25+lbs boost when needed, all temps are awesome !! I am suspicious that I am approaching Injector replacement time but I don't think/understand why that would be giving me hi-idle issues... All that being said, the truck runs like a bat out of hell, lots of power, but it is rough and not right when it's in this hi-idle mode...I just don't know what's going on with the Idle... Any Ideas ??

Thanks everyone !!!

Dan
Rcjetsaok is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-13-2019, 08:45 AM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,828
Re: Random High-Idle -- Need some help !!!

Sounds like an ICP or IPR issue to me.

Can you disconnect the ICP and run that way for awhile to see if you still have the issue?

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #3 of 3 (permalink) Old 06-13-2019, 12:08 PM Thread Starter
PSN Local
 
Rcjetsaok's Avatar
 
Join Date: Jul 2017
Location: Central Texas
Posts: 92
Re: Random High-Idle -- Need some help !!!

Quote:
Originally Posted by bismic1 View Post
Sounds like an ICP or IPR issue to me.

Can you disconnect the ICP and run that way for awhile to see if you still have the issue?
Roger that !! I will attempt to get to that no-get-to mofo !!!
Thanks !!!!

Dan
Rcjetsaok is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome