Randomly stalls and wont start for 20 mins - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-24-2019, 10:59 PM Thread Starter
PSN Newb
 
Join Date: May 2019
Posts: 1
Randomly stalls and wont start for 20 mins

My recently acquired 2003 f250 6.0 randomly dies and then wont start for about 20 or so minutes. I've reviewed the ICP, ICP voltage, ficm voltage and ficm sync and have captured the failure and the no hot start conditon that follows. The truck will start hot no problem when shut off manually vs dying randomly. I have a code for P2623 IPR circuit open. I'm wondering if I have a HPOP leak vs a failed or stuck IPR. I fixed some bare wire at the IPR plug by soldering in a new section with heat shrink. Would the IPR be damaged if the wires shorted together previously? I do not yet have the special socket and am trying to avoid throwing parts at the problem until I am sure what is needed.

The interesting thing to me is that all through the no start conditon the sync is mostly at 0. Does this point to some other issue wirh my cam or crank sensor? Looking for some experianced advice to point me in the right direction. Hopefully the xls is viewable attached. Screenshot_20190524-155404_Hancom Office S Viewer_1558738742558.jpg
Attached Files
File Type: zip zipExport-2019-05-24_14-08-42_1558738778635.zip (0).zip (1.8 KB, 5 views)
Zwbrbandit is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-25-2019, 12:55 PM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,612
Check the IPR pigtail I would bet there is bare wire showing near the plug

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
post #3 of 4 (permalink) Old 05-27-2019, 05:10 PM
PSN Veteran
 
Weatherlite's Avatar
 
Join Date: Aug 2012
Posts: 1,252
Garage
Re: Randomly stalls and wont start for 20 mins

Quote:
Originally Posted by matthewd11 View Post
Check the IPR pigtail I would bet there is bare wire showing near the plug
A bare wire, or would this be a broken wire somewhere in the harness? That code makes me think of a broken wire or a bad IPR....wire being more likely. Also, OP, a shorted wire wouldn't hurt the IPR.

2004 Excursion 6.0
New HPOP/HPO system o-rings; Updated standpipes and dummy plugs
EGR delete; Rebuilt oil cooler; CCV collection mod
VR Black Diamond head gaskets and ARP studs
Oil and coolant bypass filters; Shell EC-1 coolant
Rebuilt turbo; 250 amp alt; 6000 watts of brain scrambling
One giant 240 pound English Mastiff riding shotgun!
Weatherlite is offline  
 
post #4 of 4 (permalink) Old 05-27-2019, 09:48 PM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,612
Usually the harness will fray right at the pigtail and sometimes the power wire will contact the control wire causing this exact symptom and code. It’s most common on the earlier models

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Truck died randomly wouldnt start for 30 mins! Im lost Powerstroke121 7.3L Power Stroke Technical Info 12 12-31-2018 05:41 AM
No Start When Hot, Stalls Shifting Into Gears When Hot, Stalls When Turning Sharp zacksharpe5445 6.0L Power Stroke Technical Info 2 12-03-2017 11:45 AM
6.0 randomly cuts out and stalls Abosco1597 New To The Nation 0 06-17-2017 11:25 AM
Driving BAM STALLS, turn off, turn on, start, driving stalls Michael5126 1994-1997 Power Stroke Technical Info 10 02-05-2013 06:51 PM
random horn every 20 mins 03International 7.3L Power Stroke Technical Info 2 01-09-2012 06:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome