6.0 engine swap trouble - Page 2 - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 21 (permalink) Old 04-08-2019, 02:34 AM Thread Starter
PSN Newb
 
Join Date: Apr 2019
Posts: 10
God this sucks.. to me it seems like there is a voltage draw or a wire loose or missing to explain why there is no injector buzz or fuel pumping with koeo until i cycle the key to start for a few split seconds then back to run. At that point the injectors buzz and fuel pumps. So FRUSTRATING!
ktspindler is offline  
Sponsored Links
Advertisement
 
post #12 of 21 (permalink) Old 04-08-2019, 02:40 AM Thread Starter
PSN Newb
 
Join Date: Apr 2019
Posts: 10
So also the wiring harness’ are not identical the old one was a c93 the new one is a c92. I thought the big difference would be just because of the icp being located differently, but upon further inspection they are not the same. 1 extra wire going to the pcm board and one less wire at the round plug i believe it is 8 pin coming from cab firewall or fuse panel. Another possibility?
ktspindler is offline  
post #13 of 21 (permalink) Old 04-08-2019, 03:06 AM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,756
Re: 6.0 engine swap trouble

Engine harnesses and glow plug harnesses for a 2004 can be difficult to ensure you get the correct one due to the changes. There are actually 3 versions of the 2004 model:

1. 2003 engine. Harness # 3C3Z-12B637-BA (International # 1843797C93)
2. Mid/late 2004 engine (this is identified by a horizontal GPCM orientation and took place on 9/29/03 when the ICP was moved). Harness # 4C3Z-12B637-AA (1844262C93)
3. Late/Late 2004 engine (this took place on Dec 1, 2003, identified by a vertical GPCM orientation). Harness # 4C3Z-12B637-CA (1846377C92)

The glow plug harnesses are different also.

IIRC sometime in 04, an EGR throttle plate was added. It can simply be unplugged on those model years that have it and it should still run ok. That might be the extra wire.

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
 
post #14 of 21 (permalink) Old 04-08-2019, 03:13 AM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,756
Re: 6.0 engine swap trouble

Quote:
Originally Posted by ktspindler View Post
God this sucks.. to me it seems like there is a voltage draw or a wire loose or missing to explain why there is no injector buzz or fuel pumping with koeo until i cycle the key to start for a few split seconds then back to run. At that point the injectors buzz and fuel pumps. So FRUSTRATING!

I agree that this sounds more like a loose wire or an intermittent open circuit than a PCM issue.

I will say it again, Scangauge is a poor code reader. ForScan Lite might pick up a code that could give you a clue ..... I realize $40 shouldn't be thrown away, but consider it an investment (even if in this case it doesn't provide extra information, it will at some point in the future).

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #15 of 21 (permalink) Old 04-08-2019, 06:41 PM
sooty
 
Join Date: Feb 2012
Posts: 400
Re: 6.0 engine swap trouble

Is the truck getting fuel to the filter on the engine?
sooty is offline  
post #16 of 21 (permalink) Old 04-08-2019, 06:45 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,756
Re: 6.0 engine swap trouble

150 rpm should be enough (bare minimum though) for a start. I agree it would be nice to have more. Interestingly enough the Ford PC/ED manual states 100 rpm for the FICM to initiate the commands to the injectors. Functionally 150+ is needed.

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #17 of 21 (permalink) Old 04-17-2019, 08:26 PM Thread Starter
PSN Newb
 
Join Date: Apr 2019
Posts: 10
Re: 6.0 engine swap trouble

So I got the original Ficm and PCM from the truck the engine came out of. Fixed ground strap from the frame to cab(dont know if that would make the difference). Still got same problem. Injectors are not opening, no smoke while cranking and no injector buzz until i crank truck over for a few seconds and release. No codes found but i can definetly tell ther is a voltage draw somewhere, scan guage will read 12.3 volts KOEO and as soon as i crank it a little bit and everything kicks on it will drop to 11, 10.5, 10, volts. So after the ficm stops injector buzz, fuel pump quits pumping, glow plug light goes off there is still a really bad draw for about 30 seconds, and just like that the cab lights get brighter, and scan guage will read 11.5 or so without really cranking truck.
ktspindler is offline  
post #18 of 21 (permalink) Old 04-17-2019, 09:09 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,756
Re: 6.0 engine swap trouble

The glow plugs stay on longer than the light ..... up to 2 minutes. They are a big electrical draw.

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #19 of 21 (permalink) Old 04-17-2019, 09:34 PM Thread Starter
PSN Newb
 
Join Date: Apr 2019
Posts: 10
Re: 6.0 engine swap trouble

So thats what i was figuring but i still am tring to figure out why with KOEO before cranking the is no injector buzz. Is it possible its the ficm relay? Also no fuel while cranking because i have no smoke from the tailpipe
ktspindler is offline  
post #20 of 21 (permalink) Old 04-18-2019, 01:05 AM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,756
Re: 6.0 engine swap trouble

KOEO, the fuel pump should pump.

Sounds like an issue w/ the pump or the circuit.

Another thing that might keep the fuel pump from running is the inertia switch.

Edit ..... and you might see if the fuel pump will run w/ the gear selector in neutral.

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Solid front axle swap trouble Lightskin7tray 7.3L Power Stroke Technical Info 1 10-25-2015 03:34 PM
TROUBLE and trouble codes TravisT 1994-1997 Power Stroke Technical Info 5 06-03-2012 11:04 PM
Engine Trouble Redneck Steve 7.3L Power Stroke Technical Info 9 03-05-2010 07:58 PM
Newb from East TN with engine trouble.... Wreckless4thf 7.3L Power Stroke Technical Info 9 12-04-2009 03:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome