2004 350 60 truck stalling on me - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-25-2019, 12:11 AM Thread Starter
PSN Newb
 
Join Date: Jan 2019
Posts: 2
2004 350 60 truck stalling on me

so just had the turbo veins cleaned, egr valve checked, replaced fuel pump and filters. two weeks later truck was having hard time starting and battery died boosted it and worked fine next day truck seemed to be running at lower rpm and sounded quieter, ran great but kept dying in park. in gear was good. next day needed jump again and now dies every time I put it in gear, it wont run in park unless I apply accelerator, take it off and it dies put it in gear and it dies. vip tested the battery and says good. any ideas? I can floor the pedal and seems to be lack of response and power
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-25-2019, 09:15 PM
PSN Newb
 
Join Date: Dec 2018
Posts: 6
Re: 2004 350 60 truck stalling on me

Quote:
Originally Posted by [email protected] View Post
so just had the turbo veins cleaned, egr valve checked, replaced fuel pump and filters. two weeks later truck was having hard time starting and battery died boosted it and worked fine next day truck seemed to be running at lower rpm and sounded quieter, ran great but kept dying in park. in gear was good. next day needed jump again and now dies every time I put it in gear, it wont run in park unless I apply accelerator, take it off and it dies put it in gear and it dies. vip tested the battery and says good. any ideas? I can floor the pedal and seems to be lack of response and power
I've had batteries that they say tested goodand they were out of the truck. I got new batteries anyway and it was night and day difference to how the truck started. Maybe you should look into your alternator.

Sent from my SM-N960U using Tapatalk
Johnny McG is offline  
post #3 of 4 (permalink) Old 01-26-2019, 12:50 PM
CAT lover
 
Robertl211's Avatar
 
Join Date: Feb 2014
Location: Cape Cod, MA
Posts: 575
Re: 2004 350 60 truck stalling on me

Sounds like a high pressure oil leak that started small and is now getting larger. You might consider an air check on the HPO system. Your HPOP could have gone.

96 F250 RCFB 4x4 7.3
96 f350 CCLB Dually ZF5, custom flatbed, Gregio Medio Lamborghini paint, 3" dp 4" MBRP exhaust
95 F250 RCLB 7.3 4x4 conversion with 5" Sky RSK, D60 front, 18" American Racing, 35" Nittos, DIY SD intercooler, Melling LPOP, DIY 6637, Baby Swamps with TS6 and Swamps tunes, boost pyro trans

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

05 F350 RCLB Dually SOLD
Robertl211 is offline  
 
post #4 of 4 (permalink) Old 01-26-2019, 08:52 PM Thread Starter
PSN Newb
 
Join Date: Jan 2019
Posts: 2
Re: 2004 350 60 truck stalling on me

I just replaced batteries, no help. It does seem to get better once it warms up but issues is still there, code scan said crankshaft position sensor. regardless I took to the dealer and they will look at it Monday. Ill post the verdict.
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome