need turbo help - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-19-2018, 02:17 PM Thread Starter
PSN Newb
 
Join Date: Sep 2009
Posts: 38
need turbo help

I was getting usually 17-18psi boost causing my truck was not perform while towing load at highway speeds like it used to. During my turbo "rebuild" I was hoping I would find an issue with the ring or vanes but was my turbo was in clean condition and no significant wear on anything including the ring and vanes. I replaced all the kit parts including the compressor housing o-ring but this did not improve my low boost. I have since then pressured up my induction and exhaust tracks and I discovered a significant pressure air leak in the compressor housing, and maybe this was the issue all along. So, finally my question. Can the compressor housing be re-machined?, would this be a good idea? which turbo would you recommend if I need a replacement? My truck has no tuner and is pretty much stock except for some durability mods. As far as the replacement turbo I donít necessarily want a performance up-grade but a durability up grade would be good.
knotreel is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-20-2018, 02:22 PM Thread Starter
PSN Newb
 
Join Date: Sep 2009
Posts: 38
Re: need turbo help

never mind, i bought a housing and wheel
knotreel is offline  
post #3 of 10 (permalink) Old 12-20-2018, 02:31 PM
Moderator
 
Sbluke55's Avatar
 
Join Date: Jun 2015
Location: Colorado
Posts: 7,871
Re: need turbo help

Who did you buy it from? I would suggest kc turbos.

01 f-250, Standard
Rev tech 4" lift, 37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks intercooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
Sbluke55 is offline  
 
post #4 of 10 (permalink) Old 12-20-2018, 08:17 PM Thread Starter
PSN Newb
 
Join Date: Sep 2009
Posts: 38
Re: need turbo help

Turbolab kc was out of stock.
knotreel is offline  
post #5 of 10 (permalink) Old 12-21-2018, 09:07 PM Thread Starter
PSN Newb
 
Join Date: Sep 2009
Posts: 38
Re: need turbo help

there must be something wrong wirh me? OK, I am not a regular on here, but I ask questions, I almost never get any sugestions and the few I get are glib. Take this thread, got a problem, explain it best I can, finally I figure out an issue that needs fixing that also might be the source of my original issue. I buy the part, all I get after I said I already bought it was, did I buy it from someones favorite site suporter? All I can say it's a good thing it's free advice. I do like reading about other peoples issues and how they got fixed but I can't get no help. Hey it's not just this site, other sites I don't even get the "who did you buy from?" so maybe this one is best.
knotreel is offline  
post #6 of 10 (permalink) Old 12-22-2018, 12:22 AM
dogpile
 
Join Date: Mar 2018
Location: NC
Posts: 122
Re: need turbo help

It seems forums are not as popular as they once were, more often than not, I look at this one about once every week or two.

Best o' luck with your problem BTW.

It pays to be a winner.
Gerald Small is offline  
post #7 of 10 (permalink) Old 12-22-2018, 03:20 PM
Moderator
 
Sbluke55's Avatar
 
Join Date: Jun 2015
Location: Colorado
Posts: 7,871
Re: need turbo help

Sorry you feel that way. I personally have kc turbos parts. Charlie is a part of the forum community and puts in tons of info and that's why I recommend him.

So exactly what issues are you having again? Did the new parts help? How are you doing a pressure test on the system? Are you just worried about having 18 psi?

01 f-250, Standard
Rev tech 4" lift, 37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks intercooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
Sbluke55 is offline  
post #8 of 10 (permalink) Old 12-22-2018, 11:16 PM Thread Starter
PSN Newb
 
Join Date: Sep 2009
Posts: 38
Re: need turbo help

Just to be clear again, I did try to buy the compressor upgrade from KC, the price was right and they appeared to be a place that could support the product if I had a need. But, they did not have it. I bought it from a store ( TurboLab) that had it but at a higher price that likewise seemed that they also might be able to offer support if needed. Since this seems to be issue, I hope this clears that up.
About my truck, earlier this year I noticed lower hwy performance while towing. Reduced passing ability at 60+ mph, and lower performance on grades. I installed a monitor to clarify things and first thing that popped up was an EOT/ECT issue. While fixing that, OEM oil cooler, BP EGR cooler, ect, I installed a turbo rebuild kit. I suspected the unison ring and vanes but mine turned out to be good. After the work the cooling issues were fixed but boost was the same as was the performance. Still 17-18 psi. Other things that I did later included cat delete, new ERG valve o-rings CACC tube boots on hot side.
Lastly, I installed a coupling on the turbo inlet and capped off the exhaust tail pipe end and with and air line from a regulator set to 15psi, I pressured up the intake and exhaust systems and sound and bubble checked everything that was under pressure (pretty much everything). In addition to 2 small bubbling leaks on dr side exhaust manifold (which I judged to be insignificant for immediate fixing) there was a significant sound and bubble leak on the compressor housing which had a new o-ring. I figured that this leak must have been there all along since the performance was the same. Weather or not this leak is the cause of the low boost and performance, I donít know, but it was big enough that I thought it should be fixed anyway. After the whole system test I isolated the intercooler and pressure tested separately with non flowing air, no leaks.
So I ordered the upgraded compressor housing and after I receive and install it I will know.
Other things, 6.0 , 2003, 147K, no tuner, owned since new, 2wd, auto trans.
Some of the things I have done have improved the driveability, which sometimes suffered with slow response, but not the ultimate pulling power.
What did I want? I hoped that someone might have had a similar issue and some comments on how they solved theirs, or least some idea. Still all I know is that I bought my stuff from the wrong guy. So, can you help me even though I am a sinner?
knotreel is offline  
post #9 of 10 (permalink) Old 12-23-2018, 12:25 PM
Moderator
 
Sbluke55's Avatar
 
Join Date: Jun 2015
Location: Colorado
Posts: 7,871
Re: need turbo help

Where did you hook up the boost leak tester on the turbo? I personally do it after the ccv. Try it again and bump your pressure up to 20-25. No need to cap exhaust.

01 f-250, Standard
Rev tech 4" lift, 37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks intercooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
Sbluke55 is offline  
post #10 of 10 (permalink) Old 12-23-2018, 04:53 PM Thread Starter
PSN Newb
 
Join Date: Sep 2009
Posts: 38
Re: need turbo help

I tested the intire intake track and entire exhaust system by pressuring up thru the turbo inlet (with the induction piece that is connected to the CCV removed) and capping the exhaust at it's end, this tests the cacc's, the intercooler (to a lesser extent), the intake manifold, the exhaust to the turbo, in short everythimg. I did find a good leak as I said. I used running air for this test to maintian pressure. I could could not get the more than 15 psi due to a less than optimal fit of the test couping on the turbo inlet, it would blow off at 20psi. When I get the turbo out, bench pressure test it after installing the new compressor housing and then I will hopefully get a better fitting fernco coupling and redo the whole system test, hopefully at higher pressure (20-25). I did not feel my whole system test was the best for the intercooler as I could not see and hear the whole thing, so that is why I isolated it for a static presure holdiing test. It passed. I think I got this part, what about an overview on the issues I describe. I changed the ERG o-rings which actually improved my(auto trans) low gear boost and slowish low gear acceleration , it didn't help the higher rpm boost at 60+mph. Do you think the ERG valve it's self could be leaking boost? It seems to be working, change of sound on re-learn but I don't think that neccessarily eliminates it as a suspect? what do you think. Really all I have left that I can think of is the turbo housing leak and maybe the ERG valve, any ideas? One more thing, My truck has had, ever since I had AE scan (maybe 8, or so, years), code P0401. I always thought the ERG cooler was cloged or some other clog. But my cooler that I replaced with the BP ccoler was very clean. Naturally I still have the P0401. I know the EGR valve is in the mix of possible conrtibutors, but maybe that calc. the pcm does is beyond my understanding. The reason I have not just replaced the ERG valve is the P0401 has been there so long when the truck was running fine. So, thoughs?
Thanks , Ron
PS, I do need to cap the exhaust to pressure the exhaust system along for air leak test.
knotreel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome