Truck stalled again. Ficm logic voltage over 100 briefly. - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 11-11-2018, 01:28 PM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Truck stalled again. Ficm logic voltage over 100 briefly.

Immediately checked codes with Torque. P1397 p0611 and a cylinder 4 code. This has been happening randomly for awhile. Just had high pressure system completely redone. After getting truck towed home and jiggling wires and checking fuses the ficm voltage finally came back on and truck fired right up. Need some guidance on this one.
bobbyd613 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 11-11-2018, 06:46 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,829
Re: Truck stalled again. Ficm logic voltage over 100 briefly.

You sure that code isn't P1379 (not P1397)?

I would like to see the FICM input voltage (ie vehicle voltage - "VPower") just to rule out issues w/ the alternator. P1379 would indicate that there is high system voltage (FICM logic power is high). P1397 is "System Voltage Out Of Self Test Range" and might be applicable, but I didn't think that was a diesel code.

After that, I would consider getting the FICM repaired ..... How else are you going to see 100V? I question if that is a real voltage or not, but have nothing to go on other than your post. There is nothing at 100V in your electrical system, so if the value is real, then the FICM voltage amplification circuitry has failed.

Typically the FICM increases voltage by a factor of 4 (ish). I have trouble believing that your alternator is putting out 25V, but maybe ........... You didn't connect up your two batteries in series did you (instead of parallel)?

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #3 of 14 (permalink) Old 11-11-2018, 07:05 PM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
It may have been the p1379. Alternator seems to be around 13.6. I have a new power board but normally the ficm puts out 47-48. The stalling is random. But when it stalls there is no voltage in or out of ficm and no injector clatter. There is also a stutter when accelerating once warmed up. Oil pressure seems fine and there are no codes then. I'm so frustrated after all the money for the high pressure system including the branch tube. Seems that the pcm stops the ficm from turning on when this happens. I hear the logic board goes bad on occasion. I know i need and egr valve, but don't think that could cause the stalling.
bobbyd613 is offline  
 
post #4 of 14 (permalink) Old 11-11-2018, 07:06 PM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Forgot to mention that when out happens the voltage I reads at 0.
bobbyd613 is offline  
post #5 of 14 (permalink) Old 11-11-2018, 07:11 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,829
Re: Truck stalled again. Ficm logic voltage over 100 briefly.

The FICM absolutely could cause the stalling.

You could also have an issue w/ the FICM relay or the harness.

I just don't understand the 100V in the post title (especially if it is "logic voltage"), but oh well.

What power board did you install, an OEM one or an aftermarket?

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #6 of 14 (permalink) Old 11-11-2018, 07:16 PM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Installed a dorman and it seemed ok for a little while. The 100v was a short lived code. And went to 0 right after that. Seemed like a voltage spike in the ficm and then it went to zero like out got shut off. Voltage came back later after playing with fuses and jiggling wires.
bobbyd613 is offline  
post #7 of 14 (permalink) Old 11-11-2018, 07:22 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,829
Re: Truck stalled again. Ficm logic voltage over 100 briefly.

Can't help you w/ the Power Board then. I absolutely hate Dorman products ... especially their electronic stuff. I would suspect an issue with it before anything else!

Personally I think you need to send the FICM in to FICMrepair.com, but that will almost certainly cost you $$'s to get an OEM power board installed. That said, if you could narrow down what things being jiggled correspond to the voltage coming back, then it might be a clue.

I will post a link to your other thread on the subject because it has pertinent information in it (ie the FICM relay has been replaced, you had loose negative battery terminals, etc).

https://www.powerstrokenation.com/fo...ml#post6138645

Just to add a comment on the work that has been done ...... the late HPOP's don't go out very often. Also, the branch tubes aren't a common failure item (unless the STC fitting fails catastrophically). It almost sounds like you were taken advantage of by a shop.

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
post #8 of 14 (permalink) Old 11-11-2018, 08:19 PM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
I was skeptical about the hpop but they showed me the branch tube and the stc fitting had failed. The branch tube was cracked right whereit meets the square where it meets the stc fitting.
bobbyd613 is offline  
post #9 of 14 (permalink) Old 11-11-2018, 09:54 PM
Administrator
 
Zmann's Avatar
 
Join Date: Nov 2010
Posts: 32,929
Re: Truck stalled again. Ficm logic voltage over 100 briefly.

Second Doerman FICM issue in as many days

bare minimum go get a tech smart from the parts store or amazon

,
,
,
,
DTR's Donation page

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

RIP DTR Ron
you are missed and will live on through your great video library contribution to the DIY community

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Zmann is offline  
post #10 of 14 (permalink) Old 11-11-2018, 11:03 PM
"resident smarty pants"
 
Join Date: Apr 2008
Posts: 3,829
Re: Truck stalled again. Ficm logic voltage over 100 briefly.

Quote:
Originally Posted by bobbyd613 View Post
I was skeptical about the hpop but they showed me the branch tube and the stc fitting had failed. The branch tube was cracked right whereit meets the square where it meets the stc fitting.
Good to get all that work done in the high pressure oil system, now you shouldn't have to worry about those components. The updated fitting has been very reliable. The updated dummy plugs and standpipes also seem to be doing well!

It is not real common for that kind of "catastrophic" failure, but it does happen. At least the rear cover wasn't cracked.

It is hard not to recommend the STC fitting upgrade when folks post up about "bulletproofing". It is so much cheaper to replace it than to experience the bad failure. That said, I would guess by now that more vehicles have been upgraded w/ the one-piece fitting than those that haven't!

Mark
06 F250 CC SB FX4 Lariat;ARPs OEM gaskets;Banks exhaust;DynaTrac Balljoints;RACCCV6000;Updated HPOP fitting;JimmiJammers;Ravelco;plugs&standpipes;Fumo to;Harpooned;Quadzilla XZT Fuel Press;Blue spring;DashDAQ;PHP_FICM; RiffRaff boots;DCPower270A XP;Inverter;Rancho7000's;BPD EGR cooler;BPD WaterPump;SCT Matts SRL+;ELC Ultra w/ filter;SynchroMax
bismic1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome