Crank but no start - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-03-2015, 10:44 PM Thread Starter
PSN Newb
 
Join Date: Apr 2015
Location: ventura county
Posts: 1
Crank but no start

This is regarding a 2004 f250 CC SB 6.0 4X4 43,000 miles on it. So getting off of work the other day and my truck wouldn't start. I just did a fresh oil change on it about 50 miles ago and in the morning just filled it with diesel. I used my OBD-II reader and it came up with P2617 (CKP sensor). So I dismantle the truck, replace the sensor, and put it all back together again. Go to try and start it, no luck I just get cranking/ no start. I hook my OBD back up and now it tells me P0603 ICM keep alive, P2614 Cam sensor and trouble code p2617 is now gone. I have the cam sensor already so I am just going to replace that in a couple hours when my schedule frees up. Does anyone know whats going on or have any insight that could help me out here? Any input would be greatly appreciated.
viper00101 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome