04 high pressure oil problem - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 03-31-2015, 02:28 AM Thread Starter
PSN Local
 
turborangerdude's Avatar
 
Join Date: Mar 2011
Location: Oshkosh WI
Posts: 173
Send a message via Yahoo to turborangerdude
04 high pressure oil problem

I have an early 04 I took a part put in oil cooler did an EGR delete changed out a couple injectors. I had all the injectors out and clean them put them back in the truck runs most of the time but every once in a while it will die and then will not build oil pressure but then out of the blue it will start building oil pressure again it'll run fine for hours it'll die but start right back up but every once in awhile it won't does anybody have any ideas what could be causing this

04 F-350 6.0 dually egr delete strait piped to 6 inch dual stacks
05 F-350 6.0 srw egr delete 58v ficm and turbo back 4" with 6" tip
turborangerdude is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 03-31-2015, 03:35 PM
PSN Local
 
Michipicoten_SuperDuty's Avatar
 
Join Date: Jul 2013
Location: Metamora, MI
Posts: 418
Re: 04 high pressure oil problem

How many miles has it been since you had it back together? If it's been a few, it sounds like an IPR problem to me. How does the wiring/plug look? Have you tried replacing the IPR?

2004 F-250 Lariat, 6.0, SCLB, 4wd, Magnaflow turbo-back, EGR delete, studded, 6.4 banjo, new oil cooler and HPOP as of 5-11-2014
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Michipicoten_SuperDuty is offline  
post #3 of 13 (permalink) Old 03-31-2015, 03:50 PM
PSN Newb
 
Join Date: Mar 2015
Posts: 2
Re: 04 high pressure oil problem

Just replaced the ipr..he would clean the ipr re-re-install it and it would run again. So it got replaced. (Also working on this gremlin machine)
focidriver is offline  
 
post #4 of 13 (permalink) Old 03-31-2015, 04:10 PM Thread Starter
PSN Local
 
turborangerdude's Avatar
 
Join Date: Mar 2011
Location: Oshkosh WI
Posts: 173
Send a message via Yahoo to turborangerdude
Re: 04 high pressure oil problem

It has run a total of maybe 6 hrs of and on in the shop can't keep it running long enough to even drive it longest it has run at 1 time is about a hour and a half in between running and dying and restarting
turborangerdude is offline  
post #5 of 13 (permalink) Old 04-01-2015, 05:07 AM
PSN Local
 
Michipicoten_SuperDuty's Avatar
 
Join Date: Jul 2013
Location: Metamora, MI
Posts: 418
Re: 04 high pressure oil problem

Do you have a way to monitor ICP and IPR? If not, I'd get one. I just got my Scangauge II last week. I'm pretty geeked.

2004 F-250 Lariat, 6.0, SCLB, 4wd, Magnaflow turbo-back, EGR delete, studded, 6.4 banjo, new oil cooler and HPOP as of 5-11-2014
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Michipicoten_SuperDuty is offline  
post #6 of 13 (permalink) Old 04-01-2015, 05:44 AM
whistle tits
 
ghohouston's Avatar
 
Join Date: Mar 2011
Location: Lewisville, Texas
Posts: 3,498
Re: 04 high pressure oil problem

Did you replace the injector o rings?


1997 F350 SRW CCLB 7.3 ZF5 4x4
ghohouston is offline  
post #7 of 13 (permalink) Old 04-02-2015, 03:13 PM Thread Starter
PSN Local
 
turborangerdude's Avatar
 
Join Date: Mar 2011
Location: Oshkosh WI
Posts: 173
Send a message via Yahoo to turborangerdude
Re: 04 high pressure oil problem

Yes I havery a way to monitor icp and ipr when it won't start it usually runs around 100 psi I did not replace injector orings what has me so confused is it is so random as to when it will and won't start I have tried pressure test but I cant find a leak

04 F-350 6.0 dually egr delete strait piped to 6 inch dual stacks
05 F-350 6.0 srw egr delete 58v ficm and turbo back 4" with 6" tip
turborangerdude is offline  
post #8 of 13 (permalink) Old 04-02-2015, 09:58 PM
PSN Veteran
 
IIvonnyII's Avatar
 
Join Date: Feb 2012
Location: Walnut Grove, British Columbia CANADA
Posts: 959
Re: 04 high pressure oil problem

Replace the injector o rings. Could have pinched or torn one on installation

Admin of BCCR

2007 f-350 CC/SB Lariat --SOLD--


2006 F-350 CC/SB Harley Davidson

- 205/100s
- Custom twin superduty pump fuel system W/ RR
- BW S366
- 4" exhaust to dual 5" tips
- air raid CAI
- 80k miles
- levelled, 35s
- Bulletproofed
- Gearhead tuning
IIvonnyII is offline  
post #9 of 13 (permalink) Old 04-03-2015, 06:14 AM
PSN Local
 
Michipicoten_SuperDuty's Avatar
 
Join Date: Jul 2013
Location: Metamora, MI
Posts: 418
Re: 04 high pressure oil problem

When it does run, what's the IPR duty cycle at idle?

2004 F-250 Lariat, 6.0, SCLB, 4wd, Magnaflow turbo-back, EGR delete, studded, 6.4 banjo, new oil cooler and HPOP as of 5-11-2014
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Michipicoten_SuperDuty is offline  
post #10 of 13 (permalink) Old 04-03-2015, 07:32 AM
PSN Veteran
 
Join Date: Dec 2010
Posts: 2,086
Re: 04 high pressure oil problem

You may have your HPOP internally rotating, a known problem with 03 and 04's. Watch your ICP pressure for sudden loss of pressure.
lenzhotrod is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome