Bad injectors? - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-23-2015, 07:19 PM Thread Starter
PSN Local
 
Join Date: May 2010
Location: Gananoque ontario canada
Posts: 81
Bad injectors?

This just started out of the blue. Truck was running fine, drove to a friends shop about a half hour away. Truck sat for 3-5 hours. Went to leave, truck started fine, motor was at about 60*. Pulled out on the road and at about 35mph it started chug like it was out of fuel. Did this for about 3-4 miles and smoothed out like normal. With motor hot and at idle it stumbles occasionally. Friend thinks it's injector spools. Any thoughts? I have a cell phone video but no idea how to load it
strokerta is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-23-2015, 07:48 PM
PSN Newb
 
Join Date: Sep 2011
Posts: 7
Re: Bad injectors?

Sounds like possibly stiction, due an oil change & put two bottles of Rev X or one 16 Oz bottle of Achoil in and run it. 5w 40 synthetic oil really made my 6.0 run smooth.

Unless you think you got some bad fuel last fill dunno, but it sure sounds like injector stiction.
rabpearson is offline  
post #3 of 12 (permalink) Old 03-23-2015, 08:08 PM Thread Starter
PSN Local
 
Join Date: May 2010
Location: Gananoque ontario canada
Posts: 81
Re: Bad injectors?

I just ordered some Revx actually to try. I just changed the oil a month ago and havent drove it much (Valvoline extreme blue)
strokerta is offline  
 
post #4 of 12 (permalink) Old 03-24-2015, 03:27 PM
Jackleg Mechanic
 
mastrkee's Avatar
 
Join Date: Mar 2012
Location: Central Alabama
Posts: 881
Re: Bad injectors?

You should verify the FICM voltage and fuel pressure before you jump to stiction conclusions.

Jeff
06 F350 6.0L CCLB AMARILLO 4X4
- SCT Livewire, Quick Tricks Looney tune, XDP Coolant filter, Blue Spring Mod, High Flow Banjo bolts, Warren's 175/30 injectors with upgraded spools, ARP Studs, PowerMax Stag One Turbo, Bilstien 5100's. Banks 4in turbo back Monster exhaust. All necessary internal bulletproofing. High Idle mod
mastrkee is offline  
post #5 of 12 (permalink) Old 03-24-2015, 05:23 PM Thread Starter
PSN Local
 
Join Date: May 2010
Location: Gananoque ontario canada
Posts: 81
Re: Bad injectors?

checked ficm yesterday and it is good. I personally don't think its injectors because of how it stumbles on the road. The stumbling gets progressively worse until it feels like the truck has almost been shut of for a second. Then seems to get better and carry on like normal.
strokerta is offline  
post #6 of 12 (permalink) Old 03-24-2015, 06:12 PM Thread Starter
PSN Local
 
Join Date: May 2010
Location: Gananoque ontario canada
Posts: 81
Re: Bad injectors?

heres a little video

Powerstroke issue - YouTube
strokerta is offline  
post #7 of 12 (permalink) Old 03-25-2015, 01:21 AM
PSN Local
 
Join Date: Nov 2010
Location: Tennessee
Posts: 146
Re: Bad injectors?

326,000 on original injectors?

2004 2.5" Level, MBRP 4" No Cat, No Muff, High Idle Mod, PMM Coolant Filter, 6.4 Banjo Bolts, Edge Juice w/ Attitude, Bulletproofed, March 2015 HPOP
jg6.0 is offline  
post #8 of 12 (permalink) Old 03-25-2015, 03:10 AM Thread Starter
PSN Local
 
Join Date: May 2010
Location: Gananoque ontario canada
Posts: 81
Re: Bad injectors?

Kilometres. But ya
strokerta is offline  
post #9 of 12 (permalink) Old 03-25-2015, 03:17 AM
PSN Veteran
 
codykthekilla's Avatar
 
Join Date: Apr 2010
Location: Spring Hill, TN
Posts: 620
Garage
Re: Bad injectors?

I wouldn't think its a stiction issue cause usually when its sticton its worse cold and clears up when it gets warm. I'm kind of curious if your turbo is sticking, pitch to me doesn't change much and I can't tell if you're letting out of the throttle or if the rpms are changing on their own. Are you having low power and is it having issues shifting gears? If so if you lift off throttle at higher rpms does it change gears? Also noticed air filter minder light is on, are you sure you don't have an intake restriction? Any codes?

2002 F-250 CCSB PSD 4X4, 38R, S&B CAI, Bully Dog GT, 4" Exhaust, 05 head lights and grill, 08 power fold mirrors, tailgate, bumper, tail lights, 2014 chrome steps.
1979 Bronco 4X4, 460, c6, 205
2003 Ranger 2.3 MT 2wd
codykthekilla is offline  
post #10 of 12 (permalink) Old 03-25-2015, 05:36 AM Thread Starter
PSN Local
 
Join Date: May 2010
Location: Gananoque ontario canada
Posts: 81
Re: Bad injectors?

That's me staying on the throttle. Air filter light is on because the sensor thing on the intake tube got broke. But the filter is good. And there are no codes. Seems to shift a touch hard. But when it's cold it always did
strokerta is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome