6.0 no start help - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-28-2015, 05:08 AM Thread Starter
PSN Newb
 
Join Date: Feb 2015
Posts: 2
6.0 no start help

I have that 05 The truck will not crank turns over it has oil pressure the high-pressure oil pump is working what else do you all think it could be
Jb21 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-28-2015, 05:32 AM
PSN Newb
 
95 5speed's Avatar
 
Join Date: Oct 2014
Posts: 23
Re: 6.0 no start help

It could be the EGR going out. A buddy of mine had the same issue with his and I have no idea how it relates to the EGR but that's what it ended up being

1995 F250 7.3 5 speed 4x4
Dana 60, Ranch hand, straight pipe, intake and lots of little mods
95 5speed is offline  
post #3 of 5 (permalink) Old 02-28-2015, 06:01 AM
Banned
 
Join Date: Feb 2015
Location: tenn
Posts: 143
Re: 6.0 no start help

Quote:
Originally Posted by Jb21 View Post
I have that 05 The truck will not crank turns over it has oil pressure the high-pressure oil pump is working what else do you all think it could be

what are your pids "readings".i will give you a few things to look at.have you done any up dates on your truck such as dummy plugs oil tubes and stc fitting.if you have not i would check those.i would also check the ipr.pull the ipr out and see if the screen has a tear in it or crap on the screen.

have you done an air test if you need further help feel free to pm me.
equalizer is offline  
 
post #4 of 5 (permalink) Old 02-28-2015, 06:56 AM Thread Starter
PSN Newb
 
Join Date: Feb 2015
Posts: 2
Re: 6.0 no start help

At first we thought it was the high-pressure oil pump took the IPr out and there was no screen put a new IPr in it and I think it's got 1400 PSI or something like that
Jb21 is offline  
post #5 of 5 (permalink) Old 02-28-2015, 12:29 PM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,732
Re: 6.0 no start help

Did you find the old screen? Its probably stuck in the pump.

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome