Half of guage cluster doesn't light up - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-23-2015, 06:53 PM Thread Starter
06 FX4,4" Rough Country
 
Bleed Blue's Avatar
 
Join Date: Aug 2013
Posts: 101
Half of guage cluster doesn't light up

My factory engine temp gauge and trans temp guages have zero glow at night. Can't see them whatsoever, and my speedometer numbers are dim until about 45mph U can start to see the numbers glow from there on up. They don't start glowing as I speed up, I'm saying 45 is the first number I can ever see. Could this be a fuse?

06 F250 CCLB FX4, 173K, Egr delete, Blue spring, SCT performance tune, AFE cold air, 4" Rough Country, 35x12.50 Cooper STT m/t, Fuel Hostage 18x12 -44 offset, 4"dp into 5" Diamond Eye system
Bleed Blue is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-23-2015, 06:59 PM
whistle tits
 
ghohouston's Avatar
 
Join Date: Mar 2011
Location: Lewisville, Texas
Posts: 3,498
Re: Half of guage cluster doesn't light up

Quote:
Originally Posted by Bleed Blue View Post
My factory engine temp gauge and trans temp guages have zero glow at night. Can't see them whatsoever, and my speedometer numbers are dim until about 45mph U can start to see the numbers glow from there on up. They don't start glowing as I speed up, I'm saying 45 is the first number I can ever see. Could this be a fuse?
Pull the cluster out, leave it plugged in, and turn the lights on. Wiggle the bulbs and see if they come on.


1997 F350 SRW CCLB 7.3 ZF5 4x4
ghohouston is offline  
post #3 of 4 (permalink) Old 02-26-2015, 01:03 AM
Big dumb redneck
 
6speedSD's Avatar
 
Join Date: Apr 2009
Location: Olive Branch, Mississippi
Posts: 4,200
Garage
Re: Half of guage cluster doesn't light up

Sometimes a slight smack to the top of the dash will bring them back on. Mine do it on the left side. Tap the dash and they all come back on.

2005 F350 CCLB Dually
Studded, deleted
5" straight piped
155/30's
KC Stage 1.5
Reg return
Beans sump to the stock pump
BPD FICM
Tuned by several...depends on my mood for the day.
6speedSD is offline  
 
post #4 of 4 (permalink) Old 02-26-2015, 02:27 AM
PSN Newb
 
unclemark's Avatar
 
Join Date: Nov 2014
Posts: 36
Re: Half of guage cluster doesn't light up

Quote:
Originally Posted by 6speedSD View Post
Sometimes a slight smack to the top of the dash will bring them back on. Mine do it on the left side. Tap the dash and they all come back on.

I have a few that will go dark on occasion and thats the fix for me.
unclemark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome