intermittent missing and sluggish throttle - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-20-2015, 05:46 PM Thread Starter
PSN Newb
 
Join Date: Feb 2015
Posts: 3
intermittent missing and sluggish throttle

New to 6.0 but not to diesels. I have done a pretty good bit of searching but can't seem to find what I am looking for. I have an 04 6.0 stock afaik with approx 260k. It ran fine when I bought it about 4 months ago. Recently it has started intermittently idling rough. The rough idle is accompanied by missing and sluggish throttle. I bought a scan gauge 2 and have been monitoring things. While the problem is occuring Ficm voltage never drops below 46.5. Ebp seems higher. Ect and eot delta gets higher but still within 15 degree limit. Icp doesn't respond instantly to throttle like it normally would.

I haven't gotten a chance to check fuel pressure but both fuel filters have been changed within last 2 months and have maybe 1000 miles on them. Last oil change was about 3k ago done by po. The engine never throws cel.

On a side note when I went to change fuel filters I found a plug disconnected just forward of fuel filter in valley pan. The truck was running fine then and I found nothing for it to plug into so I didn't worry about it.

Any ideas on where to start? I have not monitored ipr or egr while it is happening.
redneckaggie is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-25-2015, 05:03 AM
Fixing Broken Stuff
 
toolmangary's Avatar
 
Join Date: Jan 2009
Location: South Lyon Mi
Posts: 2,078
Re: intermittent missing and sluggish throttle

Your problem is most likely stiction, and with the miles you have a fresh set of injector will to wonders, as long as you use OEM injectors.

2015 Challenger HellCat Redline Red 8sp
1997 F350 4X4 CCLB PSD
2004 Jetta TDI
1999.5 Jetta TDI 11mm pump S7 PP764's 3bar MAP
1986 F350 CC Dually 6.9 ATS turbo lowered
1984 Mark VII 2.4 BMW Turbo Diesel
1970 Roadrunner 383 4sp
1970 Cuda 426 4sp Dana 60
1956 F100
toolmangary is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome